Tagged: 

Viewing 30 posts - 1 through 30 (of 34 total)
  • Author
    Posts
  • #437811

    OK, since the 4.1.2 WordPress update, my Enfold theme update will not work.

    An error occurred while updating Enfold: Could not create directory.

    It’s running on Azure, so no permission problems on the upgrade folder.

    Have tried deleting the upgrade folder, adding again, no deal. I can add files to the upgrade folder, so this is not the issue,

    I can update the theme via FTP no problem, but this is not ideal.

    I can update WP and plugins fine, it’s just the theme that is the problem. I don’t have any other other themes.

    It starts to unpack the upgrade zip, then just says Could not create directory.

    Please help!

    #438446

    Hi schoop!

    Thank you for using Enfold.

    Log out of the dashboard then remove browser cache or use another browser. Login again.

    Nice slider. :)

    Regards,
    Ismael

    #439624

    That didn’t work.

    Which folder is it trying to create?

    I may be able to stop the website, remove the folder and try again.

    #439917

    I have exactly the same error and tried the using an uncached browser workaround. still no luck.

    #440853

    Hey!

    Make sure that you didn’t reach your site’s quota for disk space. Clean up the server space then test it again. Add this line in the wp-config.php file:

    define('FS_METHOD','direct');
    

    If it doesn’t work, try to change the file permission of the wp-content folder to 775.

    Regards,
    Ismael

    #462062

    None of this helped me.

    #462072

    I’m also having the same problem, the version of my wordpress is 4.2.2, I am trying to update the theme enfold version 3.1.5 to 3.2.1, but has an error “An error occurred while updating Enfold: Could not create directory. “duranto the decompression process.

    It was changed the settings from this server, already checked the permissions, and earlier, the problem did not occur.

    #462073

    How can I update manually without changing my settings?

    #462074

    Hi!

    Please refer to video tutorial here – http://kriesi.at/documentation/enfold/updating-your-theme-files/

    Best regards,
    Yigit

    #462075

    My Themeforest information is correct. Manually updating is not my preferred method.

    #462134

    Hey!

    The “Could not create directory” error is coming from WordPress and indicates that the issue is server-related, try the following:
    http://publishingwithwordpress.com/how-to-solve-wordpress-could-not-create-directory/

    Best regards,
    Josue

    #464291

    I’m on Windows not Linux.

    #464312

    Hey!

    In that case you’d need to ask your server provider support to make these permissions changes.

    Regards,
    Josue

    #464665

    Hi. I too am getting the same error as other users when trying to upgrade Enfold. I need for this to work in the theme, not manually on the server as the client I am developing the site for will not know how to do that with future versions. Please advise asap as we are launching the site soon.

    #464668

    The wp-content folder has the correct permissions. All plugins and other themes upgrade fine.

    #465182

    Having the same problem, Windows Server 2008 R2, WP 4.2.2, Enfold 3.2 to 3.2.2 on a machine to which I have full admin access.

    What directory is it trying to create, and where is it trying to create it??? If I had that info, I could check the permissions and ownership of the directory in question.

    #465293

    The issue occurs when unpacking the zip theme file on Azure.

    I too have no issue with updating plugins or other themes. It downloads the zip OK, it is when it tries to unpack it the problem occurs.

    There are no permission issues. It started to happen when 4.2 was launched.

    What is the length of the filename that the zip is trying to unpack? There may be a restriction on length of filename in Azure.

    #465835

    Hi!


    @schoop
    : Themeforest or envato handles the servers where you download the files from including the items’ file name. I’m not sure if there is any file name length restriction or if that limitation even exist but you can try to contact the envato support about that info.


    @scotthco
    : When you try to update the theme, the file directory should be included in the error log. If you check the php info page of your server, that directory is the value in the upload_tmp_dir directive.

    If you can’t update the theme in the updates panel, please update it via FTP.

    Best regards,
    Ismael

    #467796

    Every other theme updates fine. Every plugin updates fine. With so many problems about the same issue when permissions are fine, perhaps you should look into it further instead of suggesting things we’ve clearly already tried.

    #468785

    Hi!

    @DJQuad: Give us the ftp details. We’ll check the directories. Did you check the error logs? If you’re in a rush to fix a server related issue that we don’t have any access to, please hire a freelance developer or consult a server administrator. Thank you.

    Regards,
    Ismael

    #468836

    @ismael @Josue please check this post: https://kriesi.at/support/topic/very-slow-admin-back-end/ there are lots of things going strangely wrong.

    #469212

    Here you go.

    #469465

    Hey!

    @DJQuad: What is the folder permission of the killshotservers.com folder? I checked it via FTP but I can’t see the permissions info. If it is set to 711, please set it to 755. Do this for all folders inside that particular folder. If possible, please create a php info page, we would like to check it. What is the actual that you get when you try to update the theme? Is this it?

    An error occurred while updating Enfold: Could not create directory.


    @Heathcliffe
    : Envato reported that there are an ongoing DDoS attacks on the marketplace causing random site outages. For the meantime, please remove the API key in the updates panel.

    Best regards,
    Ismael

    #470432

    It’s the Windows equivalent of 755. Below is phpinfo.

    #471367

    Hey!

    A lot of forum threads, which seems to be having the same issue, suggested that you have to set the file permission to 775 or 777, basically granting full access to all user groups temporarily. Run the auto update then change the permission back to normal.

    OR

    This is just a wild guess, I’m not really sure if this is really going to help but please give it a try. Try to look for this directory or folder: C:\Windows\temp

    Right click on the folder, click properties then disable the Read Only attribute. Restart the server then try the auto update.

    Let us know if it helps. Aside from that, I don’t think we can provide any more useful information. I’m sorry if we can’t provide a knowledgeable or direct solution. Please contact a server administrator or hire a freelance developer. You can find someone here: http://kriesi.at/contact/customization

    And again, you can still update the theme via FTP.

    Cheers!
    Ismael

    #472125

    I’ve already tried everything you’ve suggested the first time you’ve suggested it.

    Rather than suggesting we “hire a freelance developer”, this is very simple. Get a Windows host and try to update the theme. Your theme is the only theme (or plugin for that matter) that is having issues.

    #472149

    Hey!

    I don’t think I suggested any of those before. Granting full access to folder or files is not safe so we will not advice it unless necessary. Did you even try it? Actually, hiring someone who is more familiar with server configurations will help in this case.

    Cheers!
    Ismael

    #475200

    Hey Ismael:

    I believe I’ve tried all suggestions here to no avail. Nothing is being logged to the php error log, and I even turned on WP debugging, and nothing is being logged there either. And yes, I did remember to add define('WP_DEBUG_LOG', true); to wp-config.php. I even tried changing upload_tmp_dir to something other than C:\Windows\temp and setting appropriate permissions. Apparently Win 7 (Pro anyway) is touchy about who gets permissions on that folder C:\Windows\temp.

    It would be super helpful if I actually had a way of finding out precisely where the folder is being created and what its name is.

    Scott

    #475383

    Hi!

    It would be super helpful if I actually had a way of finding out precisely where the folder is being created and what its name is.

    I asked that question myself so I asked Kriesi and then he told me basically the same answer that is provided here: http://halfelf.org/2011/how-the-wordpress-upgrade-works/

    The article said that there are two kind of auto update, core and child. Child is the theme and plugin updates where they create a folder called “upgrade” inside the wp-content folder. The problem is, I’m not really sure if the envato protected api is using the same update process.

    Cheers!
    Ismael

    #476172

    I’ve had the same issue the last few updates, but wasn’t sure if it was WordPress or Enfold related. However, recently I’ve done a major batch of updates and Enfold is the only update I’ve experienced this issue with, on both live site and my local laptop copy I use for plugin development.
    Doing a process monitor exercise, I’ve found that during the update process, the file created in the temporary upload folder, in my case C:\Windows\Temp is named:
    enfold.zipAWSAccessKeyId*******************Expires1437422162Signature*****************-***********-3Dresponse-content-dispositionattachment-3B-filename-3Dthemeforest-4519990-enfold-responsive-multipurpose-theme-wordpress_theme.tmp
    (AccessKeyId and Signature obscured, but at correct length)
    this then breaks windows file system path length limits when an attempt is made to move it into the PHP working path.

    The URL requested for the update was:
    https://s3.amazonaws.com/marketplace-downloads.envato.com/files/140862862/enfold.zip?AWSAccessKeyId=*******************&Expires=1437422162&Signature=*****************-***********%3D&response-content-disposition=attachment%3B+filename%3Dthemeforest-4519990-enfold-responsive-multipurpose-theme-wordpress_theme.zip

    It’s clear that this is the updater attempting to use the entire URL passed to Envatos AWS service, including the query string, as the filename, instead of just enfold.zip. This almost certainly appears to be an updater issue within Enfold, not a configuration issue, but will only show up on Windows hosts where path length comes in to play.

    * Edit *
    It may be possible to quick fix this by shortening the zip file lodged with Envato if possible? Change it from themeforest-4519990-enfold-responsive-multipurpose-theme-wordpress_theme.zip to something shorter perhaps? That may fix it for some people depending on WordPress installation paths.
    I have also raised this as a bug with the WordPress Core dev team, with the suggestion that the download_url() function in WordPress removes query strings from URLs before creating temporary files based on them.

    Many thanks,
    Richard

    • This reply was modified 9 years ago by Hyperopic.
Viewing 30 posts - 1 through 30 (of 34 total)
  • The topic ‘An error occurred while updating Enfold: Could not create directory.’ is closed to new replies.