Viewing 30 posts - 1 through 30 (of 30 total)
  • Author
    Posts
  • #468471

    SITE: TheArtOfAdvice.com

    In the past day or two I have noticed extreme slowness with the back-end of my site. Who whole back-end is slow but the biggest problem is when go to dashboard –> updates. It does not even resolve the page. The front-end is totally fine but the back-end is unbearably slow.

    I have:
    – Reinstalled WordPress
    – Reinstalled Enfold with the latest version from ThemeForest
    – Deactivated/reactivated all plugins

    And still nothing.

    I’ve checked the server and CloudFlare and everything appears fine.

    I am running a few other sites on my virtual server and they are running just fine.

    One admin error keep popping up in the logs:

    [05-Jul-2015 05:36:46 UTC] PHP Warning: Invalid argument supplied for foreach() in /home/[USERNAMEREMOVED]/public_html/wp-content/themes/enfold/framework/php/auto-updates/class-pixelentity-theme-update.php on line 49

    I’ve tried to troubleshoot this on my own for a few hours and wanted to enlist some help.

    Thank you!

    • This topic was modified 5 years, 2 months ago by  JustinGreis. Reason: Added site name
    #468567

    I have the same exact problem and error. We need this resolved asap and it clearly looks like it’s an Enfold problem.

    My Steps:

    I have:
    – Reinstalled WordPress – I Actually deleted all wordpress files and reupload the latest version.
    – Reinstalled Enfold with the latest version from ThemeForest through FTP
    – Deactivated/reactivated all plugins

    And still nothing.

    #468570

    I’ve been playing around with the site and trying to troubleshoot all night. Can’t seem to make any progress but I have narrowed the issue to the fact that I cannot navigate to ‘update-core.php’

    The site seems to timeout and the only error I seem to get is the one related to: class-pixelentity-theme-update.php

    HELP PLEASE!

    #468573

    Yes. update-core.php is where mine is stuck. I waited for ever to receive the the error “/themes/enfold/framework/php/auto-updates/class-pixelentity-theme-update.php on line 49”. Most of the time I did not get the error and the whole site shutdown to get a “503 service unavailable” .

    #468574

    Yep! Same here.

    #468575

    We’re noting the very same issue too … site is coming to a grinding halt because of it !

    #468577

    Still not resolved but…

    I went to: /public_html/wp-content/themes/enfold/framework/php/auto-updates/class-pixelentity-theme-update.php

    …and checked out the file…

    There was a bit of commented out “debug code”

    // to debug
    // set_site_transient(‘update_themes’,null);

    So I uncommented out the code…

    // to debug
    set_site_transient(‘update_themes’,null);

    and then the WHOLE ADMIN SITE came to a screeching halt, not just the update core.

    When I commented the code back, the rest of the admin site came back up.

    Still unresolved but trying to troubleshoot.

    #468578

    The same in:

    get by peer

    Warning: Invalid argument supplied for foreach() in /www/htdocs/w0114a7e/wp-content/themes/enfold/framework/php/auto-updates/class-pixelentity-theme-update.php on line 49
    Recv failure: Connection reset by peer
    Warning: Invalid argument supplied for foreach() in /www/htdocs/w0114a7e/wp-content/themes/enfold/framework/php/auto-updates/class-pixelentity-theme-update.php on line 49
    Zum Hauptinhalt springen Springe zur Werkzeugleiste

    I bought here 4 x ” Enfold ” and get in the WordPress Admin Error Messages for Enfold . That can not be so well.
    Ich habe hier 4 x “Enfold” gekauft und bekomme im WordPress-Admin Fehlermeldungen wegen Enfold. Das kann doch wohl so nicht sein
    ——————————————————————————————————-
    I comming no longer on the Dashboard for updates on WordPress. The page loads and loads and loads . After a long time I get the following error message :

    et by peer
    Warning: Invalid argument supplied for foreach() in /www/htdocs/xxxxxx/wp-content/themes/enfold/framework/php/auto-updates/class-pixelentity-theme-update.php on line 49
    Recv failure: Connection reset by peer
    Warning: Invalid argument supplied for foreach() in /www/htdocs/xxxxxxx/wp-content/themes/enfold/framework/php/auto-updates/class-pixelentity-theme-update.php on line 49
    Zum Hauptinhalt springen Springe zur Werkzeugleiste

    This I have noticed only now , since I have to drive a few updates.

    Dieses habe ich erst heute bemerkt, da ich einige Updates fahren muss

    Internal Server Error
    The server encountered an internal error or misconfiguration and was unable to complete your request.
    
    Please contact the server administrator,  (Email address hidden if logged out)  and inform them of the time the error occurred, and anything you might have done that may have caused the error.
    
    More information about this error may be available in the server error log.

    I use WordPress 4.2.2 and 3.2.2 Enfold
    Ich benutze WordPress 4.2.2 und Enfold 3.2.2

    #468581

    I fixed it. Goto Enfold theme options -> Theme Update. Take out your “Your Themeforest User Name” and “Your Themeforest API Key”. Leave them blank. After your save this, you should be able to go to Dashboard -> Updates ……real fast now.

    I’m assuming I might have revoked an api key and generated a new one in the past? I don’t know. So I went back to themeforest and copied the api key and username and pasted it in the “theme update page” and it crashed again. I just assume to leave it blank.

    #468582

    samharry – that worked for me too.

    I can now get to the update-core.php page.

    Obviously there is something wrong with the theme update functionality.

    Would love to hear from someone at Kriesi about this issue.

    #468583

    Also, I am unsure if this is related but the Vimeo script that was fixed with the last release does not seem to work anymore. It is just displaying my fallback static image rather than the vimeo video. Again, not sure if this is related but just noticed it now that I am done troubleshooting the update-core.php issue.

    #468604

    I’m also getting a white screen of death when updating posts. This never happened before this theme update. We didn’t install any other plugins and reinstalled WordPress.

    #468606

    samharry –

    Savings/updating posts is slower than normal and certainly a lot slower than on other sites on my server using a different theme. I updated a few posts and it did take much longer than typical but it did eventually work.

    The white screen of death has happened to me once before… Not sure if it’s the same root cause but in my case the iThemes Security (formerly Better WordPress Security) File Change Detection feature was bombing out. I eventually disabled that one feature and it worked. Not the case for me this time.

    #468608

    Hey all, just searched for class-pixelentity as I have the same problem. When I first logged into my site, I saw that the dashboard was saying there was an update available, but it was not in my plugins so assumed it was the theme (although the theme was not showing there was an update). BUT I noticed my licence key was not my normal licence key, I have a few licences for Enfold and the key wasn’t any I had created / purchased.
    I entered my correct key and a few times have the following message:

    Empty reply from server
    Warning: Invalid argument supplied for foreach() in /var/sites/r/recoveryplaces.org/public_html/wp-content/themes/enfold/framework/php/auto-updates/class-pixelentity-theme-update.php on line 49
    
    Warning: Cannot modify header information - headers already sent by (output started at /var/sites/r/recoveryplaces.org/public_html/wp-content/themes/enfold/framework/php/auto-updates/class-envato-protected-api.php:345) in /var/sites/r/recoveryplaces.org/public_html/wp-includes/pluggable.php on line 1196
    #468617

    Sweet. I will give that a try. I have that featured checked on iThemes. Thanks Justin

    #468738

    same to me (http://flymotions.com).
    blank themeforest user name an API key do the (only workaround) job. update page can be loaded.

    #469127

    I have the same problems, same WP error messages and same pixelentity error in my hosting cpanel error logs – have tried all the same steps as the first few posters, nothing has resolved it.

    This appears to be an Enfold problem as I have it across all my purchased Enfold sites. Running latest versions of WP and Enfold.

    A response from the staff would be great!

    #469151

    Removing API and username is a temp fix for me aswell. Would like auto-update to work though, so please let us know when you’ve fixed it Enfold! Thanks,

    Matt

    #469155

    I also have the same problem

    reset by peer
    Warning: Invalid argument supplied for foreach() in ……../public_html/it/wp-content/themes/enfold/framework/php/auto-updates/class-pixelentity-theme-update.php on line 49

    #469160

    profumopuntoit – removing the themeforest API key and username from Enfold>>Theme Update should fix it temporarily…

    #469167

    Thank you meanster99

    #469313

    Same problem here – also latest WP and Enfold on multiple sites. Removing Themeforest user name and API key fixed it. Any idea on why this is happening? Thanks.

    #469317

    Hey there – I had same issue. Went to hosts – wpengine.com – and they’ve diagnosed the issue – it’s ENVATO API. Hence why it seems to fix itself if we get rid of the API code for updates.

    Hope this helps –

    We’ve noticed an influx of 502 errors on our platform that appear to be related to themes utilizing the Envato API. This includes most themes purchased through themeforest. API calls from those themes to the Envato API are timing out, which is causing the 502 errors many of our customers are experiencing.

    We’re in contact with Envato concerning this issue, but at this time 502 errors may still be an issue for any WordPress site utilizing a themeforest theme.

    We have also updated our Status blog with the above information at the following post, https://wpenginestatus.com/themeforest-theme-502-errors/. Please check there for updates in regards to this issue.

    #469395

    Hi!

    Sorry for the late reply, I don’t think any of the moderators have seen this thread yet because each time someone replies it’s sent to the back of our support queue. From reading the thread I understand that removing the Envato data solves the issue? I know there has been some problems with the Envato API lately so hopefully it will be fixed soon and removing the Envato details should only have to be a temporary fix.

    Regards,
    Rikard

    #469400

    Rikard – The temporary workaround of removing the username/API seems to work in the interim. I am hoping the API issues are resolved soon so we do not have to apply the updates manually. Keep us posted on what you hear about the resolution of this issue.

    #469423

    Hey!

    Envato is dealing with a DDoS attack, so we will have to wait for them to restore everything back to normal.
    http://themeforest.net/forums/thread/ongoing-ddos-attacks-on-envato-market-ftp-file-upload-affected/184299

    Best regards,
    Basilis

    #470028

    I put in my username and API key and things seem to be back to normal.

    :)

    #470485

    Hi!

    @justingreis Great! Thanks for your input :)

    Best regards,
    Yigit

    #475865

    Today I receive again:

    Failed to connect to marketplace.envato.com port 80: Connection timed out
    Warning: Invalid argument supplied for foreach() in /home/nicheper/public_html/en/wp-content/themes/enfold/framework/php/auto-updates/class-pixelentity-theme-update.php on line 49

    and no problem if I remove my credentials

    #476212

    Hi!

    Looks like the envato api is a bit unsteady. Unfortunately, this is not something we can fix on our end. Let’s hope that envato fix this issue immediately. We will close this thread for now. If you’re still having this issue, feel free to open a new thread.

    Regards,
    Ismael

Viewing 30 posts - 1 through 30 (of 30 total)

The topic ‘VERY Slow Admin Back-End’ is closed to new replies.