Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #1261644

    Jeffrey Trujillo

    Please help. I’m confused. My Enfold website (on WordPress.org hosted by GoDaddy) is getting “404: Page Not Found” errors on all pages except the home page. I am unable to edit and publish these pages from within WordPress.org. I reinstalled the newest WordPress, have the newest Enfold version, and tried reuploading avia-shortcodes folders via direct FTP (after seeing some other forum questions); but to no avail.

    WordPress’ automated email said it caught an error with Enfold. This is the page where the error was caught: http://www.tucson-therapist.com/wp-admin/post.php?post=821&action=edit

    WordPress version 5.5.3
    Current theme: Enfold (version 3.5.4)
    Current plugin: (version )
    PHP version 7.4.11

    Error Details
    =============
    An error of type E_ERROR was caused in line 489 of the file /home/jlongtail/public_html/wp-content/themes/enfold/config-templatebuilder/avia-template-builder/php/shortcode-template.class.php. Error message: Uncaught Error: Cannot use string offset as an array in /home/jlongtail/public_html/wp-content/themes/enfold/config-templatebuilder/avia-template-builder/php/shortcode-template.class.php:489
    Stack trace:
    #0 /home/jlongtail/public_html/wp-content/themes/enfold/config-templatebuilder/avia-template-builder/php/shortcode-template.class.php(443): aviaShortcodeTemplate->create_sortable_editor_element(Array)
    #1 /home/jlongtail/public_html/wp-content/themes/enfold/config-templatebuilder/avia-template-builder/php/template-builder.class.php(395): aviaShortcodeTemplate->prepare_editor_element()
    #2 /home/jlongtail/public_html/wp-includes/class-wp-hook.php(287): AviaBuilder->js_template_editor_elements(”)
    #3 /home/jlongtail/public_html/wp-includes/class-wp-hook.php(311): WP_Hook->apply_filters(”, Array)
    #4 /home/jlongtail/public_html/wp-includes/plugin.php(478): WP_Hook->do_action(Array)
    #5 /home/jlongtail/public_html/wp-includes/media-template.php(1467): do_action(‘print_media_tem…’)
    #6 /home/jlongtail/public_html/wp

    Installed plugins:
    XML-RPC Pingback
    Display PHP Version
    Envato Market
    Go Daddy Quick Setup
    Limit Login Attempts
    PHP Compatibility Checker
    UpdraftPlus – Backup/Restore

    Inactive plugins:*
    Really Simple SSL
    SSL Zen

    *Purchased SSL through GoDaddy after using these for a while.

    #1261727

    Hey Jeffrey Trujillo,

    Thanks for contacting us!
    The problem that you are having is compatibility between WordPress 5.5.3 and Enfold 3.5.4 (which is really an old version of Enfold, released in April 2016)
    You can check all the versions in our changelog: https://kriesi.at/documentation/enfold/changelog
    Please update to the latest version of Enfold and make sure to have a backup first.

    To update to the latest version of Enfold you can do the following:
    1. Login to ThemeForest and download the Enfold theme, right-click over the downloaded zip file and extract/unzip it.
    2. It should generate a new folder, open it and look for the enfold folder
    3. Right-click the enfold folder then zip it, here’s a tutorial on how to create a zip file in windows: https://www.howtogeek.com/668409/how-to-zip-and-unzip-files-on-windows-10/ (this should create enfold.zip
    4. Log in to WordPress as and Admin.
    5. Install and activate a maintenance plugin and put your site in Maintenance mode.
    6. Go to Appearance > Themes, switch to a default WordPress theme like TwentyTwenty then delete Enfold.
    7. Click on the ADD NEW button.
    8. Click on the UPLOAD THEME button.
    9. Click BROWSE and choose enfold.zip file
    10. Click the INSTALL NOW button and switch to Enfold or your child theme.
    11. Remove the maintenance mode then deactivate and remove the maintenance plugin.
    Once update is done, generate an envato token and register your theme so you can check for new updates and update it via theme options, check further information on this here: https://kriesi.at/documentation/enfold/theme-registration/

    Best regards,
    Nikko

    #1261845

    My apologies, Nikko. Since the message I’d received from WordPress, which I cut and paste from for the message above, I had indeed updated Enfold to Version 4.7.6.4, and it did not correct the issue. Can you log in and give it a look?
    p.s. I’d tried reverting to the older version of Enfold, along with a backup of the website from that time, though it didn’t correct the issue, so I went back to the newest WordPress and the newest Enfold. Thank you.

    • This reply was modified 2 weeks ago by  Jlongtail.
    #1261846

    See above reply #1261845

    • This reply was modified 2 weeks ago by  Jlongtail.
    #1262056

    Hi,

    Thanks for the update. I reset your permalink setting, then changed it back to your selected settings, and it’s working as it should after that. Please review your site.

    Best regards,
    Rikard

    #1262129

    It’s working! Thank you!

    #1262249

    Hi Jlongtail,

    We’re happy to hear that. :)
    Let us know if you need further assistance.

    Best regards,
    Nikko

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.