Viewing 27 posts - 1 through 27 (of 27 total)
  • Author
    Posts
  • #798903

    Hello,
    I see similar threads but I couldn’t find the solution

    Permalinks are working and also pagination in archives is working, only on blog home (using masonry layout) pagination bring to a 404 page

    We are for the moment on a Windows server and we have already the code below in web.config
    <rewrite>
    <rules>
    <rule name=”Main Rule” stopProcessing=”true”>
    <match url=”.*” />
    <conditions logicalGrouping=”MatchAll”>
    <add input=”{REQUEST_FILENAME}” matchType=”IsFile” negate=”true” />
    <add input=”{REQUEST_FILENAME}” matchType=”IsDirectory” negate=”true” />
    </conditions>
    <action type=”Rewrite” url=”index.php” />
    </rule>
    </rules>
    </rewrite>

    Thank you

    #799737

    Hey profumopuntoit,

    Here is an article that might help you:

    Best regards,
    Victoria

    #800091

    Please do not invite your client to add the code in the suggested link because it is incorrect in xml syntax and will certainly return 500 error and break all the website
    Better to suggest https://docs.microsoft.com/en-us/iis/extensions/url-rewrite-module/enabling-pretty-permalinks-in-wordpress
    And that code we have already in our web.config, as me mentioned before.
    Our permalinks are working correctly.
    It is only the blog home pagination which return a 404 error, category archive pagination is working ok as we mentioned in the private data link

    Thank you Mauro

    #800247

    Hi Mauro,

    Can you give us temporary admin access to your website in the private content box below, so that we can have a closer look.

    Best regards,
    Victoria

    #800272

    Yes sure thank you

    #800580

    Hi profumopuntoit,

    I wrote to my colleagues. They might have more knowledge and experience on the issue.

    Best regards,
    Victoria

    #801052

    ok thank you

    #801129

    Hi,

    It should be fixed now. I have replaced permalinks from:

    /index.php/%year%/%monthnum%/%postname%/

    to:

    /%year%/%monthnum%/%postname%/

    Hope this helps :)

    Best regards,
    Nikko

    #801131

    Now all posts return a 404 error!
    Please do not change our permalinks structure because we have hondreds of inbound links

    #801134

    I have reset the permalinks as before

    #801374

    Hi,

    Are you having some problem yet?

    Best regards,
    John Torvik

    #801443

    Yes
    clicking to http://www.profumo.it/blog/page/2/ returns still a 404 page
    Best regards
    Mauro

    #803237

    Hi,

    We are still not sure what’s causing the issue but if you’ll provide the FTP details, we’ll check it further.

    Best regards,
    Ismael

    #803812

    Ok thank you

    #804773

    Hi,

    We already have access to the WP dashboard. Please provide the FTP details as well. :)

    Best regards,
    Ismael

    #805053

    Here they are
    thank you

    #806022

    Yesterday I passed from pagination (as it was before) to “Load more” and it was working, but today it is not working again.
    It is not the first time that happen like this

    #807336

    Hi,

    Where are you hosting the site? The admin-ajax.php file are inaccessible or block by the server.

    Request URL:http://www.profumo.it/blog/wp-admin/admin-ajax.php
    Request Method:POST
    Status Code:403 Forbidden
    Remote Address:104.28.13.119:80
    Referrer Policy:no-referrer-when-downgrade

    Please contact your hosting provider.

    Best regards,
    Ismael

    #807575

    Hello,
    Server support says file permission is ok
    I updated wordpress and plugins and “Load more” issue is not there anymore (at the moment, but it comes and goes), but if I use pagination still I receive a 404 error.
    I am leaving with “Load more” but feel free to change and test
    Thank you
    Mauro

    #807576

    Quite strange is that file type is seen as “xhr”

    #807877

    Hi,

    It’s probably being blocked by your server after some time. You should ask them if this is the case. Is the site hosted on GoDaddy?

    Best regards,
    Ismael

    #808074

    maybe but why pagination is not working?
    No is a Windows dedicated server on one Italian provider, Serverplan

    #808840

    Hi,

    maybe but why pagination is not working?

    The “load more” button requires the admin-ajax.php file so it’s not going to work without the script. Please ask your hosting provider why the admin-ajax.php file is being blocked by the server. However, I’m not sure why the pagination is not working.

    Best regards,
    Ismael

    #881426

    I have the same problem.

    http://dspa.com.br/portfolio/ – Working
    http://dspa.com.br/portfolio/page/2/ – Not Working

    I cannot say if ajax-admin is working properly.
    So anybody can help me?

    #881634

    Hi assennato,

    Here is a thread for you to consider

    Best regards,
    Victoria

    #931716

    Hi, Victoria. Sorry I just saw now your reply.

    I already tried that, but I didn’t have any results with it. The problem persists.

    Could you have any light in this dark tunnel?

    #931828

    Hi assennato,

    Please, consider this
    https://docs.oceanwp.org/article/451-404-error-with-the-portfolio-pagination

    If you need further assistance please let us know.
    Best regards,
    Victoria

Viewing 27 posts - 1 through 27 (of 27 total)

You must be logged in to reply to this topic.