Viewing 12 posts - 31 through 42 (of 42 total)
  • Author
    Posts
  • #903479

    Yigit, thanks. I will try that though I have no way to test Safari since I only have windows equipment. The bigger issue with this latest 4.2.2 for me is that the ipad pro view reverts to mobile screen and displays mobile fallback image instead of displaying the video the way it did in 4.1.2. I imagine this is a screen breakpoint issue that could be (easily?) fixed with a little css?

    Thanks for jumping in, we’re glad you’re here!

    Rob

    #903531

    i went back on some test installations of mine to Enfold 4.1.2 or 4.0.5 ( i got both on a duplicator archiv) the troubles come definitly from WordPress 4.9. They changed the mediaelement scripts and many more – the poor WP Bakery Page Builder User f.e. those things do not work. etc etc. pp.

    So we are still relatively well. I can live with selfuploaded video to youtube till the next WP Update will fix those bugs.

    #903815

    Yigit,

    I google “background video safari wordpress bug” and only got one current result, this one from a theme that released a patch to fix it back in October. Is this bug something devs are working on? Safari is a major browser platform so we really need this functionality.

    https://churchthemes.com/update-fix-background-video-safari-11/

    Also I’m waiting for a response on the ipad pro issue above.

    Thanks!!!!

    Rob

    #906424

    Hi,

    Our developer have replied on the other issue

    which will be included on next versions.

    Thank you

    Best regards,
    Basilis

    #908724

    Hi everyone. Sorry but this one took longer.

    I was able to fix the issue on some level. “Only” did take me 10 hours to get to the bottom of this issue, which is actually two-fold :/

    The first problem (very technical): for some reason the API to the mediaelement video, which is usually passed as a javascript data object, is no longer passed in Safari. (might be a mediaelement bug, probably introduced with the latest WordPress update)

    I was able to circumvent that. It is now again possible to use the Video in Safari manually.

    The second issue is Safari itself and its new policy regarding autoplaying content. You can read more about it
    here: https://webkit.org/blog/7734/auto-play-policy-changes-for-macos/

    Long story short: a user can change which kind of autoplay is allowed (with sound, without sound, no autoplay at all) but if it is disabled there is no chance that we can force the video to play without user interaction. So if autoplay is disabled by the user in safari there is nothing we can do about it.

    Those fixes will be included in the patch tomorrow.
    Cheers!
    Kriesi

    #908730

    Hi, That’s good that you’ve been able to fix the issue. I look forward to seeing the patch tomorrow.
    If the user has autoplay disabled, what will the background video look like sites in Safari that use Enfold? Will it revert to an image instead or will it show a play button? Have you added code so that something will appear rather than a blank dark grey background?

    #908856

    Wow, Kriesi! Good to see you here! And thanks for the detailed explanation. I hope tomorrow’s patch is a success and we can put this one behind us and focus on all the great new functionality you’re building for our theme…. side bars that auto-hide, more mobile features…. can’t wait.

    Thanks,
    Rob

    #912017

    4.2.3 fixed the issues for me – thank you.

    I also like that the right column of the support website now tells us when the next Enfold version is coming out, and provides an easy link to the revision history. This is a step in the right direction after what I consider a very bad 2017 for Enfold.

    Thanks

    Rob

    #912032

    is there someone who can please try out the “video sidebar widget” with a self hostet video?
    in my system it is broken since 4.2.3 update. even with no caching active.

    i think the error regards to the class mejs-container because the calculated height
    ist overwritten by enfolds shortcode.css with height: 30px !important;

    example:
    https://vistano.com/ernaehrung/krankheit-ernaehrung/wie-lange-koennen-wir-ohne-essen-aushalten/

    greez
    rene

    • This reply was modified 1 year, 11 months ago by  isee.
    #912271

    Hi,

    @goldengate415 Thanks for your feedback Rob! :)

    @kinkel please go to Appearance > Editor and under CSS folder edit shortcodes.css file and find following code in line 5202

    #top .mejs-container{height: 30px !important;}

    and change it to

    #top .mejs-container{height: 30px;}

    Also, please make sure to flush cache.

    Cheers!
    Yigit

    #912332

    cheers Yigit,

    thanx for support…
    will you remove the !important in the next version?

    greez
    rene

    #912498

    Hi Rene,

    Yes, we will. You are welcome! Let us know if you have any other questions :)

    Best regards,
    Yigit

Viewing 12 posts - 31 through 42 (of 42 total)

You must be logged in to reply to this topic.