Viewing 23 posts - 1 through 23 (of 23 total)
  • Author
  • #1400491

    On one of my Enfold websites (see private content) I have 2 indentical (?) Google fonts loading:


    I use Open Sans on all my Enfold sites and normally there is just one Open Sans request, not two. I searched all theme options but can not find somethuing that causes this issue.

    Any idea why on this website 2 Open Sans fonts are loading?



    Hey Alwin,

    Thank you for the inquiry.

    Did you embed a Google Map or ReCAPTCHA in any of your pages? Where do you see the duplicated requests? Please provide a screenshot using imgur, savvyify or dropbox.

    Best regards,


    Hello Ismael,

    I have Google Map embedded on the Conbtact page, but I have that on all my websites without have the duplicated Google fonts requests.

    Here is a screenshot from my GTmetrix (same aplies when I run Google Pagespeed Insights tool):


    Please include an admin login in the Private Content area so we can be of more assistance.

    Best regards,


    Hello Mike,

    Please see private content


    Thank you for your patience, but the 2FA code doesn’t work and WordFence has locked me out, please disable WordFence and the 2FA so we can login and investigate.
    Please note that our Mods are in different parts of the world and on different time zones, anyone of us should be able to login and assist, so disabling the WordFence and the 2FA would help.

    Best regards,


    I understand the problem, but I am very concerned about the security of my clients’ websites.

    In the past it was no problem for Enfold support to log in with a WordFence 2FA code. I think the codes I gave you had expired so I created new 2FA codes for you (see private content)



    The other request for the Open Sans font seems to be coming from the Google map element, removing the element should also remove the duplicate request but that might not be an option for you. Odd thing is, the issue also happens on pages without the map. Did you add any customization in your child theme? Please activate the Appearance > Theme File Editor so that we can check the theme files.

    Temporarily, you can add this code in the functions.php file to disable the font output.

    add_action( 'init', 'ava_disable_google_fonts' );
    function ava_disable_google_fonts() {
        global $avia;
        $avia->style->print_extra_output = false;

    Best regards,


    I have removed the Google Maps element but it did not changend anything, still 2 fonts loading (I have set Google Maps back now).

    I have activated the Theme File Editor for you guys and also include some new 2FA codes in the private content box below :)

    Thanks for the help!




    Thank you for the update.

    Looks like the issue occurs when the font for the heading and body text is the same. To fix the issue temporarily, please select a different font for the heading and body text in the Enfold > General Styling > Fonts panel. You can also add the action hook that we provided above in the functions.php file.

    add_action( 'init', 'ava_disable_google_fonts' );
    function ava_disable_google_fonts() {
        global $avia;
        $avia->style->print_extra_output = false;

    Best regards,


    Hello Ismael,

    I have the same font for the heading and the body text on several Enfold websites without this issue, so I don’t think this is causing this issue.

    But I tried and have set Roboto as the font for the headings. The result is that 3 Google fonts are now loaded; 1x Roboto and still 2x Open Sans…

    One other thing I don’t understand: when I run my other websites with the same settings (so Open Sans set for both the headings and the body text) in GTmetrix I see only 1 download for Open Sans in GTmetrix. So that all looks fine, however when I look in my browsers Webdevelopers Tools/Network/Fonts I see multiple times the Open Sans font on all my websites. The only website that is showing 2 downloads for Open Sans in GTmetrix is the one this topic is about.

    For example https://www.greenconnections.nl. In GTmetrix I see only one download for Open Sans, but in Webdeveloper Tools I see Open Sans downloaded twice?

    https://kriesi.at/ is also using Open Sans. In Developer Tools I see multiple downloads for the same Open Sans font here also?

    • This reply was modified 1 week, 3 days ago by Alwin.

    first: can you remove this from ismael – i used that code long time to do the same thing – but i recognised on some pages that i update to the latest php Versions that it might come into conflict.

    function my_output_google_webfonts_script( $activate ){
      return false;
    add_filter( 'avf_output_google_webfonts_script', 'my_output_google_webfonts_script', 10, 1 );

    instead of:

    function enfold_customization_switch_fonts() {
        global $avia;
        $avia->style->print_extra_output = false;
    add_action( 'init', 'enfold_customization_switch_fonts' );

    of topic for the one public link:
    second: – besides the page link (i do not see as participant) where your fonts are loaded : i see on the other page that there is no Consent to any of your features you use for that page.

    third: i can not see any @font-face rule in your css – did you upload the open sans font to the font-manager of Enfold ?

    next: the google maps could not cause that font-loading with open sans. Google Map loads “Roboto” and “Google Sans Text”
    maybe one of your other Google Things ( Analytics etc. )
    if you want to hamper loading of these fonts for maps :
    add_filter( 'avf_gmaps_no_google_fonts', '__return_true' );


    Next – do you use the advanced Layerslider on that page?
    The layerslider has its own google font support – have a look if that could be the reason:
    on layerslider options page – see on top right that gear : click – and see if there is google font support activated.


    Hello Guenni 007,

    Thanks for your help!

    – I don not use the advancend Layerslider at all, I have disabled it in Enfold settings/Layout builder/Integrated (Bundled) LayerSlider Plugin and even enabled Remove Theme plugins files and slides. I do use the Full Width Easyslider.

    – On greenconnections.nl I did upload Open Sans to the Enfold font manager some time ago, trying to host Open Sans locally. But I delcided to not host the font locally and deleted the Open Sans from the Enfold font manager, I just doubled checked on my host file manager and see no Open Sans font in the Enfold font manager.

    – I did not try the code from Ismael at all

    – What exactly is your code going to do?

    function my_output_google_webfonts_script( $activate ){
      return false;
    add_filter( 'avf_output_google_webfonts_script', 'my_output_google_webfonts_script', 10, 1 );

    @ Guenni007; how do you explain:
    https://kriesi.at/ is also using Open Sans. In Developer Tools I see multiple downloads for the same Open Sans font here also?

    Also, on the page we are right now (kriesi/support/this topic) I see the exact Open Sans font is loaded 3 times (in Developer Tools)?

    Also, on experimentkrewerd.nl, I changend both Header and Body font in Enfold settings from Open Sans to Roboto, just to see what happens then. Well, now the Roboto font gets downloaded twice… So it seems that the issue is not related to the Open Sans font specific?

    (I set the whole site back to Open Sans now)

    • This reply was modified 1 week, 2 days ago by Alwin.

    where do you exactly see that f.e. kriesi.at or your experimentkrewerd.nl does load Open+Sans twice
    there is once the script that decides if the font could be loaded – if there is a consent.
    so – if (cookie_check && !silent_accept_cookie) … and inside a lot of if clauses that has allow_continue = false next – only if (allow_continue) = true then load font.
    the next line in head it loading the font itself.

    So what you could say is that kriesi and your site do not respect the cookie consent setting. Or you have set them incorrectly. Or when I look at Krisie.at, no value is placed on GDPR. Because without having rejected or agreed to anything, a huge list is displayed which are all not GDPR-compliant.


    The safest way to deal with the font issue in terms of the GDPR is to host it yourself.
    And that’s exactly what this code from Ismael or the alternative filter from me is for. It prevents the embedded handling of Enfold with Google Fonts.
    Then you had to upload via Enfold Font Manager your Open Sans Font – and choose that font ( selfhosted Fonts are at the end of the fontlist ) in Enfold Font Options dialog.


    I don’t know how strictly the General Data Protection Regulation is applied in the Netherlands. I didn’t want my clients to have to fight a civil suit. Google Analytics is one thing that is absolutely not GDPR compliant and can only be loaded after consent. An afterward option to install a gaoptout addon is nice but even that is not GDPR compliant: first consent – then load



    About experimentkrewerd.nl please see GTmetrix reports and look at Fonts:

    And exprimentkrewerd.nl in Developer Tools:

    And kriesi.at in Developer Tools:

    About GDPR, I’m looking into this and I’m also looking for Google Analytics alternatives (I’m testing PiwikPro now, Plausible also seems to be a good option).

    Thanks for all your help on this forum :)

    • This reply was modified 1 week, 1 day ago by Alwin.
    • This reply was modified 1 week, 1 day ago by Alwin.
    • This reply was modified 1 week, 1 day ago by Alwin.

    these are not identical the same fonts:


    if you upload those files to : https://wakamaifondue.com/beta/
    you see that the first one is a open sans regular (45kb) – the second one is too a open sans regular but with different localisation:
    Catalan, Marshallese, Macedonian, Romanian; Moldova, Navajo, Romanian, Serbian, Undetermined; North American Phonetic Alphabet and Undetermined; International Phonetic Alphabet.
    It only has special cyrilic characters:

    Why there is that additional character set loaded – i could not imagine.

    Next – i will look now to kriesi.at – but i guess that these three fonts are the font-weights light, regular and bold.


    that screenshot of kriesi.at dev tools – what browser is it? Chrome?

    on kriesi too these are different unicode-ranges
    and once – there you are right: different sources googleapis and gstatic – that is not neccessary.


    The screenshot ios from the Edge browser, so yes Chrome.

    I wil take a deeper look at the other Open Sans font with cyrilic characters on my website.


    but that’s already complaining on a very high level, isn’t it? Gtmetrix values of nearby 100% ;)
    A TTBF at 83ms – that are top values – so what ?
    As I said, I would rather worry about the compliant GDPR implementation.

    for example now – my results on top are nice too – but why does it wait so long after everything is loaded to load the last 30kb of the favicon? a good 200-300ms pass before loading the last file. And this caused a “bad” TTLB value.


    Haha, well, all my websites have an almost 100% score in GTmetrix, which is not that difficult in itself.

    But indeed, the favicon.ico file is always loaded last and there is always a lot of time between loading the penultimate item and the favicon.

    Probably an Enfold thing? I just uploaded a favicon in the relevant Enfold settings.

Viewing 23 posts - 1 through 23 (of 23 total)
  • You must be logged in to reply to this topic.