Tagged: 

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #1270587

    Hello,

    on my site the YouTube Videos are not shown inside a color section on top of the sites.
    A few weeks ago it worked and it is still working on the English version (WPML).
    On top I recognized that then I insert the standard video widget, the video is only showing through an hyperlink to YouTube.
    Do you have any idea?

    Thanks a lot!

    Best,
    Sven

    #1270760

    Hi Sven,

    Please send us a temporary WordPress admin login and login URL so that we can have a closer look. You can post the details in the Private Content section of your reply.

    Best regards,
    Rikard

    #1270863
    This reply has been marked as private.
    #1271035

    Hi Sven,

    Thanks for that. I see that you have set the page in question as your custom 404 page in the theme options, could you try setting a different one to see if that makes any difference please? If not then please try installing this plugin: https://wordpress.org/plugins/enable-jquery-migrate-helper/, then set the jQuery version to 1.12.4 in the plugin options.

    Best regards,
    Rikard

    #1271097

    Hey Rikard,

    I tried both solutions, but it is sill not working. Any idea?

    Best and thank you very much!

    Sven

    #1272099
    This reply has been marked as private.
    #1272896

    Hi Sven,

    I’m very sorry for the late reply. I haven’t been able to find a solution for your problem unfortunately, but I’ll ask the rest of the team to have a look as well. Please reply to this thread once you have read it, so that it gets added back to our support queue.

    Best regards,
    Rikard

    • This reply was modified 1 month, 2 weeks ago by  Rikard.
    #1273339
    This reply has been marked as private.
    #1273872

    Hi,

    Sorry for the troubles. We created a private test page with a color section and applied the Youtube video to it as background, and the video plays automatically when we set the Enfold > Privacy & Cookies > Cookie Handling > Default Cookie Behavior to the first or second option. When we checked, it is set to the third option, so any external scripts including those required by media files or external services will not load without user consent.

    Best regards,
    Ismael

    #1274324

    Hey Ismael,

    thank you for your testing.
    Unfortunately it is still not working, when I changed the default to Opt out or the first option.
    Did you get it work? Very frustrating :-(

    On top I don’t know why it stop working, few weeks ago it worked fine with opt-In. In Germany we have to use opt-in because of the DSGVO. So it is no alternative to use an opt-out method.

    Thank you for your help,

    Sven

    #1274336

    i do have on my htaccess file a lot of security header entries – and i do sometimes forget to allow frame-src etc for google ( youtube) etc.
    some security plugins will do that too! and maybe those contents from outside your site are blocked.
    you can look if this is the matter by opening the developer tools of your browser and look into : developer console.

    _____________
    something like this:

    # Extra Security Headers
    <IfModule mod_headers.c>
    Header set X-XSS-Protection "1; mode=block"
    Header always append X-Frame-Options SAMEORIGIN
    Header set X-Content-Type-Options nosniff
    Header set Strict-Transport-Security "max-age=63072000; includeSubDomains; preload"
    Header set Referrer-Policy no-referrer
    Header set Feature-Policy "camera 'none'; microphone 'none'; payment 'none';"
    Header set Content-Security-Policy "default-src 'self'; frame-src 'self' https://www.google.com/ https://www.youtube.com/ https://www.youtube-nocookie.com/ https://player.vimeo.com/; frame-ancestors 'self'; script-src 'self' 'unsafe-eval' 'unsafe-inline' https://www.google.com/ https://maps.googleapis.com/ https://www.youtube.com/ https://www.gstatic.com/ ; style-src 'self' 'unsafe-inline' https://fonts.googleapis.com/; img-src 'self' data: https://ps.w.org/ https://maps.gstatic.com/ https://maps.googleapis.com/ https://khms0.googleapis.com/ https://khms1.googleapis.com/ https://lh3.ggpht.com/ https://cbks0.googleapis.com/ https://lh3.ggpht.com/ https://geo0.ggpht.com/ https://geo2.ggpht.com/ https://geo1.ggpht.com/ https://geo3.ggpht.com/ https://repository.kreaturamedia.com/ https://de.gravatar.com/ https://secure.gravatar.com/  ; font-src 'self' data: https://fonts.gstatic.com https://fonts.googleapis.com/"
    </IfModule>
    #1274363

    Hey Guenni007,

    thank you for your idea. I tried to solve the problem with your way, but it is still noch loading. But I understand the idea behind this.

    It has something to do with the cookie because if I disable all cookie notice provided by enfold it worked fine.
    It is logical that BEFORE accepting the cookies the YT videos are blocked, but AFTER accepting it should run. I think the fault is here.
    I try a third party cookie notice, but I think I am not the only guy who has the problem…

    Best,

    Sven

    #1274548

    Hi,

    When we checked the Default Cookie Behavior settings and it is once again set to the third option. You have to set it to the first or second option if you want the video to play automatically on page load, else, users will have to toggle the privacy options first, make sure that videos from Youtube are enabled, then reload the page before they will be able to see the video.

    but AFTER accepting it should run.

    It will not start working automatically after accepting the cookies — users have to REFRESH the page first. There is also an option where you could set the page to refresh automatically once the user accepted the cookie. It is in the same panel as the Default Cookie Behavior, just look for the Advanced Options right at the very bottom of the panel and configure the Auto Reload Page settings.

    Best regards,
    Ismael

Viewing 13 posts - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.