Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #306036

    Hello,

    I just installed the WordPress SEO plugin on my website and I am facing some challenges with the SEO Description, sometimes it gives me a content that is absolutely not corresponding to anything of what I am trying to do. Fishing some dummy content such as: Lorem ipsum dolor sit amet and naming the page link such as.

    I figure out for the Static page that I have to change it on the WordPress settings but not in Enfold, but about my other pages where I would like to have the POST-Slider, it is not working. When I remove the POST-Slider then it does…

    Please can you help me out?

    I am using the latest WordPress SEO plugin 1.5.5.3

    Thank you.

    #306087

    Hey resultsaccelerated!

    Thank you for using Enfold.

    Can you please give us an example on pages where this is happening? Did you add the descriptions on the yoast seo panel for each page or post?

    Best regards,
    Ismael

    #306138
    This reply has been marked as private.
    #306450

    Hi!

    You can insert a custom description text into the “Meta Description” field if the auto generated seo description doesn’t return the right content: https://www.clipular.com/c/6257239794909184.png?k=c2mZn14W6i2Mw-p3QqKL-_olCHA
    Yoast SEO will read the content of all shortcodes/template elements and because you didn’t delete the demo posts: http://www.worldwiderunners.com/wp-admin/edit.php it also reads the demo “lorem ipsum” text if you add the post slider to the template.

    Regards,
    Peter

    #306539

    Dear Peter,

    The problem I have is that when I change the meta and also add some keywords, it does keep my keywords in the settings, and changes the url to something related to the POST and not to the Page.

    My issue is for example if I have the homepage where I want to create the meta with keywords based on the page content and not on the Post- Slider then I can’t…
    Or there is a trick that I might not be aware of.

    Thanks again for the help.

    Best.

    #307180

    Hey!

    Please update the theme to the latest version (2.9.1).

    Best regards,
    Josue

    #307798

    Just did it and it still didn’t solve my problem.

    #308662

    Hi!

    In fact it seems to be a bug with the latest Yoast SEO plugin version. Another user contacted the Yoast support team and they suggested following (temporary) fix unril they release an update:

    For the moment, I’d recommend that Enfold make an announcement on their home page and advise that customers that who have installed wp-seo 1.5.5.3 fall back to version of WP-Seo 1.5.5 that can be found on https://github.com/Yoast/wordpress-seo/releases.

    The process to fall back is easy.
    1) download 1.5.5
    2) In WP I’d recommend an export of your WP-SEO settings in 1.5.5.3 (just in case)
    3) Upload via FTP v 1.5.5 into plugin folder
    4) In WordPress Deactivate Version 1.5.5.3
    5) In WordPress Activate version 1.5.5
    6) Goto pages that you are using Enfold ‘Blog Content’ and dbl check that they have proper SEO meta description content and not imported content that comes from the ‘bug’. Rewrite Yoast SEO metadescription, keyword, permalinks, slugs as needed. This bug is a bad one, you may need to really clean up your page.
    7) Resubmit page link to Google webmaster tools/Fetch as Google. Your pages that have been corrupted by this bug, your SEO is incorrect, and you have to be re-crawled, after you have updated step#6

    (ref: https://kriesi.at/support/topic/wordpress-seo-plugin-1-5-5-3-breaks-enfold-page-w/ )

    Best regards,
    Peter

    • This reply was modified 9 years, 11 months ago by Dude.
    #308715

    Great, I’ve done the change and it solved my problem.
    Hopefully this won’t happen in the new update.

    Thank you so much for taking the time to look into it.
    I really appreciate the effort!!!

    Have a great day.

Viewing 9 posts - 1 through 9 (of 9 total)
  • The topic ‘Yoast WordPress SEO problem with Page with POST.SLIDER content.’ is closed to new replies.