Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #991284

    Hi,
    I have added a font to my Enfold child theme. I am using WPML.org for multilanguage of my site.

    For German language (basic language in WPML settings) my CSS works fine:

    .single .post-entry h1 {
       font-family: 'Parisienne','Helvetica Neue',Helvetica,Arial,sans-serif;
    }

    For English language my CSS is not working:

    .single .post-entry h1 {
       font-family: 'Parisienne','Helvetica Neue',Helvetica,Arial,sans-serif;
    }

    I am using:

    • WordPress version: 4.9.7.
    • Enfold version: 4.4.1
    • WPML Multilingual CMS: 4.0.5
    • WPML String Translation: 2.8.5
    • WPML Translation Management: 2.6.5
    #991386

    Hey Marcel,

    Thank you for using Enfold.

    Did you add the font on both languages? How did you add it?

    Best regards,
    Ismael

    #991440

    Hi Ismael,
    I have added the @font-face {} to style.css in child theme folder.
    The CSS for h1-Headline I have added in Enfold settings > styling > fonts > Quick CSS for both languages.

    Best regards,
    Marcel

    #991680

    I saw another bug: Media element “Masonry Galery” is working on German version but not on English version. See the links in private content. In my post before I have sent you login credentials for WP admin.

    Any idea what went wrong? English content version is a 1:1 copy from German content, just with translated text. No idea why Masonry Galery i not shown on English version.

    #991722

    Hi,

    1) I corrected the font files urls to absolute urls. The relative urls you were using gave me 404 errors.

    2) Two font files are still missing:
    https://www.bridal-boutique.de/wp-content/themes/enfold-child/fonts/open-sans/open-sans-regular/open-sans-regular.woff

    and

    https://www.bridal-boutique.de/wp-content/themes/enfold-child/fonts/parisienne/parisienne-regular.woff

    3) You need to translate the images like posts/pages. Please install the media translation plugin and translate the images to use them on the English website.

    Best regards,
    Dude

    #991860

    Hi Dude,

    thanks for your answer.

    1.) Perfect. It is working now.
    2.) I will fix that.
    3.) Is it new (not the plugin, rather that I have to use the plugin). Reason: Everything works fine until the last update. If I create a new English version of a German page “Masonry Galery” works fine without the plugin. Only the pages with “Masonry Galery” I had created before the update(s) do not work anymore. Please see both links in private content.

    #992646

    Hi,

    3.) Yes, something has changed in the WPML plugin which creates issues with the elements’ translation. It has been discussed and solved in the following thread:

    // https://wpml.org/forums/topic/translated-images-not-showing-after-updating-wpml/#post-2580566

    Please try to follow the steps provided by the OP and WPML moderator.

    Best regards,
    Ismael

    #1009358

    Hi Dude,

    where did you correct the absolute URL? There is a small mistake in your absolute URL (/wp/ is missing) an I want to correct this.

    Edit: Temporary I have disabled “CSS file merging and compression” in Enfold performance settings. If you enable, you can see the wrong absolute URL to the font files at the bottom of the avia-merged-styles.css file.

    Thanks,
    Marcel

    • This reply was modified 1 year, 9 months ago by  Mathuseo.
    #1009752

    Hi,

    I think he changed the url of the font files on your style.css file or the Quick CSS field. Please look for the “Parisienne” font face rule.

    Best regards,
    Ismael

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.