Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #803207

    Hello,
    I am having issues with WPML language switcher.
    I have hidden the default Enfold switcher and have added a menu switcher to my main menu.
    It works great for all pages (switching from english to french) – however does not work on the homepage for some reason.
    Do you have any thoughts on what could be going on? (I did put a support request @WPML as well to see if they had any insights.

    much appreciated!

    #803210

    Fixed!: FYI to others on GODADDY HOSTING

    Problem:language switcher doesn’t work on home page, works on every other page.
    Solution:The issue is not caused by the WPML plugin rather it is caused by your host provider.
    “GoDaddy manages WordPress Hosting, where user is unable to change the homeURL of their site”
    You will need to make sure in wp_options “home” field is not empty and this will fix the issue
    Therefore the options Like mentioned above
    1. Please contact your host provider (GoDaddy) they will work with you on fixing the issue
    you need to make sure in wp_options “home” field is not empty and this will fix the issue
    In wp_options there is the site_url field and the home field both should contain your sites URL.
    With GoDaddy user is unable to change the homeURL please contact them and ask them to set your homeURL in the wp_options in the database .

    2. If you would like to give this a try you will need to access your database (using phpmyadmin mostlikely from your cpanel)

    #803288

    Hi,

    Great, glad you got it working and thanks a lot for sharing, much appreciated :-)

    Best regards,
    Rikard

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.