Tagged: ,

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
  • #29367


    Enfold is great obviously! Really easy to use and create layouts. I have installed WPML and am trying to have the site in 3 languages. But when the plugin is active, all my URL’s break. All links in the navigation, page links, buttons…everything except the homepage!

    Seems quite drastic and as if I am missing something pretty fundamental. Any ideas?



    Sorry – URL is http://www.focusbarcelona.com …thanks!


    Please try to flush the permalinks (go to Settings > Permalinks and hit the save button). If this doesn’t solve the issue install: http://wordpress.org/plugins/rewrite-rules-inspector/ and click the “Flush rules” button on the right side. If this still doesn’t help you maybe need to update your htaccess file manually: http://codex.wordpress.org/Using_Permalinks#Creating_and_editing_.28.htaccess.29


    Hi, have done everything suggested above to no avail.

    Every attempted page access in any language throws up the 404 page.

    Looking at the contents of $wp_query I notice that it’s erroneously trying to look for post_type ‘post’ instead of page and therefore returning 0 results – see data below. It looks like WPML is responsible for this part of the query… any ideas how to remedy it?

    [query] => Array
    [page] =>
    [name] => new-page-english

    [request] => SELECT wp_posts.* FROM wp_posts JOIN wp_icl_translations t ON wp_posts.ID = t.element_id
    AND t.element_type IN (‘post_post’,’post_page’,’post_portfolio’) JOIN wp_icl_languages l ON t.language_code=l.code AND l.active=1 WHERE 1=1 AND wp_posts.post_name = ‘new-page-english’ AND wp_posts.post_type = ‘post’ AND t.language_code=’en’ ORDER BY wp_posts.post_date DESC
    [posts] => Array



    Please create me a wordpress admin account and send me the login data to: (Email address hidden if logged out) – I’ll look into it.



    Hey, thanks a lot…I have added you as a user. Let me know the verdict!

    Many thanks



    I found the problem. I just had to change the permalink to /%category%/%postname%/, then I saved the settings and changed it back to /%postname%/ – now all links work and only the French flag returns a 404 error because you didn’t set a frontpage yet ( http://focusbarcelona.com/wp-admin/admin.php?page=avia&lang=fr&admin_bar=1 )



    Thanks a lot for this! Really simple in the end?!



    Yes, but glad it was a simple solution and not a bug in the framework :)


Viewing 9 posts - 1 through 9 (of 9 total)

The topic ‘WPML Breaks all URL's’ is closed to new replies.