Tagged: , , ,

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
  • #1408673

    Hi there, we are having some problems with the word count of WP Store locator Stores. Support from Yoast said it could be a WPSL or theme problem:
    Support at WPSL suggested this could be a theme problem:

    So we did some debugging and when we switch to a default theme (e.g. 2023) using the Health Check & Troubleshooting plugin the word count is working fine.

    Is this a bug in the theme, or do we need to add some code in order to make Yoast understand WPSL Stores with Enfold?


    Hey Websols,
    Thank you for your patience, as I understand you are using the plugin WP Store Locator that your Yoast plugin is not reading the word count on the “store” post.
    I don’t have any experience with this plugin but when I install it and add a “store” the yoast panel doesn’t show for it like the pages and posts do and I don’t see any options to have it show. I also switched to the 2023 theme and the yoast panel still didn’t show on the “store” post.
    Can you explain how to recreate your issue?

    Best regards,


    Hi there, you need to enable the permalink feature in the settings of WP Store locator. Maybe afterwards open and save the Yoast settings for WPSL stores.


    Thanks for the feedback, this did enable the Yoast feature, but on my site it is counting the words correctly: note in the screenshot The text contains 14 words
    perhaps you have another plugin that is interfering, try disabling all of your other plugins and checking again.

    Best regards,


    Hi, we’ve just made a clean install with WP 6.2.2 (Dutch language) , Enfold 5.6.2, Enfold child, latest Store locator and latest Yoast plugin. No other active plugins. Running on PHP 8.0.28 / MariaDB 10.3.38
    Unfortunately still The text contains 0 words
    When we switch to Twenty-Twentythree the word count is correct instantly :The text contains 189 words
    Then back to Enfold Child: The text contains 0 words
    Even Enfold main theme: The text contains 0 words

    So still looks like an Enfold thing to us…


    Thanks for the feedback, please include an admin login in the Private Content area so I can compare the settings on your site with mine to see why the word count is working on my site and not yours.

    Best regards,


    Done, see private content


    Thanks for the login, I enabled the Classic Editor at Enfold Theme Options ▸ Select Your Editor ▸ Use WP Classic Editor and now the word count works, please check:

    Best regards,


    OK, is this something you need to fix then? Because some of out clients are using the new Gutenberg editor for their custom post type posts and this means we can’t disable it globally…


    The Gutenberg editor is from the WordPress core files and not from the theme.
    Supporting third party plugins is outside of our support scope, I don’t see that I can open a issue for the Dev Team that is about two plugins not working together when the Gutenberg editor is used.

    Best regards,

Viewing 10 posts - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.