Viewing 16 posts - 1 through 16 (of 16 total)
  • Author
    Posts
  • #1425142

    Since updating to WordPress 6.4 & even this morning’s 6.4.1, we have had a very unstable working environment. We currently cannot save work (pink ribbon on top -Message “updating failed”) and are having issues with the Accordion content element.

    Content Elements – Accordion functionality is terrible. The toggle content is there but not displaying. Sometimes, when you click on a Toggle +, it takes you to the top of the page rather than just opening up the toggle container.

    #1425164

    Hey So Evolve,

    There are some problems with the new WordPress updates: https://github.com/WordPress/Requests/issues/838, https://joltmailer.com/wordpress-6-4/. As always, we recommend that you update on a staging version of the site first of all.

    Best regards,
    Rikard

    #1433851
    This reply has been marked as private.
    #1433880

    Hi,

    What happens if you deactivate all plugins? If that doesn’t make any difference, then please share server error logs with us.

    Best regards,
    Rikard

    #1433999
    This reply has been marked as private.
    #1434011

    Hi,

    Thanks, but that looks like an activity log. Do you have one with errors only?

    Best regards,
    Rikard

    #1434024
    This reply has been marked as private.
    #1434039

    Hi,

    Thank you for the update.

    We were able to reproduce the issue but we are not yet sure what is causing it. Please clone the site to a staging or development environment, switch the installation to debug mode and enable the error logs. Or post the S/FTP details in the private field so that we can debug the issue further.

    // https://developer.wordpress.org/advanced-administration/debug/debug-wordpress/#example-wp-config-php-for-debugging
    // https://developer.wordpress.org/advanced-administration/debug/debug-wordpress/#wp_debug_log

    Best regards,
    Ismael

    #1434091
    This reply has been marked as private.
    #1434135

    Hi,

    Thank you for the info.

    We can’t access the server using the login info above. Please check the info carefully or provide another S/FTP account. Did you create a backup or restore point?

    Best regards,
    Ismael

    #1434187

    Updated Access & Confirmed – the site is backed up daily

    • This reply was modified 1 week, 2 days ago by So Evolve.
    #1434573

    Hi,
    Thanks for your patience, I found that your site is exhausting it’s allowed memory size in /public_html/wp-includes/class-wpdb.php on line 2320, I noticed that you have some javascript in your page and sometimes these are also executed in the backend, so I moved it to your WP Code plugin as a javascript snippet.
    I then created a shortcode to display your getresponse-form snippet and added it to your WP Code plugin:

    function getresponse_form_shortcode($atts) {
        $atts = shortcode_atts(
            array(
                'form-id' => '', 
                'e' => '1', 
            ),
            $atts,
            'getresponse-form'
        );
        $form_id = $atts['form-id'];
        $e = $atts['e'];
    
        if (empty($form_id)) {
            return '<p style="color: red;">Error: Form ID is missing</p>';
        }
        $html = '<getresponse-form form-id="' . esc_attr($form_id) . '" e="' . esc_attr($e) . '"></getresponse-form>';
        return $html;
    }
    add_shortcode('getresponse-form', 'getresponse_form_shortcode');

    Then I added [getresponse-form] to your page to show the form snippet.
    While this didn’t solve the issue directly, it ruled out the possibility of the javascript causing the issue in the backend. I found a Yoast support issue that points to /public_html/wp-includes/class-wpdb.php on line 2320 as a known Yoast issue and I tried adding the snippet but this didn’t help, so please try changing your server setting and see if this helps.
    max_execution_time = 300
    PHP max input variables = 10000
    PHP time limit = 300
    Max input time = 120

    Best regards,
    Mike

    #1434587
    This reply has been marked as private.
    #1434592

    Hi,
    Yes that is what I see, did you try to change your server setting as posted above and the Yoast support thread above?

    Best regards,
    Mike

    #1434595

    We had, but we just cleared the hosting cache, and now the edits are available without error.

    Thanks

    #1434596

    Hi,
    That is good news. If you don’t want to use the getresponse form shortcode I created, that is fine, I was just trying to rule out possible issues. Shall we close this thread then?

    Best regards,
    Mike

Viewing 16 posts - 1 through 16 (of 16 total)
  • You must be logged in to reply to this topic.