Viewing 30 posts - 1 through 30 (of 36 total)
  • Author
    Posts
  • #1041937

    Hello, I updated my staging site to Enfold 4.5.1 and WordPress 5.0 (gulp!) and am seeing some strange behavior on some of the pages built with Enfold ALB.

    Some of the text elements (containing only text) display this message on the preview pane to the right:
    “It seems you are currently adding some HTML markup or other special characters. Once all HTML tags are closed the preview will be available again. If this message persists please check your input for special characters and try to remove them.”

    When this happens, the text box on left that you would normally be able to edit is blank, though if you close the element you can see the text that’s there.

    If I click on preview to preview the page, the text renders fine on the front end. I just can’t edit it on the back end. This does not occur on all pages — just some of them. Some of the ALB pages work normally on the backend.

    I am in no rush to update to WordPress 5.0… Login info in private content. :)

    Best
    Rob

    #1041951

    Yes – it seems that the whole Enfold Shortcode Stuff is in the textfield. If you goto text view you see this:

    _____________

    Edit: if you first – when you open an existing Enfold ALB Page goto “Save” : “Update” Button on the right top side – then the page will be as it should be – and the image of text-block element would not be this way above:

    #1041965

    Yes – same happened with various sites I have.
    I confirm this technique definitely works… although you may also have to refresh the page, following saving.
    Mark

    #1042023

    I have maybe even bigger problems ..
    I updated wp and enfold, I started to check page by page if there were any problems and at the end I found two pages that gave the html problem.
    As mentioned above I tried to save and refresh the page.
    Result: the problem has not been solved and, in addition, the pages crash (also the editor) and create duplicates within the page itself.
    OMG

    Edit: I solved.
    I recovered the backup and redo everything from scratch.
    re-installing all one thing at a time, following the above procedure, everything is back to normal.
    thank you

    • This reply was modified 1 year, 9 months ago by  RafaRojo.
    #1042052

    Thank you for posting this!!!

    Would you please mind making this process clear for us all?
    I’m not quite sure of the steps carried out here…

    Many. many thanks
    Stevo :-)

    #1042074

    Just had a very similar issue with the text block.
    A bit of a hack, but it works.

    Thanks a lot @guenni007!

    #1042219

    Yes, I too was able to work around the issue but not without issue. The first time I clicked the update button, I got a failure message. I logged out and back in and retried. Update worked but still had problem with text block. So then I updated and then viewed page, then went back into the back end and finally was able to add a text block.

    At least this process works for now..

    #1042226

    Clicking on the “Update” button and reloading the page worked fine for me as well. I also found a post saying that you can install a plugin called “Delet Gutenberg” but I haven’t tried that so far (here is the post: https://kriesi.at/support/topic/text-block-has-no-wysiwyg-editor/#post-1042218)

    #1042232

    To all participants like me : do alway update your themes ( at least the main updates ) via clean upload. I have never had such big problems on doing that. I never updated via dashboard.

    • Update via ftp.
    • Rename the downloaded newest version to enfold-new
    • Upload that enfold-new folder to the themes folder
    • Rename your enfold folder to f.e. enfold-old
    • Rename your enfold-new folder to enfold
    • Check if all your existing settings work to your full satisfaction. Yes – then stop here
    • No – delete or rename back the enfold folder back to enfold-new
    • rename the enfold-old folder back to enfold
    #1042263

    Conclusio: Enfold isn’t ready für WordPress 5.0. Period.

    #1042266

    Hi Dieter

    I don’t want to put myself on any side here, but please keep in mind that you do not have to update to WordPress 5.0. It is optional. Just can also still stick to WP 4.9.8 if you prefer to.
    Almost everybody got very surprised last Tuesday when WP 5.0 got announced and published yesterday. So to me it sounds to easy to just blame Kriesi here.

    In addition, I am convinced that the Kriesi guys working on Enfold are doing a great job and are working very hard in order to make the theme even better.

    Just curious: Do you actually have some other issues with WP 5.0 in combination with Enfold 4.5.1?

    Best
    Michael

    #1042272

    I don’t see anyone here creating sides or blaming Kriesi. We all know WP 5.0 was rushed out, and I’m guessing that the Beta WP 5.0 that the Enfold coders tested on is different than the WP 5.0 that was released yesterday…. maybe just one little line of code threw the whole ALB off.

    What does concern me is that the forums seem to be without mods today — on the first day of a major release. Just some “we are working on this, hang tight” would be welcomed at this point.

    #1042278

    Dear Kriesi team,
    Two of my clients pages are nearly down due to the update to WP 5. It would be highly appreciated to get a work-around or a solution for the above mentioned issues pretty soon.
    Thanks, Enrico

    #1042290

    Hi Michael,
    were do you see me blaming anyone? I simply said: Enfold isn’t ready for WP5. That’s a fact and that’s all.

    Like @goldengate415 said, anyone knew WP5 was coming.

    Cheers

    #1042294

    Alright sorry, then I misunderstood it.
    You are saying that Enfold is not ready for WP 5.0, that’s your opinion and that’s fine. I just have a different opinion on that and think it works pretty good already with 5.0.

    #1042307

    Just install Classic Editor Plugin and bypass the inferior “Gutenberg” block editor. It is crap. Enfold Visual Composer is light years ahead of this. Thus why we purchase Enfold – because it is one of the best, if not the best visual composers, not only for novice users, but can be easily highly customized for experienced developers. In my opinion this update is going to be a big mistake for WordPress. But I applaud Kriesi for not leaving us hanging and dealing with this crap! ;)

    #1042311

    jomo5280, could you or someone else explain what value or advantage there would be to install the Classic Editor plugin?

    If we have this work around with the advanced Layout builder and not using the new Gutenberg blocks option.

    Thanks!

    GB

    #1042472

    Hi,
    Sorry for the late reply, I have alerted the dev team about this issue and this thread. Thank you for your patience.

    Best regards,
    Mike

    #1042501

    Thanks Mike. The solution from 007 is not working for me on pages that I had already opened to test… perhaps it only works the first time a page is opened? In any event I will wait for 4.5.2 before installing WP 5.0 on my production site. :)

    “Edit: if you first – when you open an existing Enfold ALB Page goto “Save” : “Update” Button on the right top side – then the page will be as it should be – and the image of text-block element would not be this way above:”

    #1042505

    I am trying the update page and refresh to an existing ALB page to solve “the issue” and it is now NOT working.

    It had worked on one page of mine yesterday but not today even though I have not made any updates or changes since.

    Hoping the Dev team comes up with an update solution soon as I have two important sites to contend with.

    Thanks,

    GB

    #1042509

    Hi,
    Thank you @goldengate415 I have tested with “saving” a page when first opening and then reopening the page, did work for me. I found that if I opened an element before saving the page, it seems that Gutenberg created a auto save and I had to try saving the page 3 times & go to the front end 3 times before it was right. The auto save was like a cache that was hard to break. Your comment sounds like it was this same issue.
    I created a sticky for the forum to post these solutions, from your suggestion last time :)

    @gb perhaps you could try saving a couple more times to see if this “auto save” is your issue too?

    Thank you for your patience, the dev team will be working on this, I’m just not sure if it will be today, as it’s Sunday.

    Best regards,
    Mike

    #1042511

    Thanks, Mike, it’s great to have a mod and development team on this. And thanks for the sticky!!!!

    I hope it’s still Saturday and not Sunday or else I’m in big trouble! :)

    Best
    Rob

    #1042512

    Thanks Mike, I also noticed that the auto save could be a factor in this.

    And see that if I keep at it like you describe, I can get the process to work. It’s slow but at least I can continue until the update comes.

    Thanks again!

    #1042544

    Hi,
    @goldengate415, Yes, it’s Saturday :)

    @gb, I’m sure the dev team will get this sorted out after the weekend, glad you can at least continue with your work.

    Best regards,
    Mike

    #1042645

    Ugh. What a mess, eh? I couldn’t do anything to edit a page, add a page — all I got was updating failed. I did put in that Class Editor plugin and I’m back to normal.

    #1042696

    Hi jodyrussell,

    Great, glad you got it working and sorry for the problems.

    Best regards,
    Rikard

    #1042749

    Hi

    Yes I have the same problem I copied a page over to play around with it. When I go to the text section it doesn’t show anything in the visual however if you go into the text section it shows the coding for the whole page. What a nightmare. I was just about to release a website today to a client and now I can’t

    Thanks

    Alex

    I’m using 4.5.1

    • This reply was modified 1 year, 9 months ago by  info224.
    #1042751

    I experienced other problems too. When I edit a column (e.g. background color, background image, padding etc.) save and nothing is saved. nothing changes. When I change my site language to “english” instead of german, it works.

    Also I save a page as draft, not the actual version is saved but an older one. Saving as “publish”, everything is okay.

    Sorry, if my english isn’t that wonderful. I’m a german guy. ;-)

    regards
    Dieter

    #1042752

    I have just installed the classic editor plugin and it has fixed the problem. The text is appearing correctly in the Avia Layout builder :)

    #1042807

    Yes, that plugin fixes the problems! Mike, you might want to add that suggestion to the sticky. Much better than the “save and re-save” the page which didn’t work for me.

    Cheers
    Rob

Viewing 30 posts - 1 through 30 (of 36 total)

You must be logged in to reply to this topic.