Viewing 28 posts - 1 through 28 (of 28 total)
  • Author
    Posts
  • #794340

    WooCommerce 3.0.6
    Enfold 4.0.6
    WordPress 4.7.4
    No other plugins

    If you select the “default enfold product gallery” variation images are not displayed if you select a new variation on the single product page. The main image is displayed statically for every variation.

    If you switch to the “WooCommerce 3.0 product gallery” variation images are displayed as expected if you select a new variation.

    Bug or feature?

    #794659

    Same behavior on WooCommerce 3.0.7, Enfold 4.0.7, WordPress 4.7.5

    #795047

    Hi,

    Thank you for reporting, it.
    It must be something that we lost while testing but can u also make sure that before we confirm it, it is happening on a clear installation also?

    I am sure that especially u, before reporting you tested with every option – but still it would be nice to know.

    Best regards,
    Basilis

    #795048

    Hi, this is a fresh installation for testing purpose only. That’s why I listed the installed components :-)

    #795891

    Hi, I just updated the theme and I have seen that I stopped working the variables of product images, I make a selection of a variable and it does not change the image I have to go. I use Child theme, I need a solution, thank you very much.

    I have installed, WooCommerce 3.0.7, Enfold 4.0.7, WordPress 4.7.5.

    #797219

    Hi,

    What plugin are you using for the variable images?
    It it compatible with latest WooCommerce?

    Best regards,
    Basilis

    #797327

    This behaviour persist without any plugins for adding variation images, which is done by adding an image from a media gallery to WooCommerce product variation directly in the product edit mode.
    Note that the original post specifically stated that no other plugins were installed.

    #797530

    Good morning, I use the product variables with the woo commerce plugin. It has stopped working with the new woocommer update and my enfold theme. I hope your news so I can solve this as soon as possible, thanks

    • This reply was modified 2 years, 10 months ago by  oncediez.
    #798540

    Hi,

    Yes the issue is happening, our developers are working to solve it.

    Best regards,
    Basilis

    #799353

    Same issue with latest versions of Enfold and Woo. Just hoping someone finds a solution.

    #800558

    Hi Craymon,

    Please bare with us. Issue is still not resolved.

    Best regards,
    Victoria

    #803048

    solution !!
    you have enabled the default WooCommerce options and not the Enfold modification to the product view
    and it’s works :)

    • This reply was modified 2 years, 10 months ago by  bsodit.
    #803578

    Hi bsodit,

    Glad you got it working for you! :)

    If you need further assistance please let us know.

    Best regards,
    Victoria

    #805457

    How you do that??
    ” have enabled the default WooCommerce options and not the Enfold modification to the product view”

    I keep reading this but I cannot find anywhere to switch between this two option! It is driving me crazy

    #805465

    Ok, I’ve just figured it out: it comes with 4.0.7 release of Enfold (which I coundln’t find via themeforest..)
    Now I got the update via dashboard and it’s ok!

    #805470

    in your dashboard, go to the ENFOLD setting -> shop -> use woocomerce 3.0 instead of enfold

    #805941

    Hi,

    Thanks for sharing @bsodit, much appreciated :-)

    Best regards,
    Rikard

    #831850

    10 weeks have passed since I reported this bug and still the enfold product gallery does not change images if you select a variation. It worked before Enfold 4.0.6 and stopped working at the moment the new WooCommerce product gallery has been introduced. Some customers want or need to stay with the enfold product gallery for layout reasons but also want the images of variations to change. Did you miss this issue or are there no plans to bring this feature back?

    #834220

    Hi,

    WooCommerce 3.0 made huge changes to the product gallery and the logic, it displays product images. We try to be backwards compatible as long as possible, but WooCommerce does not provide any backwards compatibility for the variations any more. This makes it impossible for us to show variation images without reimplementing the complete logic.

    As the variations work fine when you use the new product gallery the expense to implement an outgoing and no longer supported feature does not make sense.

    Thank you once again for using Enfold. Feel free to come back when you need more assistance.

    Best regards,
    Günter

    #855400

    Hi
    I encountered the same issue with the variations images and by enabling the Shop gallery, it got fixed.
    It’s good to have this forum to search for problem resolution before opening a ticket here.
    Just wanted to shared my success.
    Lyse

    #855646

    Hi
    I just realized that I have the same expectations as mensmaximus – I need this to work the way it was. I have two websites using this and in one I have thousands of variable products…..

    Thanks
    Lyse

    #855896
    #863917

    Any changes to this?
    The default gallery shows the variation images, but when i hover over the image to zoom it shows the parent image (basic variable product image).
    And Enfold still does not switch images :(

    #864264

    Hi,

    As already mentioned above the old default gallery cannot support variation images because WooCommerce changed the logic behind with 3.0.

    In the next update there will be an enhancement in the shop options of Enfold that you can have the new gallery look very similar to the old one.

    Meanwhile you have to update some core files. Please replace the complete content of the following files with the RAW paste content of the links:

    enfold/config-woocommerce/config.php

    https://pastebin.com/31Zvcwx8

    enfold/config-woocommerce/woocommerce-mod.css

    https://pastebin.com/g3QQCExT

    enfold/includes/admin/register-admin-options.php

    https://pastebin.com/qRtnM8pn

    enfold/framework/js/avia_advanced_form_elements.js

    https://pastebin.com/HDRbTv5F

    These links are valid for one month. Make sure to make a copy of the original files to have a fallback and that you are using Enfold 4.1.2.

    Please clear your browser cache, Server cache and reload the page (sometimes you need to close the browser and reopen a new browser window and reload the page several times).

    If you have problem we can do the update for you, please give us FTP access to your server.

    Best regards,
    Günter

    • This reply was modified 2 years, 5 months ago by  Günter. Reason: Added avia_advanced_form_elements.js
    #865667

    Hi, thank you for this update.
    The variation thumbnails still do not load under the main image:

    Can you help me?

    #865714

    Hi,

    @imagevo

    Are you using a plugin for variations? Because in the default WC installation it works fine for me. Try to disable all other plugins and check.

    Anyway, as this thread becomes overcrowded – please open an own thread and give us an admin account so we can check your backend.

    Best regards,
    Günter

    #865799

    Thank you

    #866547

    Hi,

    @imagevo: The variation images are displaying once you select an option. Please create a new thread with the url to the site plus the login credentials. We’ll close this thread for now.

    Best regards,
    Ismael

Viewing 28 posts - 1 through 28 (of 28 total)

The topic ‘WooCommerce Variation Image’ is closed to new replies.