Viewing 30 posts - 1 through 30 (of 34 total)
  • Author
  • #815810

    Hi guys,

    I’m using the latest version of Enfold and WooCommerce. After the last WooCommerce update, the terms and conditions are shown twice on the checkout page. Not only the sentence with the checkbox, but also the whole text of the Terms & Conditions page. I don’t know if this is a bug in WooCommerce or in Enfold, but I hope you can help me.


    Same here. Changed themes and it is fine. Downgraded WOO and it is fine. Any ideas?


    In fact I dont think it is the latest Enfold. Im using Version 4.0.5.
    On my test site I have updated WP and Woo then this issue occurred – before updating Enfold.


    Same here, latest version of Enfold and WooCommerce.


    The problem is not with Enfold, but rather with WooCommerce 3.1.0

    In the changelog ( they introduced this:

    * Feature – Display (toggle-able) terms inline on the checkout rather than showing a link.

    I can’t seem to find where the toggle is, but the code change can be found here on line 17

    To avoid the issue, download the terms.php and upload it in /theme_name/woocommerce/checkout/terms.php and change line 17 to
    $terms_content = “”;


    And if you want to fix it with a more clean approach through a filter, you can use this piece of code in functions.php

    add_filter('woocommerce_format_content', 'yanco_remove_inline_terms', 10, 2);
    function yanco_remove_inline_terms( $apply_filters, $raw_string ) {
    	if( is_checkout() ) {
    		return '';
    	return $apply_filters;

    I tried the filter but it’s not working. Athough … it is working, but if you click on the link the terms doesn’t open. I’ll contact WooCommerce how to solve this.


    I’ve switched to Twenty Twelve, the terms & conditions works fine then, so it’s an Enfold bug. I use the function snippet to remove the text of the terms & conditions (that works). Do you think you can get the popup with the terms also working? Because customers can’t read them now :-)


    Yeah everything works aside from the terms link not opening.


    Hi guys,

    I’ve just noticed this too and it’s a real problem because the terms and conditions are not only long, but they are shown twice.

    From a consumers perspective it’s really annoying because it isn’t even obvious to keep scrolling, it just looks like there is no option to “Place order”.

    Please can you fix asap?


    Hi all,

    Here are some threads for you: (Purchase code hidden if logged out) -and-conditions-shows-twice/

    Fixing Outdated WooCommerce Templates

    Best regards,


    Victoria, I don’t really see how those threads can help. As I mentioned earlier, I don’t have the problem if I use Twenty Twelve, all the WooCommerce files are up to date. I think this is an Enfold bug.


    Hi BuroStaal,

    Could you please remove the code given in this thread. I do not see the Editor submenu in the Appearance menu. I need to test without it.

    Best regards,


    I have the same issue. Multiple webshops… Please fix this.


    same issue, using the code above the term and conditions not displayd twice, but only the check button it is ok!!.
    The problem now is that the text will not diplayed in a popup but linked to tems and conditions page…



    @burostaal: I took a look at the checkout page and the “terms & conditions” page is not duplicated anymore. Is this fixed? Please update the theme to version 4.1.1.

    Best regards,


    @Ismail: I sent private content earlier to tell that I disabled the “terms & conditions” page because it looks relaly weird and customers didn’t understood what to do with it. I sen my login details so you could login and enable it again. I updated yesterday to 4.1.1. but that’s not fixing the issue. I’ll send login details again in the private content.

    This reply has been marked as private.


    The page “Algemene Voorwaarden” is already set as the “Terms and conditions” page in the Woocommerce > Settings > Checkout panel of the “by-dodotnl” site.

    Best regards,


    @Ismail, it’s better to use the halzes10 site because that one is up to date. The by-do sity isn’t, that’s why it’s still working there. I’m waiting to update the by-do site till I’m sure the issue is fixed.



    I tried to access the site but I got the following error or notice.

    Geachte Bezoeker
    We zien veel verzoeken op de wp-login pagina (hackpogingen komen helaas vaak voor).
    Klik daarom hier om aan te tonen dat je geen spambot bent. Dat verhoogt de veiligheid van je site.
    De pgina herlaad na je bevestiging.

    Dear Visitor
    We are noticing a lot of requests on the wp-login page due to hacking attempts, which unfortunately happen quite often.
    Please click here to show you are not a spambot.
    The page will reload after your confirmation.

    Best regards,


    That’s just an extra safety measure :-) You van click on the link in Dutch or English to proceed to the login page.



    It’s not working properly because the content of the “Terms” page is outside the “woocommerce-terms-and-conditions” container. We edited the page and removed the color section. It breaks the layout of the checkout page.

    Best regards,


    That totally does the trick, also on my other Enfold webshops. Thank you Ismael!


    Can you tell us how this was fixed?


    Like Ismael wrote: It’s not working properly because the content of the “Terms” page is outside the “woocommerce-terms-and-conditions” container. We edited the page and removed the color section. It breaks the layout of the checkout page.

    So the only thing you need to do, is remove the color section from the terms & condition page. So the columns can’t be in a color section (or grid).


    I used the WP basic editor and still not opening for me


    No, I don’t mean the basic editor. Normally, I first put a section in a page. In that section I place a 1/1 column and in that column I place a text module for example. Now, I don’t need to use the section. So just place a 1/1 column (or an other size) in the page and place a text module in the column. Save the page, empty your cache, refresh your browser and see if it works. If it’s not working I can’t help you.


    Oh I see. Ok Ill see what I can do. Thanks!


    Thanks so much everyone, that worked

Viewing 30 posts - 1 through 30 (of 34 total)

You must be logged in to reply to this topic.