Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • #1401509

    Hi Support,

    Fantastic theme, team Kriesi!

    So, I’ve noticed that the WooCommerce shortcodes aren’t working correctly on our Sale page.

    This is the shortcode I’m trying to use: [products limit=”9″ orderby=”popularity” paginate=”true” on_sale=”true”]
    However, it’s not paginating the page or ordering by popularity. Also, when I activate sidebar on this page, it adds a big chunk of space between the sidebar and the product columns.

    Any ideas?

    Many thanks in advance,


    Hey Ben,
    The default pagination is not displaying properly because the action or callback for it is disabled. You can add this code in the functions.php file to add it back. You will have to adjust the style of the pagination a bit.

    add_action('after_setup_theme', function() {
        add_action( 'woocommerce_after_shop_loop', 'woocommerce_pagination', 10 );

    For the popularity sort please try the solution in this post.

    Best regards,

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.