Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #979198

    Hi,

    I have upgraded to the latest Enfold version. I have also upgraded all the WPML plugins. Now the woo commerce store (used as a catalog) is not working anymore. If I try to access to the products or related categories I have this error:

    Page not found

    Can you please help me to figure out how to solve this problem?

    Regards
    D.

    #979226

    I am going to restore the last backup! I cannot resolve the problem! Even without WPML active the woo commerce store doesn’t work.

    Regards
    David

    #979691

    Hi David,

    Sorry for the problems and thanks for the feedback. We’ll keep the thread open in case you should have any further problems after restoration.

    Best regards,
    Rikard

    #979700

    Hi Rikard,
    I did restore everything and updated only WordPress and the Enfold Theme to the last version. I did not update Woocommerce and the WPML plugins and left them as follow:

    • Woocommerce plugin version 2.5.5
    • Woocommerce multilingual version 3.8
    • WPML Media version 2.1.21
    • WPML Multilingual CMS version 3.4.0
    • WPML String Translator version 2.3.8
    • WPML Translation Manager version 2.2.0

    I don’t know why when I update the plugins above, woocommerce products and categories are unreachable (page not found error). I did also try on my local computer on Mamp and I have the same problem.

    Regards
    D.

    #980037

    Here the answer from WPML support in case someone has the same problem! I din’t try yet but I will really soon.

    Cheers
    D.

    ————————————–

    Maybe the issue is happening because you have upgraded from an older version of WPML(3.4 to 4.0.3) & WooCommerce Multilingual(3.8 to 4.3.2.1) to the latest version.

    Are you using the latest version of WooCommerce(3.4.3) now?

    If possible, please upgrade in the following order to avoid the upgrade issues.
    WPML 3.4 >> 3.5 >> 3.6 >> 3.7 >> 3.8 >> 3.9 >> 4.0

    You can upgrade up to WPML 4.0 manually by uploading the plugins files to wp-content/plugins folder(deactivate plugins before uploading latest version, then activate it). Visit WPML.org>>My Account>>Downloads section for downloading the WPML old versions by clicking *Changelog* link of each plugin.

    Please take a full site backup before upgrading. From WPML version 4.0 you can upgrade automatically to WPML 4.0.3 from WordPress Dashboard.

    #980295

    Hi,

    Let us know i you tried it also please and what would be the results!

    Best regards,
    Basilis

    #981035

    Hi,
    I have identify the problem. WC Catalog Visibility Options was creating the problem with Woocommerce and WPML. I have updated it on my test environment to the last version (3.1.3) and now everything works fine.

    I will update the live website when the backup system is going to run a backup of everything.

    I have just noticed a problem with the avia editor. When the Woocommerce Catalog Visibility Options is active, I cannot edit pages. The avia editor doesn’t load the page.

    Regards
    D.

    • This reply was modified 1 year, 9 months ago by  dmiklus.
    #981044

    Hi again,

    I have solved the problem with the avia editor. The Lite Speed Cache Plugin was the problem. I had to turn off the Cache Logged-in Users option under settings.

    Best regards
    D.

    #982157

    Hi,

    Did you solve all problems or do you still need help?

    Best regards,
    Dude

    #982312

    Hi Dude,

    I have resolved everything. I have only an issue with the SSL configuration. When I change the WordPress setup from http to https the browser doesn’t download all the pictures and the website looks like really slow and stuck. All the images are marked as insecure content. Before the activation, I have changed all the urls with the https under the Enfold theme panel. My hosting provider is telling me that the SSL certificate is working correctly, but I cannot find a solution. This is the first time that I have issues with a SSL configuration. Any suggestions

    Regards
    D.

    #982630

    Hi,

    I can see some content on your site not being served using https, the file in private for instance. How are you adding that script?

    Also make sure that you change the site URL under Settings in the WordPress menu.

    Best regards,
    Rikard

    #982664

    Hi Rikard,

    The script is added by a plugin called TooToc Video Live chat. When I change the WordPress configuration to HTTPS the browser doesn’t load all the pictures. I don’t understand why.

    D.

    #982665

    Hi Rikard,

    When I am logged in as admin and I preview the website everything works fine. When I am logged out then doesn’t work.

    D.

    #982668

    Hi Rikard,
    resolved!!! Thanks for everything!

    D.

    #982789

    Hi dmiklus,

    Glad we could help :)

    If you need further assistance please let us know.
    Best regards,
    Victoria

Viewing 15 posts - 1 through 15 (of 15 total)

You must be logged in to reply to this topic.