Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #1376955

    Dear Enfold,

    I hope you are happy and well. Merry Christmas. I continue to enjoy Enfold after many years of use.

    I need some help with something that I just noticed today.

    I have set the images in Woocommerce to be custom cropped at a 2:3 ratio. This crop is working correctly on my home page, and on my shop page.

    Home

    Shop
    https://www.wildsugar.fashion/shop/

    It has stopped working within product categories. You can see when you look at a product category that it was working because there are images there that are cropped correctly at the 2:3 ratio. Then at some point, something changed and now the images in product categories are cropped at a 1:1 ratio.

    https://www.wildsugar.fashion/product-category/dresses/

    I upload all my images at a 4:5 crop ratio. They display at this ratio in the product overview. I am happy with this too.

    I need help getting the images in product categories (dresses, skirts, etc.) to once again crop at the 2:3 ratio.

    I have checked my custom css. I have not had to enter any custom code in the past to achieve the result I have enjoyed for so long. It appears that the only setting I have access to that would make a difference is in: Customize -> Woocommerce -> Product Images (I have not changed these settings. They are set to what they have always been).

    <a href='https://automattic.pxf.io/y2XdbN/' target='_blank' rel='nofollow'/ rel=Woocommerce Product Images Crop Ratio" />

    Thank you once again and all the best for the new year.

    Best,
    Dameon

    • This topic was modified 1 year, 7 months ago by dameonjamie. Reason: Added login credentials for Kriesi customer support
    #1377106

    Hey Dameon,

    Thank you for the inquiry.

    You may need to add this filter in the functions.php file to disable the theme’s default size for the catalogue images.

    add_filter( 'avf_wc_before_shop_loop_item_title_img_size', 'avf_wc_before_shop_loop_item_title_img_size_mod', 10, 1 );
    function avf_wc_before_shop_loop_item_title_img_size_mod( $thumbnail_size ) {
        return 'woocommerce_thumbnail';
    }
    

    If the issue persists, here are a few things you can try to troubleshoot the problem:

    1.) Check the WooCommerce settings for the product images to make sure that the correct image sizes are being used for the product categories. You can access these settings by going to “Customize > WooCommerce > Product Images” in the WordPress dashboard.

    2.) Check the WordPress media settings to make sure that the correct image sizes are being used for the product images. You can access these settings by going to “Settings > Media” in the WordPress dashboard.

    3.) Check the WordPress theme and plugin files to see if there are any custom image size functions being used that might be affecting the way the product images are displayed.

    Hope these suggestions help! Let us know if you have any other questions or if you need further assistance.

    Best regards,
    Ismael

    #1377187

    Hi Ismael,

    I think this is the same solution that you posted here:

    Images sizes in woocommerce shop catalog

    Found that yesterday. It worked. Thank you.

    Best,
    Dameon

    #1377224

    Hi,

    Great, I’m glad that Ismael could help you out. Please let us know if you should need any further help on the topic, or if we can close it.

    Best regards,
    Rikard

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.