Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #1039722

    Hello,

    I recently tried to get some help from the support forum, but fear that post has been lost in the shuffle.

    Since upgrading to Enfold 4.5 and WooCommerce 3.5, our website has had a number of issues with the online store. Basically, after adding any quantity of products to the cart from the online shop page, the cart page shows an empty cart. However, it seems that if a user waits for a bit and refreshes, the cart shows correctly. Also, some users have had success if they are currently logged into the website.

    After speaking with WooCommerce and then testing the website, it does appear to be a theme conflict. I also went through and tested all the plugins to see if maybe one of them had been the culprit, but it didn’t appear to be the case.

    Recently, I updated WooCommerce to version 3.5.2 and had hoped it would solve the problem. But, the issue actually became worse. I also tried downgrading the PHP from 7.2. to 7.1 and that temporarily seemed to work. But, the issue then began happening again.

    I would prefer to not have to reach out to a developer and to pay them to fix this, but I am running out of time and options with it now being December. Any help, even just identifying the cause of the problem, would be appreciated.

    #1040844

    Hey npmcgrew,

    Can you create a staging site (basically a clone of your site on your subdomain)? so we can do some testing without affecting your live site.
    Here is a post on creating a staging site that might help: https://themeisle.com/blog/wordpress-staging-site/

    Best regards,
    Nikko

    #1040853

    Hi Niko,

    I have included our staging site login and FTP credentials in the private content of the reply.

    Thanks in advance!

    In using RobotNinja’s plugin and site, I did notice the following:

    Our website, TheMallardCreek.com passes the tests. Mallard Creek’s site has Enfold 4.4.1 and WooCommerce 3.5.2 installed.

    FairwaysMembership.com does not pass the test and I get the following error code:
    “After adding a product to the cart, Robot Ninja navigated to your store’s Checkout page (https://fairwaysmembership.com/checkout/) but was unable to confirm the page was loaded by looking for an element with class name woocommerce-checkout. Robot Ninja waited a maximum of 10 seconds before timing out.”

    I have also included the RobotNinja.com login credentials to potentially help you more.

    #1041716

    Hi npmcgrew,

    I tried the check link but it returns:

    DNS Lookup for "www.robotninja.com" failed. System.Net.Sockets.SocketException No such host is known

    The site seems down, I also checked it in: https://downforeveryoneorjustme.com/www.robotninja.com

    Best regards,
    Nikko

    #1041743

    Hi Nikko,

    I actually decided to go ahead and hire a developer from Codeable. If I had to guess, it’s an issue to do with GoDaddy’s Managed WordPress hosting. My overall understanding is that GoDaddy’s automatic cache (cannot be disabled) may cache dynamic pages.

    I will reply here once I know the full extent of the issue and what solution we find for your reference.

    If you have any suggestions for website hosting in North America, that would be welcome. Our main needs are stability and uptime, ability to work well with WordPress, Enfold Theme, WooCommerce, WooCommerce Square, WooCommerce PayPal Checkout, JetPack / Akismet Anti-Spam.

    I also enjoy a lot of the plugins offered by WPMU Dev, although I could see where they are user friendly enough that they actually cause problems.

    Anyway, thanks for the response and if you have any insights it would be much appreciated. I’ll be sure to let you know what solution(s) we find.

    #1043134

    Hi npmcgrew,

    I see, I’m not really sure what’s causing the issue, but try enabling wordpress debug or error logging: https://codex.wordpress.org/Debugging_in_WordPress
    Sometimes you can find some errors that might be related to the issue you’re having.

    Best regards,
    Nikko

    #1043161

    Hi Nikko,

    It turned out to be a GoDaddy Managed WordPress Hosting issue. Long story short, their built-in wordpress caching cannot be disabled on dynamic pages, such as WooCommerce pages. This was the root cause of why the cart showed as empty and then would show correctly after some amount of time.

    So, we moved FairwaysMembership.com to Kinsta hosting and everything is working well. I did keep the theme to Enfold 4.4.1 because it was working without fail for the first time in weeks, but I don’t think it’s the theme.

    Just thought I would give you the heads up in case you see anything similar from some other Enfold users.

    Have a great holiday season!

    #1043180

    Hi npmcgrew,

    Glad to hear that it’s sorted out!
    And thanks for the heads up, this would surely help other Enfold users on godaddy hosting having the same issue.
    Thanks for using Enfold and have a great holiday season too :)

    Best regards,
    Nikko

Viewing 8 posts - 1 through 8 (of 8 total)

The topic ‘WooCommerce Empty Cart Issue After Adding Products’ is closed to new replies.