Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #991661

    Hello,

    I am trying to find a solution for our WooCommerce Bookings products. This has worked for us in the past, but the support team at WooCommerce is pointing to a Javascript issue. Basically, everything is functioning as it should be with the exception of the calendar. The calendar shows faded and has a ‘loading’ cursor when hovered.

    The product(s) are:
    (Purchase code hidden if logged out) -club/”>9-Holes at Oberlin Golf Club on August 6
    (Purchase code hidden if logged out) -club/”>18-Holes at Oberlin Golf Club on August 6

    The javascript error found: https://cld.wthms.co/aj4cTj

    Is there any way I can go ahead and fix this? Many thanks in advance!

    #991673

    Hi npmcgrew!

    I switched the theme to TwentySeventeen and then back to Enfold and the calendar seems to work again:
    https://fairwaysmembership.com/product/ (Purchase code hidden if logged out) -club/
    https://fairwaysmembership.com/product/ (Purchase code hidden if logged out) -club/

    Best regards,
    Peter

    #991702

    Hi Peter,

    Thanks for going ahead and doing that. Unfortunately, the same is not true for me. Oddly enough, it works find when I am viewing the site as an admin.

    However, when I test on other, non-logged in computers in the office on either Safari, Chrome or IE, the same issue is occurring. On the Safari browser, I did login to another of my ‘customer’ accounts. Once I did that, I was able to use the datepicker.

    Is there a chance that the calendar has somehow been set to only appear if a user’s logged in? If so, how can I disable this so that people actually go through the process without becoming very confused?

      Here is something I have found in the inspect tool from chrome:

    Console: Failed to load resource: the server responded with a status of 403 (Forbidden)
    Style: #top .wc-bookings-booking-form .blockUI.blockOverlay {
    background-color: #ffffff !important;
    }

      I am wondering if this CSS would work but don’t want to implement it if there’s a bigger issue on the horizon:

    .woocommerce .blockUI.blockOverlay {
    position: relative!important;
    display: none!important;
    }

    #991717

    Hi,

    Ah ok, I didn’t test the website without user account. Now I could reproduce the bug, however it’s not a theme issue. If I switch to TwentySeventeen (default wordpress theme) the calendar is also grayed out and doesn’t work. I’d recommend to check the htaccess and firewall configuration of the server – maybe the access to the wp-admin/ folder is blocked somehow. If not please contact the plugin author and ask him for support.

    Best regards,
    Dude

    #991718

    Hi Dude,

    I added the code to the General Styling CSS area:
    .woocommerce .blockUI.blockOverlay {
    position: relative!important;
    display: none!important;
    }

    This has worked on all of the office computers with Explorer, safari and Chrome. Would you be tentative to send this out to customers in my position or would you just go ahead and see how it all works?

    #991727

    Hey!

    Personally I wouldn’t recommend this fix. The problem is the blocked ajax request and not the gray “loading overlay”. The gray overlay just indicates the website is processing data in the background. Removing the overlay does not solve the issue – you just sweep it under the carpet and the data request is still not processed (properly) in the background. To be honest I don’t know if the ajax request is really necessary but I would at least talk to the plugin author before ignoring it.

    Regards,
    Peter

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.