Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #420029

    How can I disable the animation that Enfold has when I add an item to the cart? (The one that slides in the cart logo at the top right with a short summary of what was just added)

    So you know, the reason I ask is because I have both regular WC products and also WC Subscription products. In fact, in my case I have one of each in a WC Grouped Product. If I add the regular product, I get the Enfold animation. But if I add the WC Subscription product, I get the default WC animation (the one that puts a green info box at the top of the page content that says “[ITEM” was successfully added to your cart” and has a “View Cart” button on the right). This might be a bug for you to fix for others, fyi.

    However, in my case, while the Enfold animation is pretty slick, some of my product names are long, and it doesn’t work well for me. I’d actually prefer the default WC animation with the green info box. So… how can I disable the Enfold animation when regular WC products are added to the cart.

    Thanks!

    #420782

    Hey wsnider28!

    Please add following code to Quick CSS in Enfold theme options under General Styling tab

    ul.cart_dropdown { display: none !important; }

    Regards,
    Yigit

    #420816

    In response to…

    Hi wsnider28!
    It sounds like your wanting to disable Enfold’s add to cart feature and just use the WooCommerce default add to cart feature instead. Is that correct? This is sounds like it would be easy but it’s actually going to take a lot of customization to do.
    Can you send us a link to your page so we can get a better idea of the different AJAX cart styles that are displaying on your site? If we can see it in action we will be able to get an idea if it’s feasible or not.

    …Sure. Here you go: http://www.mmmidwives.com/product/ (Purchase code hidden if logged out) /

    Thanks

    #421469

    Hey!

    I cannot see the code being applied, have you not added it?

    Regards,
    Yigit

    #421476

    Sorry, I hadn’t added it, because I thought from the last email that you meant it would be a different, more in-depth customization.

    However, I just added ul.cart_dropdown { display: none !important; } to my custom css, and while it does hide the Enfold animation when adding the regular product to the cart, it does NOT enable WC’s default animation (the green bar across the page), like adding the subscription product shows.

    So the css code is only half of the solution. I can’t have customers adding the regular product to the cart and not receiving ANY visual feedback that the item was added. Surely somewhere in an enfold php file, there’s some code that blocks WC’s animation and replaces it with Enfold’s.

    • This reply was modified 2 years, 7 months ago by  wsnider28.
    #423148

    Hi!

    When you say “WC default animation” which WooCommerce theme are you referring to? Can you send us a link? This is bordering on custom work but if it’s some simple styling your wanting to do then we can take a look.

    Regards,
    Elliott

    #423154

    Like I said in my original post, the default WC animation is the one that puts a green bar across the top of the content of the page that says “[ITEM] was successfully added to your cart” and has a “View Cart” button on the right. It’s part of the WooCommerce plugin, not part of a theme.

    If you go to the link I provided (http://www.mmmidwives.com/product/ (Purchase code hidden if logged out) /) and try adding each of the two products to the cart, you’ll see what I mean. The top one (a standard product) will produce the Enfold animation. The bottom one (a subscription product) will produce the default WC animation.

    While in reality, for you guys, this is probably a gap in the Enfold theme that needs to be corrected so that adding a subscription triggers the same animation you’ve built into Enfold for WC standard products, I on the other hand would prefer to ditch the Enfold animation entirely and allow the default WC animation to display when adding any item to the cart.

    #423984

    Hi!

    Oh, I see what you mean now. I’m not really sure what that’s called but if you navigate to Dashboard > WooCommerce > Settings > Products > Display and uncheck the “Enable AJAX add to cart buttons on archives” option then green banner should display everywhere when clicking on the add to cart button.

    Best regards,
    Elliott

    #423987

    Yep, that did it. I’m a bit surprised the WooThemes support couldn’t have answered that, and sent me here instead. But hey, resolved now, anyway.

    Thanks for the help.

    #424429

    Hi!

    glad it’s working for you now. Let us know when you need some more help with the theme.

    Cheers!
    Andy

Viewing 10 posts - 1 through 10 (of 10 total)

The topic ‘WooCommerce Add-to-Cart animation’ is closed to new replies.