Viewing 30 posts - 31 through 60 (of 67 total)
  • Author
    Posts
  • #783402

    Sorry but I do not recall the post. I am helping in 5 forums and on github writing about 100 posts each day since woocommerce 3 has been launched. I just recall there have been several issues. So just deactivate the plugin and test it again.

    #783848

    Hallo mensmaximus das ist wirklich ein toller Beitrag, leider ist mein Englisch nicht so gut, aber ich denke ich habe alles verstanden.
    Vielen Dank für Ihre Mühe und die damit verbundene Arbeit.
    Diana

    #783989

    I have followed @mensmaximus excellent instructions (child theme) and that has fixed my blury images. However, where I used to have a thumbnail gallery (pre-WC 3), I still have a column of images each the size of the regular product image. Is this part of the same problem? Is there a solution?

    #784057

    Hey Elsmore01, it is probably coming from the same issue. I’m not sure at a 100% if your issue was the same as mine, but my thumbnails were different sizes, depending on the size of the original image I uploaded. I chose to change the height of the div that contained those images with some CSS :

    .thumbnails .woocommerce-product-gallery__image a.noHover.noLightbox {
        height: 5.7em;
    }

    The height value, will depend on your layout, so you will need to adjust.

    Hope this helps!

    @mensmaximus, you’re a beast!! Thanks again for your help!

    #784136

    @Phet, thanks for your suggestion but I actually don’t have a .thumbnails class.

    <figure class="woocommerce-product-gallery__wrapper">
    <div class="woocommerce-product-gallery__image" data-thumb="...">
    <a class="lightbox-added" href="..." rel="product_images[grouped]">
    <img class="attachment-shop_single size-shop_single wp-post-image" src="..." alt="" title="" data-src="..." data-large_image="..." data-large_image_width="1024" data-large_image_height="1024" srcset="..." sizes="(max-width: 450px) 100vw, 450px" style="" width="450" height="450">
    <span class="image-overlay overlay-type-image" style="left: 0px; top: 5px; overflow: hidden; display: block; height: 387px; width: 397px;">
    </a>
    </div>
    #784139

    Got a URL we could view? If not, try this :

    .woocommerce-product-gallery__image a.lightbox-added {
    height: DefineYourCustomHeight !important;
    }

    FYI, this is only a “band-aid” to the problem…

    #784142

    Sure, it’s:
    http://impalalily.cloudlevel-sites-01.co.uk/product/jimmy/

    As you will see the images all have the hover effect normally reserved for the main image (I think), and the thumbnail gallery doesn’t exist so it seems to be a php issue? I must admit I’m not that familiar with the inner workings of Enfold Woocommerce pages…

    Yes, I’m treating this and the child theme as a ‘band-aid’. I’ve checked on this forum but I can’t see any indication as to when this might be fixed properly. It has been over 3 weeks – seems like a long time…

    #784152

    @elsmore01 if you would have followed my instructions you would not have this issue. I wrote my patch is for Enfold 4.0 to 4.0.5. You have version 3.6.1. All you have to do is to update Enfold to 4.0.5.

    #784229

    @mensmaximus – my mistake. I have updated and it looks good. Thank you for your help.

    #785042

    I started regenerating thumbnails before I found this thread. Would there still be a benefit to me using your directions, or did I create a hopeless mess by already regenerating?

    • This reply was modified 3 years, 2 months ago by  anm54475.
    #785052

    @vladbejenaru nothing is lost and nothing is damaged for ever. Once Enfold will get a WooCommerce 3 compatibility update you will regenerate the thumbnails again.

    #785418

    Hello,

    I have make all by instructions . But now image is little blurry and I see now little magnifier. You can see on image.
    https://www.dropbox.com/s/3wmtcaoxcnbxydp/2017-04-30_211829.jpg?dl=0

    Is this some new thing from wooo or ….?

    #785540

    Hi,

    This link should help you: https://docs.woocommerce.com/document/fixing-blurry-product-images/

    Best regards,
    John Torvik

    #785612

    Hello,

    I have made regenerate thumbnails and that is fixed. Woocommerce is put magnifying glass that can not be removed or excluded. They put completely stupid additions.

    #785613

    @zaccc you say you followed the instructions carefully but it seems you did not. My instructions say:

    If you just want to fix the basic image issue please stick with my first solution.

    If you are curious and want to use the new zoom and lightbox feature from woocommerce continue reading.

    So if you don’t want he new features from woocommerce you should just have used my first solution.

    #786782

    hmm… my WPRocket doesn’t like any of the Woo-Enfold fixes and says no if i have the “Remove query strings from static resource” Feature activated.

    More over I am not very fond of the new Woo3 picture solution. (forward & backwards arrows are too small and so on).
    … seems I have to wait with my Woo3-Update until the Kriesi-Enfold Team comes up with a perfect solution. :-)

    Btw:
    Thank @mensmaximus !
    and a much bigger thanks in advance to the Enfold-Developers. ;-)

    #786797

    @mensmaximus Thanks so much this was a big help.

    #791617

    Hi

    I just updated my site and the small pictures under the main picture is in wrong order.
    You can se here: http://www.svenskvaxtmiljo.se/produkt/light-cubico/

    What can i do?

    #791880

    Hi Vikab,

    Can you give us temporary admin access to your website in the private content box below, so that we can have a closer look.

    Best regards,
    Victoria

    #792160

    Sure. Important to notify me when you are done.
    This password works only for today.
    /Maria

    #792443

    Hi,

    Please review the site.
    There is a big image and then below 2 rows with the images.
    That is how enfold is working now. There will be a new release soon, that would include an option to use the default WooCommerce options, if that would work better for you.

    Best regards,
    Basilis

    #792791

    @basilis
    Sounds great!
    Anything which extends the woocommerce product pages is very much appreciated. ;-)

    #792857

    Hi @e9,

    Thanks for the feedback, the next release with this functionality should hopefully be available soon.

    Best regards,
    Rikard

    #792932

    I regenerated my images, as suggested by Woocommerce, before finding the Maximus fix.

    I followed all of the steps to the fix carefully, but my images are still blurry AF. I have a small limited number of plugins (WPML, Woocommerce, and Contact).

    Will there by an update on this soon?

    #793012

    Hi mikepatten,

    The images look fine on my end. The update is coming soon. Please, bare with us.

    Best regards,
    Victoria

    #793143

    Thanks @mensmaximus, and attn: Enfold developers.
    We just began development on our webstore today. We are running the most recent versions of WordPress, Enfold, and WooCommerce. Working in Firefox, we had this same blurry image issue on the product page. Verified the problem also existed in Internet Explorer 11 and iOS 9 (Safari). The problem did not occur in Chrome.
    We used the fix originally provided by @mensmaximus in https://kriesi.at/support/topic/enfold-theme-woocommerce-product-images-not-showing-as-of-4-4-17/page/3/#post-773385, just to fix the image problem, and it worked perfectly.
    Looking forward to Enfold being fully compatible again.

    #793169

    Hi @perfectword,

    Thanks for the feedback. We are working hard on a new release which should hopefully fix all the problems with the latest versions of WooCommerce.

    Best regards,
    Rikard

    #793300

    Hi Victoria,

    I changed the default image size settings, and regenerated thumbs, which seemed to do the trick (but they are still not quite as sharp as they used to be). I’m selling art, so it helps if the images look high quality.

    Catalog images 300 × 300px Hard crop
    Single product image 600 × 600px Hard crop
    Product thumbnails 180 × 180px Hard crop

    Do you know if these are the actual default sizes from Woocommerce? I searched online and I found several sizes.

    #793493

    Hi,

    Please try the following

    Fixing Blurry Product Images

    and let us know if it solves your issues.

    Thank you very much

    Best regards,
    Basilis

    #794375

    Enfold users who have applied my patch to solve the blurry image issue in Enfold up to 4.0.5 with WooCommerce 3.0 need to remove the patch after updating to Enfold 4.0.6. Please follow this simple steps.

Viewing 30 posts - 31 through 60 (of 67 total)

The topic ‘WooCommerce 3.0.0/3.0.1 and the images issue’ is closed to new replies.