Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #644501

    Good day. I have not touched my website in a while and all of a sudden I look today and only on the home page and the news page I see this line of code:

    Warning: preg_replace(): Unknown modifier ‘b’ in /home/content/p3nexnas06_data03/15/2180215/html/wp-content/themes/enfold/includes/helper-post-format.php on line 234

    I have not updated anything prior to seeing the message. And its only on the home page and news page. So I just upgraded the theme to its newest version, but the error line of code is still showing.

    What happened to cause this, and how does it get removed?? Website URLs in the Private Content section.

    Thank you.

    #644906

    Hey santanin,

    Can you please try re-updating the theme via FTP and overwrite all files – http://kriesi.at/documentation/enfold/updating-your-theme-files/

    Best regards,
    Yigit

    #645196

    Good day. I tried to do what you said and overwrite the “enfold” folder on my server via FTP, but the error is still there. Again, it’s ONLY on the home page and news page. And it first appeared when I published a new post. After publishing a new post, the error appears on the home page and news page. Any ideas? It’s looks so bad. Thank you for your help.

    #645481

    Hi,

    Please deactivate all plugins one by one to check which one is causing this issue and let us know if this solves the problem.
    In addition to that, please let us know if we are allowed to deactivate one or more of your plugins as well for testing purposes :)

    Best regards,
    Yigit

    #645646

    Hi again. I disabled each plugin, one at a time, flushing the cache after each one, and loading the website on a Chrome Incognito window, but I still see the error. I went though all plugins. Also, I tried activating a different theme, and when I do, the error goes away. So it seems to be isolated to Enfold.

    Also, to give you more information, once I manually moved the most recent version of Enfold to my server via FTP, as you instructed, the error does go away. But the first time I publish a new post, the error returns. So once I publish a post, the error goes on the home page and the news page. But every other page is fine.

    Also, I have a child theme activated. I have the following code in the functions.php file of the child theme. I’m not sure if this has anything to do with the issue.

    <?php
    add_filter('the_excerpt', 'do_shortcode');
    add_filter('get_the_excerpt', 'do_shortcode');
    
    add_filter( 'avia_widget_time', 'enfold_customization_widget_time' );
    function enfold_customization_widget_time( $time ) {
        return get_option('date_format');
    }
    add_theme_support('avia_template_builder_custom_css');
    ?>

    Any ideas?

    Thank you.

    #645653

    Actually, I think I am narrowing it down even more for you. I get the error on all pages that I have Blog Posts being displayed. So only pages where I use the Avia Layout Builder and go to Content Elements > Blog Posts, and add that widget to the page.

    That includes the pages I list in the Private section.

    This must help you figure out the root cause, right?

    #645710

    Hi,

    We need to take a closer look at this issue please post us your login credentials (in the “private data” field), so we can take a look at your backend.

    Login credentials include:

    • The URL to the login screen.
    • A valid username (with full administration capabilities).
    • As well as a password for that username.
    • permission to deactivate plugins if necessary.

    Best regards,
    Vinay

    #645871

    Okay no problem. It’s in the private section.

    #645890

    Hi!

    I checked all settings and there is no problem with the code you added in functions.php as well the only thing i can think about is that the file from which you are getting an error may have been corrupt.

    Please download a fresh copy of Enfold theme from themeforest and upload only the file ” wp-content/themes/enfold/includes/helper-post-format.php” before uploading this file to the same location please backup the current file or rename it to something like helper-post-format.php.bakup-original-file the extension will change but no worry.

    Let us know if this resolve the issue. If not please rename the downloaded enfold folder to “enfold v3.6” upload to wp-content/themes folder and post use the FTP access so we can take it from there.

    Cheers!
    Vinay

    #646156

    Hi again. I tried downloading a new copy form ThemeForest and just moved that one file to overwrite what’s currently on the server via FTP and it still did not work. I renamed the old file to “zhelper-post-format.php”

    I also had GoDaddy do one of their special server cache flushes. But I still see the errors on the pages where I have the Blog Posts content element.

    I also moved a copy of the enfold folder from ThemeForest to the FTP and renamed it to “enfold v3.6” as you requested.

    The information you requested is in the Private section below.

    Thank you very much.

    #646943

    Good day. I just logged into the WordPress admin and saw that you have deactivated all plugins yesterday and that they are still deactivated now. Do you know when they will be activated again?

    Also, I really needed that error code off my home page, so I removed the “Blog Posts” element from the home page, so now the error code does not appear. But the error code still appears on the other 2 pages where I have the “Blog Posts” element. Links in the private section.

    Thank you again for your wonderful support.

    #647819

    Hi,

    It is caused by the unusual url inside the link format post. We shortened the url on bit.ly (http://www.americanpakistan.org/#!blank-4/xs6z6).

    Best regards,
    Ismael

    #647957

    Thank you so much! Wow I had no idea the characters/symbols in a URL would have such an effect. I’ll make sure never to link to a URL with hashtags or exclamation points. Thank you again!

Viewing 13 posts - 1 through 13 (of 13 total)

The topic ‘Weird line of code appearing only on home and news pages’ is closed to new replies.