Viewing 21 posts - 1 through 21 (of 21 total)
  • Author
    Posts
  • #1078808

    Running the latest version of Enfold, I clicked on the Update button for WordPress version 5.1.1 and the site broke, returning a 500 Internal Server Error. After some time on the phone with BlueHost (our web host), they were able to get the site back up after turning off the Enfold theme. Just turning off all plugins didn’t restore the site.

    I reinstalled WordPress 5.1 (one version back), re-activated Enfold and everything is working again.

    Can you please look into this issue between Enfold and WP 5.1.1? Credentials listed below. Thank you!

    #1078872

    In my case the WordPress 5.1.1 does not work with Enfold 4.5.4. Downgrade of Enfold to version 4.5.3 solved the issue…

    • This reply was modified 4 months ago by  stacionar.
    #1079398

    Hi,

    The problem is likely local on your installation since there’s no general problem with Enfold 4.5.4 and 5.1.1 except for a pagination issue. Please check your PHP versions, we recommend using 7.1 or higher.

    Best regards,
    Rikard

    #1079903

    My PHP version is 7.2. Never had a problem with the installation before and have been running this website with Enfold for years. If there are others experiencing a conflict, I’m not sure that it’s my installation. What is the solution? How does one fix their installation?

    #1080110

    Hi ashforthmarketing,

    Can you please check server log for error?

    Best regards,
    Victoria

    #1080554

    See private content.

    #1081280

    Hi,

    You can put it on pastebin.com for instance, then link to the paste here.

    Best regards,
    Rikard

    #1081392

    OK, here’s the link in the Private Content section below.

    #1082945

    Hi,

    Thanks for the update.

    The latest error on that log is not critical or fatal and not likely to cause an internal server error. It is also dated March 9, 2019 and completely not related to the theme.

    PHP Warning: Invalid argument supplied for foreach() in /home1/ashforth/public_html/wp-content/mu-plugins/wpengine-common/plugin.php on line 1078

    Do you have a staging site where we can replicate the issue? We don’t see any fatal errors on that log.

    Best regards,
    Ismael

    #1092077

    Here are the credentials for the staging site. It’s just a new WordPress install. What do you need me to do to set it up for you? Install Enfold? Add a duplicate copy of my site to it? Sorry, never done this before.

    #1092528

    Hi,

    Thanks for the update.

    Yes, please create a clone on a staging site and then upgrade WordPress to 5.1.1. Make sure that the debug mode is enabled.

    // https://codex.wordpress.org/Debugging_in_WordPress#WP_DEBUG_DISPLAY

    Just add this configuration in the wp-config.php file:

    define( 'WP_DEBUG', true );
    define( 'WP_DEBUG_LOG', true );
    define( 'WP_DEBUG_DISPLAY', true );
    define( 'SCRIPT_DEBUG', true );
    

    Best regards,
    Ismael

    #1093387

    OK, set up a staging site and upgraded to WordPress 5.1.1 and the latest Enfold. The site broke and I got this message:

    Internal Server Error
    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator at (Email address hidden if logged out) to inform them of the time this error occurred, and the actions you performed just before this error.

    More information about this error may be available in the server error log.

    Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

    Apache Server at ashforth.com Port 443

    #1093388

    Oh, and I don’t know how to find debug mode or change PHP files. Sorry.

    #1093810

    Hi,

    Thanks for the update.

    The site is loading properly on our end. It’s currently on version 4.5.6. Did you try to upgrade the actual site to that version? Please post the FTP details for the staging site so that we can activate the debug mode.

    Best regards,
    Ismael

    #1093991

    I did try to upgrade the actual site to 4.5.6 and it broke. Here are the FTP details.

    #1094575

    Hi,

    Thanks for the update.

    Is that the FTP details for the live site?

    Did you see any errors after the upgrade? Please enable the debug mode for the live site and then upgrade it to the latest version. You may need to enable the maintenance mode for now until we fixed the issue.

    Best regards,
    Ismael

    #1094740

    Those are the FTP details for the test site. FTP for the live site below. Currently, the test site seems to be running WP 5.1.1 and Enfold 4.5.6 just fine. Nervous about doing that on the live site.

    #1094745

    Same thing just happened with another site of mine. Upgraded to Enfold 4.5.6 and all was well – still with WP 5.1 – but when I upgraded to WP 5.1.1, the site went down. Here’s the error. I have BlueHost looking into it right now.

    Internal Server Error
    The server encountered an internal error or misconfiguration and was unable to complete your request.
    Please contact the server administrator at (Email address hidden if logged out) to inform them of the time this error occurred, and the actions you performed just before this error.
    More information about this error may be available in the server error log.
    Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.
    Apache Server at apconst.com Port 443

    #1095177

    Hi,

    Thanks for the update.

    This is most likely a server issue because a lot of users don’t encounter this kind of error after upgrading their own site. What is the current PHP version on your server? Please make sure that it is 7.1 or later.

    Best regards,
    Ismael

    #1095291

    Per an earlier post on this thread, our PHP version is 7.2. We’re going to continue with a fresh install and hope the issue resolves. Thanks for your help.

    #1095642

    Hi ashforthmarketing,

    Please, let us know if you need any more help.

    Best regards,
    Victoria

Viewing 21 posts - 1 through 21 (of 21 total)

You must be logged in to reply to this topic.