Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #1068854

    Hi there,

    My site is currently returning the following on any page where a gallery was implemented:

    Warning: count(): Parameter must be an array or an object that implements Countable in D:\home\site\wwwroot\wp-content\themes\enfold\config-templatebuilder\avia-shortcodes\av-helper-masonry.php on line 362

    The site is running PHP 7.3 and thought since I recently updated the Enfold theme thought there could be a conflict between the two, however I’ve dropped the PHP down as far as 5.6 and no matter what the warning still persists. I updated Enfold directly through WordPress, and also am now seeing the following group of warnings on WordPress’ Updates screen as well:

    Warning: Illegal string offset ‘http_code’ in D:\home\site\wwwroot\wp-content\themes\enfold\framework\php\auto-updates\class-envato-protected-api.php on line 307

    Warning: Illegal string offset ‘api_error’ in D:\home\site\wwwroot\wp-content\themes\enfold\framework\php\auto-updates\class-envato-protected-api.php on line 307

    Warning: Invalid argument supplied for foreach() in D:\home\site\wwwroot\wp-content\themes\enfold\framework\php\auto-updates\class-pixelentity-theme-update.php on line 49

    Warning: Illegal string offset ‘http_code’ in D:\home\site\wwwroot\wp-content\themes\enfold\framework\php\auto-updates\class-envato-protected-api.php on line 307

    Warning: Illegal string offset ‘api_error’ in D:\home\site\wwwroot\wp-content\themes\enfold\framework\php\auto-updates\class-envato-protected-api.php on line 307

    Warning: Invalid argument supplied for foreach() in D:\home\site\wwwroot\wp-content\themes\enfold\framework\php\auto-updates\class-pixelentity-theme-update.php on line 49

    Any ideas on how to remove the warnings, and what might have caused them in the first place?

    Thanks in advance for your help!

    Mark

    #1068935

    Hey JoeSurf,

    Please, add this code in your wp-config.php:

    
    // Turn debugging on
    define('WP_DEBUG', true);
    
    // Tell WordPress to log everything to /wp-content/debug.log
    define('WP_DEBUG_LOG', true);
    
    // Turn off the display of error messages on your site
    define('WP_DEBUG_DISPLAY', false);
    
    // For good measure, you can also add the follow code, which will hide errors from being displayed on-screen
    @ini_set('display_errors', 0);
    

    If you need further assistance please let us know.
    Best regards,
    Victoria

    #1069281

    Thank you. That worked after also downgrading the site’s PHP from 7.3 to 7.1 and clearing the cache.

    #1069286

    Hi,

    Great. Glad we could help. Please don’t hesitate to open a new thread if you need anything else.

    Have a nice day.

    Best regards,
    Ismael

Viewing 4 posts - 1 through 4 (of 4 total)

The topic ‘Warning Issue Regarding "av-helper-masonry.php"’ is closed to new replies.