Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
  • #1289272


    I have an issue with a button that invokes a video modal popup.

    When I click the button, the the modal pops up with the video embedded successfully, but it does not start playing automatically.

    These are the different URLs I have tried for the button:

    There are no javascript errors either.

    Looking at the embed code from Enfold, it doesn’t follow the embed code that YouTube expects for autostart, in particular I don’t see the ‘allow’ attribute in the code with the various values it expects.

    Here is what I am seeing with the Enfold theme code:
    <iframe class="mfp-iframe" src="" frameborder="0" allowfullscreen=""></iframe>

    Here is what YouTube expects:
    <iframe width="560" height="315" src="" title="YouTube video player" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe>

    Please advise how to get my video to play automatically.


    • This topic was modified 2 years, 8 months ago by Michael.

    Hi Michael,

    Sorry for the late reply. I don’t know if there is a solution for that unfortunately, but I’ve asked the rest of the team for help. Please reply to this thread so that it gets added back to our support queue.

    Best regards,


    Is there a place that I can submit a pull request for the change? I have corrected the embed code on the core parent theme (which will obviously break if it doesn’t get added in the next release).



    Sorry for the late reply. Our Github repo is not public, so you can’t do that yourself unfortunately. But if you share the changes you have made with us here, then I’ll pass it on to our developers.

    Best regards,


    I’m sorry, if I am contributing to your project without payment, there’s got to be some sort of compensation for it. After all, I’m paying you guys for your code. It should only go that you somehow “pay” for mine.



    Thanks for contacting us!

    Inserting the link as following in Button element works for me

    Please see my testing page in private content field.



    Try adding a time code to that like this:

    This does not work either.

    • This reply was modified 2 years, 8 months ago by Michael.


    That works for me too. I have updated my testing with the new link and attached it again in private content field below

    Best regards,


    Does not work on my end. See url in private.

    • This reply was modified 2 years, 8 months ago by Michael.


    Please update WordPress to the latest version 5.7. After updating WordPress, go to Enfold theme options > Performance and disable “JS file merging and compression”, save theme options, clear cache and check once again. After confirming that it is working correctly, you can re-enable JS file merging and compression option.

    Best regards,

Viewing 10 posts - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.