Tagged: ,

Viewing 17 posts - 1 through 17 (of 17 total)
  • Author
    Posts
  • #396601

    Hi

    I’ve inserted a number of videos on a page using the “Video” media element.
    Most videos are showing but on a few pages the video that should turn into a video player, just renders a link.

    All the videos are on Vimeo in this case (I haven’t tested youtube).

    Screenshot of two videos inserted using the same method, but one showing as a link:
    https://www.evernote.com/shard/s32/sh/ (Purchase code hidden if logged out) /4ab6d0d160b0ecdaaf694f508d292084

    Screenshot of the rendered html
    https://www.evernote.com/shard/s32/sh/ (Purchase code hidden if logged out) /dfa3edd423857c8886e92560b30c9797

    Can you tell me what’s wrong?!
    (they are inserted the exact same way: https://www.evernote.com/shard/s32/sh/ (Purchase code hidden if logged out) /03e63504ce72f71c306d088fd8742a7e)

    Thanks…

    #396976

    Hi rap!

    This has happened to a couple of customers but I haven’t been able to pinpoint what causes it though. I’m guessing it’s some kind of setting on the video. The video is not set to private is it?

    Usually this happens with youtube but in your screenshot I noticed the URL your using is vimeo.com/albums, etc etc. What happens when you link directly to the video? i.e. vimeo.com/8373728

    Regards,
    Elliott

    #397224

    I’ve tried both types of URLs. That doesn’t make any change.

    However you are a bit right about the settings. Originally the privacy settings were wrong on this one video, however after I changed it, it still didn’t work.

    So is there some kind of “caching mechanism”? Originally I didn’t think that WordPress did anything other than just wrap the url in a player, but it must somehow communicate with Vimeo if it will display a player or a link depending on the settings.

    If WordPress indeed does communicate one way or another with Vimeo (and Youtube) it would make sense to somehow cache these settings.

    Do you know if something like this is happening? The privacy settings should be correct now, however I’m still only seeing the link for one (well actually two) of the videos (out of 28).

    #397690

    Hi!

    I’ll flag this for the rest of our team to see if they have any idea on what it could be.

    Cheers!
    Elliott

    • This reply was modified 2 years, 8 months ago by  Elliott.
    #402469

    Hello, having similar problem here with this video: https://vimeo.com/118247306

    Exact same thing as Rap’s problem – the video was set as private before. Would be great if we can get it sorted soon (website to launch in a week! and didn’t seem to have this problem before.)

    Thank you.

    Uchi

    #402737

    Hi,

    Can you give us a link to your website? Admin access would be useful as well. You can post login details here as a private reply. We would like to have a deeper look into this problem.

    If it’s really a caching problem: Did you already paused caching in your caching plugins and afterwards cleared browser cache? Try to also switch off all plugins, to make sure none is causing any conflict. Are you using the newest version of WordPress and theme?

    Cheers!
    Andy

    #402761
    This reply has been marked as private.
    #402788

    Hey!

    login details are not working for me. Please check. But if the problem is solved for you, there is no reason for login in anymore, right?

    Cheers!
    Andy

    #423622

    Ok I figured it out.

    As I thought it was a caching issue. WordPress caches the video player on the first hit, so if the access settings for the video was wrong, then it won’t display the video player even though you fix the video access settings afterwards.

    It can be fixed by going directly to the database (if you’re not sure what you’re doing, please remember to backup first!!!!!). I use phpMyAdmin for this.

    1) Find the table named “wp_postmeta” (in my case I have prefixed my tables for security measures, so my table name is actually a bit longer)
    2) click on “SQL”
    3) Insert the following select statement:
    SELECT * FROM wp_postmeta WHERE meta_key like ‘%_oembed%’

    This will bring up all the cached embedded players. The meta_value field contains the player, so it should be quite easy to find the video that is not working and simply deleting the row (don’t worry, WordPress will generate a new entry the next time you visit the page and your player will be inserted correctly!).

    I have a lot of videos in my site (hosted on Vimeo) so used the following SQL to find the exact row that messed up:
    SELECT * FROM wp_yasd_postmeta WHERE meta_key like ‘%_oembed%’ and meta_value like ‘%6769%’

    (the number 6769 is part of the vimeo video ID for the video messing up, you should of course insert part of the url/ID for the video that is messing up in your case)

    Hope it helps..

    • This reply was modified 2 years, 6 months ago by  rap.
    #423684

    Hey!

    wow, glad you figured it out and thank you a lot for sharing your wisdom with us :)

    Let us know when you need some more help with the theme. We are happy to assist you.

    Regards,
    Andy

    #423868

    Hello,
    I have the same problem rap did have. I want to place video in to homepage slider but it shows just black full screen picture.
    I have tried to find wp_postmeta and solve it according to rap’s instructions. I got this error message:

    Error
    SQL query: Documentation

    SELECT * FROM wp_postmeta WHERE meta_key like ‘%_oembed%’
    LIMIT 0, 30
    MySQL said: Documentation

    #1064 – You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ‘%_oembed%’
    LIMIT 0, 30’ at line 1

    Thank you for advice

    #424089

    Hey jankund!

    I think this link is for you to find out more about the reason for this error: http://www.inmotionhosting.com/support/website/database-troubleshooting/error-1064

    Best regards,
    Andy

    #424914

    It could be due to the quotes around the %_oembed%.

    It has to be normal single quotes.

    #425034

    Hi!

    thanks a lot @rap for your help. Let us know @jankund if this helps.

    Regards,
    Andy

    #426210

    Hello, now I got this:
    Error
    SQL query: Documentation
    SELECT * FROM wp_postmeta WHERE meta_key like (_oembed)
    LIMIT 0, 30
    MySQL said: Documentation

    #1054 – Unknown column ‘_oembed’ in ‘where clause’
    Jan:-)

    #427120

    You’re using parentheses around the _oembed, it should still be single quotes :)

    But if you’re not sure what you’re doing, it’s not really a good idea to mess around with the SQL. At least I hope you’ve remembered to take a backup.

    #427186

    I will let it be. I did backup. You are right I am not sure… Thx.

Viewing 17 posts - 1 through 17 (of 17 total)

The topic ‘Video player not showing, only showing link’ is closed to new replies.