Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
  • #1102476

    <div class="avia-video avia-video-16-9 av-lazyload-video-embed " style="background-image:url('https://.../wp-content/uploads/...-teaser.jpg');" itemprop="video" itemtype="" data-original_url="https://.../wp-content/uploads/Teaser-Website-Food-TV.m4v">[video src="https://.../wp-content/uploads/Teaser-Website-Food-TV.m4v?autoplay=1" /]</div>

    WP + Enfold: Latest

    The preview image + play button shows correctly. Once clicking on the play button, only the video-shortcode is pasted instead of the html-code.

    Please help!

    • This topic was modified 10 months, 3 weeks ago by  mailworm.

    Hey mailworm,

    Could you please give us a link to your website, we need more context to be able to help you.

    Best regards,


    Hi Victoria, please see private content for login credentials. Thank you, Thomas


    Hi mailworm,

    I could not log in. I am getting an error.

    Anyway, please disable lazy loading and see if the issue persists.

    Best regards,


    Ups, sorry Victoria, backend was limited for access through german IPs only. You could try again now.

    However, I tried all combos.

    – Lazy Load + Preview Image + Video
    – Immediate Load + Preview Image + Video
    – both combo without Preview Image

    It always shows [video src="https://.../wp-content/uploads/Teaser-Website-Food-TV.m4v" /] instead of rendering the corresponding HTML.

    A child theme is in place, but nothing there is touching this or any other shortcode.
    Also already deactivated all plugins, with no effect.

    Please help/ advice.


    Uh! When I use the classic editor and use “insert theme shortcode” > media elements > video, the code pasted is [av_video ..! while the same element used in the ALB seems to insert [video … (without av_?!? However the problem at the frontend is the same. A [video .../] short code is pasted instead of HTML.

    • This reply was modified 10 months, 3 weeks ago by  mailworm.

    Uploaded the same video as mp4 instead of m4v and now the video loads. Seems, like m4v is missing in line 348 of video.php. However, it does not lazy load, though I set it to do so. It loads immediately.

    Plus the video is looping and does not stop at the end. I don’t see any option to toggle this?

    Thank you.



    Thanks for the update.

    The m4v is not included in the list supported formats by the video shortcode. You can only use mp4, ogg, web and ogv. You can also upload the video to youtube or vimeo.

    If you want to disable the loop, edit the framework > php > function-set-avia-frontend.php file. Look for the code inside the “avia_html5_video_embed” function around line 616:

    $loop = $attributes['loop'] == 1 ? 'loop' : '';

    Best regards,


    Hi Ismail,

    couldn’t this option “loop on/ off” be considered as option in a future version? I’ve seen this question asked regularly. Overriding the file will make me loose the change on update.

    However, the lazy load functionality does not work. I have added a mp4 video and set “lazy load videos” to “wait for user interaction”. Nonetheless the video is loaded immediately.

    Please advise.

    Thank you.



    couldn’t this option “loop on/ off” be considered as option in a future version?

    This is possible with the current shortcode, but you need to use youtube or vimeo. Set the loop parameter to false or 0.


    Best regards,

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.