Tagged: ,

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #1124003


    Is there a way to make a video slide play automatically once loaded? Currently when I place a video into slide #1 postion in the Fullwidth Easy Slider it requires a click by the user. I’ve tried both uploaded .mp4 and YouTube links. Autorotation is active too. Nothing seems to work. Strangely, once the video is clicked and launched it will play automatically once the slide show loops back to it no matter if it was paused or not during viewing. Any ideas what’s going on?

    Thank you!


    Hey jgdoyle1,

    Thank you for using Enfold.

    That is because of a browser policy — autoplay is disabled by default when the video is not muted or if it has an audio and for users who don’t meet the Media Engagement Index (MEI) threshold.

    // https://developers.google.com/web/updates/2017/09/autoplay-policy-changes

    Chrome’s autoplay policies are simple:
    Muted autoplay is always allowed.
    Autoplay with sound is allowed if:
    User has interacted with the domain (click, tap, etc.).
    On desktop, the user’s Media Engagement Index threshold has been crossed, meaning the user has previously played video with sound.
    On mobile, the user has added the site to their home screen.
    Top frames can delegate autoplay permission to their iframes to allow autoplay with sound.’

    Best regards,


    Hi Ismael,

    I have been following this forum topic for a few weeks now.

    The fallback response re the mobile devices not playing video seems pretty consistent and yet confusing.
    I have come across a number of sites where the video plays on both mobile and desktop.

    Like this one, for example, auto-plays on my iPhone.


    Can you clarify how this site can get it right?
    And, Is this restriction to mobile devices built into the Enfold Theme?





    And, Is this restriction to mobile devices built into the Enfold Theme?

    Yes, the background video option for the sliders and color section is disabled on mobile devices by default, so you have to add a fallback image. When the video doesn’t automatically play on desktop, then it is probably due to the browser policy mentioned above. When you do see it play on your end, it’s either the video is without sound or you’ve passed the Media Engagement Index (MEI) threshold — meaning you’ve played videos in your browser before. If you really need this to work on both desktop and mobile, try the layer slider.

    Best regards,


    hello, all of my YouTube videos, which are used as background don’t work any more either. Many come without sound and they don’t work either!
    I am not a coder who easily can manage pasting code.

    I need help – and I don’t understand, why a feature (a playing video), which is meant to enhance the experience, is actually automatically stopped!

    I think you should take your communities feedback into account. It seems there are lots of us!

    Please contact me for support!


    Hi MiaShia,

    Please open a new thread and include WordPress admin login details in private, so that we can have a closer look at your site.

    Best regards,

Viewing 6 posts - 1 through 6 (of 6 total)
  • The topic ‘Video auto-play not working on Fullwdth Easy Slider’ is closed to new replies.