Viewing 16 posts - 1 through 16 (of 16 total)
  • Author
  • #23377


    this is maybe a major bug (or feature, dunno).

    I’ve been trying to add some other plugins I’d like to use. They add another button to the MCE bar (some spare add them beside the upload button above the editor). As example, I tried 7 FLV player plugins for now (most of them current and up to date). They all add an extra button to the MCE. In every case the editor was pretty much useless and won’t render navigaiton buttons at all. Also the Avia Builder button won’t work.

    I tried to deactivate all other plugins (there are not many at the moment, only Google Docs Viewer and WPML) – the prob persists.

    I tried to switch to the WP standard theme – everything is working fine.

    I’ve made a small video showing the effects:




    I’m really stuck at this (and obviously under some time pressure). Currently I’m unable to edit my homepage (the other pages seem to work) because the visual editor (of text areas) won’t work.

    If I disable WPML (!!!), the visual editor shows up (even in Avia forms).

    I’ve made some local installations from scratch trying to reproduce the error. After adding some content manually (not by import) I installed my needed plugins. BOOM – editor corruption. Tried to allocate errors in the database directly – everything seems fine.

    Btw, I stumbled upon the bug in a previous test installation.

    So from my point of view this Avia Layout Builder is somewhat beta, unfinished or whatever. I’ve never encountered such strange behaviours. Even not with other premium themes I bought.

    Some more clear words: Do I have to throw this theme to trash? If I’m unable to use certain other plugins like WPML (ENFOLD clearly states the compatibility). Maybe I’m totally left off and every other plugin is doing something crazy… :(

    Hoping for an answer within a business day…


    Can you check the developer console please because I can’t reproduce the error: . Use Chrome and on the editor page make a right click and select “Element untersuchen”. Then click on the “Console” tab. Now open the text block element and Chrome will probably output a js error in the Console. Can you post the error message please or make a screenshot of the console. I’ll ask Kriesi to answer this thread too because only he knows the ETA of the next bug fix release.


    I love ppl trying to recreate errors with an empty page stating “everything’s fine here…” (see my other thread to this behaviour). ;)

    Ok, I should have posted this earlier – my fault:

    I’ll have a look at the avia-modal.js by myself.

    Explained: I’ve added a Text Block Element to the builder, clicked it > first error. The second pops out when clicking on the visual tab. This also happens to all other builder elements using the MCE.

    The page I’m building is somewhat bigger. If you like 2 have admin access call me in. Have to wait until friday afternoon because of showcasing to customers…


    The MCE renders fine, if I purge the database by hand (orphans, drafts & co.)!

    I’ve looked into the avia-modal.js, trying to change the callback and some other things, but it won’t do it. No quick ‘n dirty. :(

    From my point the whole modal-thing should be revised. Other plugins also require to open a modal (some of my tests render them BEHIND the avia modal which is really annoying… damn, how do I get there…) and there’s currently no management of the layers…

    Been playing around with the Visual Composer – maybe Chris should have a look at it (nesting blocks inside tabs and toggles! yeah!) :)


    I forgot: I’ll try to purge only the revisions of a post next time. I think this is maybe an issue when WP saves the post in background and modal won’t update… maybe… hard to recreate.


    Hi formateins,

    The hardest thing to do with any software is finding bugs for individual use cases. So if you can give us some specific instances, we can try re-creating them.

    With wordpress unfortunately, the flexibility of plugins doesn’t always lead to things working easily with each other and when activating, creating content and general doing those every day things that we do when creating a site stuff can go wrong with seemingly no explanation.

    At that point, we are left with try to re-create it, find the cause and then fix that cause. So in this instance, we’ve had quite a bit of testing with WPML and various other plugins. For the most part with no major issues like the whole theme breaking.

    With the builder, there will definitely be plugins that wont work with it. We can’t do anything to stop that from happening. However, everything done with the builder is just a visual representation of the shortcodes from the theme. So if you have an issue with the builder on a specific page/plugin usage you can just use regular shortcodes to create that page and get the same effects.




    As a developer (and programmer) I do know about the probs we can run into. But I’m serious about ANY issue and just to the fact that I can’t recreate a specific prob with the given information won’t stop me from trying to fix it.

    In this case I do unterstand that other plugins may break your builder. It is uncommon especially when you try to add a whole bunch of plugins and always the same error occurs.

    Have a look at the other thread:

    Another info for you:

    I reduced the amount of revisions to 3 now. And AFTER raising the autosave-value to 20 minutes (value 1200) the annoying stuff stops from happening! So I started to recreate the error/s by setting autosave to 30 secs, open up a page and start editing a toggle-block (single toggle element with working MCE). When the autosave is invoked (you can barely see this in the background) and I do close the single toggle modal with the MCE, the toggle modal (showing all toggle elements) renders corrupt to a empty value of “undefined”. If I close the page (with or without saving), the MCE renders corrupt with the shown error/s above.

    After a short view to the avia-modal.js (and some other files related to it) I do think there is something going wrong with the callback. I can’t state if this behaviour does belong to the plugin probs I encounter.

    So I pointed out every information I can provide. WordPress started from scratch, business website with at elast 3 languages, using WPML to provide more comfort to my customer instead of WP Multisite, chosen Enfold as a complete solution WITH a page builder, creating page structure, menus and all that stuff. Run into probs after adding (some well shaped) plugins, encountered probs related to the autosave feature of WP. Here we are now.

    Oh, I have to mention, the Google Docs Embedder Plugin (which adds a Button to the MCE and uses a modal) is working somehow fine. Bit it is not causing the error… ;)

    If you are unable (or any other reason you can provide) to investigate on this issue, just drop me a note. Then I can stop asking questions at this support forum.

    Thanks & regards,



    Actually we’re still waiting for Kriesi’s feedback. I sent him some mails and asked him to look into it and comment on the editor issues but I haven’t heard from him yet. Kriesi had to take care of some things in the background (server change, fixing code errors in the forum because of a php upgrade, etc.) but I really hope he’ll look into it in the next few days.

    Personally I didn’t debug the errors yet because I think Kriesi can fix bugs in the core code more efficient than we can (it’s his code and he created the template builder framework) and I’d probably need to spent some days to understand all of his core/framework code before I can even start to work on bug fixes.


    Thanks 4 the response and info.


    We have a bit more detail now and hopefully will have some more in the next few days which will lead to a fix for the next theme update. Now that our git is getting updated things should be moving along :)


    Hi formateins,

    I just set up Enfold with WPML and none of the issues you describe are present.

    Take a look : .

    Perhaps you are setting up WPML incorrectly? If you’d like, I can set it up. Please send credentials to usjahm (at) gmail (dot) com.




    WPML is set up correctly and working fine.

    More or less purging the database from orphans prevents the error from happening.

    Also, raising the autosave to 20 minutes prevents the builder especially when using tabs or toggles/accordeon getting corrupt data. This is set to a default of 160 seconds, so if you are editing a toggle as example, adding some toggles and editing the contents in a second modal AND the autosave happens, the newly created toggle is set to a value of [undefined] in the first modal. After saving the stuff the MCE won’t render correctly after a refresh of the page/post.

    I have to deactivate some (or all) plugins, edit the content again saving it and re-enable the plugins. Sometime a database purge is also necessary.

    After a look at the framework and the builder files I do understand how things work, but I don’t have that much time to investigate on these things.



    That’s a sick mix on your video, cool!

    But back to business.

    I have Chrome Dev Tools console open all the time and I spend most hours a day with this theme, making videos, this and that, and I have never yet even once saw these errors or anything like what I see in your video in 1:05-1:15 . And for you its consistent? You can always trigger the errors?… So ok. I can do exactly what you did and it will show I have no errors, but that wont get a solution..

    These are the modifications I made to the enfold , (a) /config-templatebuilder/config.php line 45 to see shortcodes in advanced layout editor; (b) /config-templatebuilder/config/meta.php 5-6 added post (c) /includes/admin/register-plugins.php 22-24 remove, 2 lines .. IE throws warnings. (d) /js/shortcodes.js. IE8 related fixes.

    I compiled 5 js files into one with closure in /config-templatebuilder/avia-template-builder/php/template-builder-class.php 186-189 i commented out all those 4 lines except 185//.. on line 185 of the same file, is where js/avia-builder.js is enqueued, and thats where i put the 5 compiled files from 185-189 .




    I think we found the problem here: The testserver didnt have enough Memory to work with, thats why different problems came up with different plugin activations.

    Since the script ram was increased to 128mb everything seems to work peachy :)

Viewing 16 posts - 1 through 16 (of 16 total)

The topic ‘Using other Plugins renders MCE useless!’ is closed to new replies.