Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #1134947

    Hello,
    we updated last version on Enfold on a client website.
    The client has recieved an email from a customer and the mail was missing even tho is a required field.

    We tried various settings and this is what happens:

    – On desktop the form works fine. If i do not compile the email field the form will not be sent.
    – On mobile if i try to send an empty form the “email field” doesn’t look as required, but is green. And in fact if i fill all the others field i’m able to send the email (without the email field filled).
    – On mobile if i fill correctly all the field and send the form i recieve the content but the email field result empty.

    I already tried to deactivate all plugins to see if something was creating the problem but the problem persist.
    It’s quite urgent.
    Thank you

    #1135293

    Hey SurigliaStudio,

    Would you mind providing a precise link to the page, showing the elements in question? We need to be able to inspect them in order to help :)

    Best regards,
    Vinay

    #1135861

    Hello Vinay,
    here you can find the form.

    If you try to check it on mobile you will be able to send the contact form without compiling the email field. And if you do i will not recieve the email anyway.
    I will give you login information aswell if you need to check the backend.

    Please let me know.
    Thank you

    #1136795

    I have the same problem: if I fill the contact form (with email field mandatory) from a pc I receive all the information, but if I fill the same form from a mobile device, the email field doesn’t appear.
    Another issue: in the Enfold settings I set the Cookie notice with a check box and a phrase referring to the privacy policy that has to be appended to contact forms: in home page (www.smartbank.it) only the check box appears (without text) while in the contact page (http://www.smartbank.it/contatti/) it appears correctly (check box + text).

    #1136803

    The second issue is solved: the option “hide labels” has not to be selected. Now it is working.

    #1137065

    Hi,

    Thank you for the update.

    You should be able to fix the email validation with this patch.

    // https://github.com/KriesiMedia/enfold-library/blob/master/temp_fixes/Enfold_4_6/contact.jshttps://github.com/KriesiMedia/enfold-library/blob/master/temp_fixes/Enfold_4_6/contact.js

    Use that to replace the config-templabuilder > aviashortcodes > contact > contact.js file.

    Best regards,
    Ismael

    #1137488

    Hi Ismael,
    today we updated with the latest release of Enfold 4.6.2 and the problem is solved.
    Thank you

    #1137575

    Hi,

    I’m glad this was resolved. If you need additional help, please let us know here in the forums.

    Best regards,
    Jordan Shannon

Viewing 8 posts - 1 through 8 (of 8 total)

The topic ‘URGENT – Contact Form email field content, missing from mobile on ENFOLD 4.6.1’ is closed to new replies.