Viewing 16 posts - 1 through 16 (of 16 total)
  • Author
    Posts
  • #1108825

    Hi,
    I’m trying to upload Orkney-light font without managing to implement it.
    I went through the process, uploaded my file, and it konw appear as Orkney – light () at the bottom of font list.

    I have then selected this typo in the theme option as Title and Body text font, but nothing appears to happen when I’m publishing a page-post.
    The published page appears as being Helvetica.

    Am doing stg wrong?
    What should I do then?

    By the way, the Orkney font doesn’t appear as a choice in the classic editor’s choice.

    Can you help?
    Thanks a lot!

    JMV

    #1108991

    Hey JM,

    Please send us a temporary WordPress admin login and login URL so that we can have a closer look. You can post the details in the Private Content section of your reply.

    Best regards,
    Rikard

    #1109024

    Hi Rikard,
    attached.
    Best regards

    #1109626

    Hi,

    Pass is not working properly – could you please check it out?

    Best regards,
    Basilis

    #1109812

    Sorry,
    mistake on the ID
    Hereunder

    #1110050

    Hi JMDP,

    Can you please share the font file with us?

    Best regards,
    Victoria

    #1110079

    Hi Victoria,
    Zip files are in the media library since the upload.
    If not, how can I send it to you?
    Best
    JM

    #1110818

    Hi JMDP,

    Here are the formats that can be used for web
    https://transfonter.org/formats

    and I do not see any of those in your media. Please get the correct font files.

    Best regards,
    Victoria

    #1113178

    Hi Victoria,
    I’ve uploaded the good Orkney file (I think) and still not able to implement the font.
    Best
    JM

    #1113309

    Hi JMDP,

    Can you disable caching and minification for now?

    Best regards,
    Victoria

    #1113314

    Hi Victoria,
    Thanks for youor answer.
    I’ve disabled cache and minification.
    By the way, if needed, you have an admin account in the feed of the discussion. See hereunder.

    As far as I understand your 2nd point, I haven’t touch the CSS (anyway, I must admit that I’m unable to do it, having no skills for that)
    Best

    #1113805

    Hi,

    THank you for the update.

    Where did you put the font files? Which directory? You can use the font face rule to register the font.

    @font-face {
      font-family: 'FontName';
      src: url('webfont.eot'); /* IE9+ Compat Modes */
      src: url('webfont.eot?#iefix') format('embedded-opentype'), /* IE6-IE8 */
           url('webfont.woff2') format('woff2'), /* Super modern browsers */
           url('webfont.woff') format('woff'), /* Modern browsers */
           url('webfont.ttf')  format('truetype'), /* Safari, Android, iOS */
           url('webfont.svg#FontName') format('svg'); /* Legacy iOS */
    }

    Adjust the font name and add the path of the font files.

    Best regards,
    Ismael

    #1114232

    Hi,
    the font files are in the media directory.
    I’ve tried your CSS rules but it seems I do do succeded to do it.
    Best Regards

    #1114551

    Hi,
    Glad to hear that it is sorted out now, unless there is anything else we can help with on this issue, shall we close this then?

    Best regards,
    Mike

    #1115293

    Hi Mike,
    no, it’s not sorted out. I changed the font in order to move on.
    “the font files are in the media directory. I’ve tried your CSS rules but it seems I do do succeded to do it.”

    A thing which puzzled me is that it seems strange to you (maybe) that the font zipfile is stored in the Media Files directory.
    But it’s you import-export feature who store them here. I just followed the process, but isn’t it the right place?

    Or stg I do not understand. (?)

    Best regards
    JM

    #1115945

    Hi,
    Sorry my misunderstanding, so I downloaded your font “orkney-light” and imported it into localhost and then I applied it to the headings which worked fine.
    When I look at your “advanced styling” I see that you have selected “default font family” for your headings and body.
    Which headings did you want to have “orkney-light”?

    Your font will not be available in the “TinyMCE Advanced”, the theme settings doesn’t change the WordPress editor settings. You can try (Purchase code hidden if logged out) -to-tinymce-advanced”>editing TinyMCE Advanced to add custom fonts, but I would recommend not using TinyMCE Advanced as it often causes issues with the Advanced Layout Builder.

    To use css to change your font-family, such as the special heading on your homepage “B I E N V E N U E” Please try this code in the General Styling > Quick CSS field or in the WordPress > Customize > Additional CSS field:

    h1.av-special-heading-tag {
    font-family: 'orkney-light' !important; 
    }

    Please see the screenshot in Private Content area.

    Best regards,
    Mike

Viewing 16 posts - 1 through 16 (of 16 total)

You must be logged in to reply to this topic.