Viewing 20 posts - 1 through 20 (of 20 total)
  • Author
    Posts
  • #490247

    Here’s the error:
    Notice: The called constructor method for WP_Widget is deprecated since version 4.3.0! Use
    __construct()
    instead. in /home2/raboneco/public_html/wp-includes/functions.php on line 3457

    I De-activated all plugins but that did not fix the error… it’s regarding php4 construct – would Enfold require an update for wp 4.3?

    I don’t think it’s enfold though, because a changed to 2015 theme, same error was there: I’ve had to do this temporary fix:

    As a temporary work around look for define( ‘WP_DEBUG’ true ); in your wp-config.php file and set that to false.

    • This topic was modified 8 years, 9 months ago by Eleina_Shinn.
    #490253

    Yes, you should update your Enfold theme.

    #490257

    Enfold is updated to the latest version already…. here’s what WordPress is saying:

    Here’s what’s going on: that message is because the theme needs to be updated. BUT you are only seeing that message because of those lines.
    define(‘WP_DEBUG’, true);
    define(‘WP_DEBUG_DISPLAY’, true);
    define(‘WP_DEBUG_LOG’, true);
    A temporary work around would be to set those to false. The warning will still be there but you wont see it. You still want the theme author to fix it but not having that displayed will buy you time till that happens.

    I’ve done the temporary work around, and now the site is okay… do you guys have another update that I don’t have?
    My Site says:
    No Updates available. You are running the latest version! (3.2)

    #490264

    Yea there is a 3.3 available on Themeforest – 2015 August 19th – Version 3.3

    Looks like you might need to manually download it and update that way, that’s what I did.

    http://themeforest.net/item/enfold-responsive-multipurpose-theme/4519990#item-description__changelog

    Looks like they released it to specifically fix the error you’re having as well as a few extras.

    • This reply was modified 8 years, 9 months ago by aoverton.
    #490270

    Ok, just so you know… I have API key on this Enfold installation and if you go to ENFOLD THEME OPTIONS – THEME UPDATES, it says “No Updates available. You are running the latest version! (3.2)” If I “Check Manually”, it also says no updates theme is up to date….

    #490272

    Then the updates through that tool don’t appear to be working properly. You can look at the ThemeForest page and see for yourself there is a version 3.3.

    By manually update I mean download the theme manually from ThemeForest yourself then update through your FTP. Scroll down this page and read or watch the video on updating the Enfold theme via FTP.

    http://kriesi.at/documentation/enfold/updating-your-theme-files/

    • This reply was modified 8 years, 9 months ago by aoverton.
    #490286

    Okay, I’ve updated to the latest version via FTP, now it says Enfold version 3.2.3…

    However, just so you know, it still doesn’t work with new WP Version 4.3 – still have to use the workaround, changing the wp-config file to debug false; I tried it.

    I’m now entirely sure, however, that it is Enfold that is the problem, although WordPress is saying that it is ??

    #490289

    Yea that’s weird, you just had me take a look and seen that I’m not actually on version 3.3 either it says 3.2.3 also. Maybe they messed up the ThemeForest download file or something else wonky is going on?

    I’d wait for a response from one of their official support staff.

    #490297

    Hi,

    just use another browser as your standartbrowser – i change to IE, and go to the admin panel an try from there to check for the update of enfold!
    it was working on me – i got now the 3.3 version.

    carsten

    #490299

    FYI – my enfold console did not shoe any updates available. My WP dashboard/updates showed enfold update available.

    Updated to 3.3 and all OK

    #490321

    Thanks to user877. Same here. Now its working.

    #490324

    Cool ;)

    #490325

    #490327

    AQWERT5Y67U8I90P-´=[0PO8I7U6Y5T4RE2W1Q’

    #490767

    I changed browsers, went to IE, manually checked for updates in Enfold Theme Options, still says I have version 3.2.3 (newest version of Enfold uploaded yesterday via FTP – should be 3.3) and problem still not resolved… have to change wp-config file to debug false; if I don’t, then website frontend and backend of WP has construct error.

    I have a lot of sites built using Enfold; all of them want to update to WordPress 4.3, but I’m afraid to do so…. can I hold off and this might get fixed with another Enfold Update?

    #491661

    Hey!

    Try updating the theme again, a new version (3.3.1) was released today.

    Cheers!
    Josue

    #500766

    I was experiencing the same issue. It appeared that they were all the same warning. There was probably 8-12 of them.

    I updated to 3.3.1 and that helped clear most of the warnings, but I’m still getting one:

    Notice: The called constructor method for WP_Widget is deprecated since version 4.3.0! Use
    __construct()
    instead. in /web/content/wp-includes/functions.php on line 3457

    I had to set WP_DEBUG in my wp-config.php file to ‘false’ to clear it. I’d prefer not to have to use this kind of workaround as a long-term solution. Any idea what I can do to clear that last warning?

    #500785

    Hi!

    The latest version of Enfold uses the __construct method to register the Widgets (as WP recommends), maybe that notice is coming from a plugin or a custom code, in any case, notices are not something to worry about, also WP_DEBUG in wp-config.php should be disabled by default and only turned on when needed.

    If you are really worried about this, hand me a temporary admin account and i’ll do a quick look to your site.

    Cheers!
    Josue

    #501231

    Alright. Thanks Josue.

    #501449

    Hi,

    Did everyone get their problems fixed?

    Regards,
    Rikard

Viewing 20 posts - 1 through 20 (of 20 total)
  • You must be logged in to reply to this topic.