Tagged: 

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #1156365

    Hello,

    I wanted to update from Enfold 3.5.4 to 4.6 via FTP. I only renamed the folders of the old and new version (WordPress is up to date). Afterwards I got the following error messages:

    Warning: require_once(includes/helper-privacy.php): failed to open stream: No such file or directory in /var/www/web22577448/html/wp-content/themes/enfold/functions.php on line 152

    Fatal error: require_once(): Failed opening required ‘includes/helper-privacy.php’ (include_path=’.:/opt/php/7.0.33/share/pear’) in /var/www/web22577448/html/wp-content/themes/enfold/functions.php on line 152

    My attempts at a solution:
    1. deactivating all plugins (renaming the folder)
    2. The folder “includes” does not exist in the new version of Enfold. Therefore I copied it from the previous version for testing.

    Both without success. Do you have an idea?
    Regards

    Joe

    #1156635

    Hey Joe,

    Did you overwrite the old folder or did you upload the new version in a new folder? If you should need any further help then please post admin login details in private so that we can have a closer look.

    Best regards,
    Rikard

    #1156706
    This reply has been marked as private.
    #1157060

    Hi Joe,

    Thanks for that. Which version of PHP are you running on the server? We recommend 7.1 or higher, if you current version is lower than that then please try to update it.

    Best regards,
    Rikard

    #1157131

    Yes, everything has the latest version. PHP ist 7.2

    #1157397

    Hi,

    Thanks for the update. Are we allowed to activate the new version in order to reproduce the problem? Also, did you try to disable all plugins to check for a conflict coming from any of them?

    Best regards,
    Rikard

    #1157800

    Hello Rikard,
    of course you are allowed to activate the new version but it is important that the website works in the end.
    I already wrote in my first post what I tried to get the problem fixed:
    “My attempts at a solution:
    1. deactivating all plugins (by renaming the plugins-folder)
    2. The folder “includes” does not exist in the new version of Enfold. Therefore I copied it from the previous version for testing.”

    Regards
    Joe

    #1158028

    Hi Joe,

    Thanks for the update, I missed the part about the includes folder not being in the new version. That is not right, it should be there. Could you try to download a fresh copy from your Themeforest account and upload the whole folder again please?

    Best regards,
    Rikard

    #1158198

    Hello,
    I checked the old folder an it seems that my FTP client didn’t transfer all the data in the folder.
    Now I downloaded the latest Enfold and transferred all the data. No errors anymore but I miss the mouseover effect with the arrow. I couldn’t find it in the settings. Did you change that or is there something not working? The effect worked with the blog images on the start page.
    Regards
    Joe

    #1158576

    Hi Joe,

    Best regards,
    Victoria

    #1158847

    Hello Victoria ,
    No errors anymore but I miss the mouseover effect with the arrow. I couldn’t find it in the settings. Did you change that or is there something not working? The effect worked for example with the blog images on the start page.
    Regards
    Joe

    #1159804

    Hi,

    Thank you for the update.

    Did you modify any of the stylesheets in the theme? We had to add the following css code to bring back the image overlay.

    .slide-image:hover .image-overlay {
    	opacity: 0.7;
    }

    Best regards,
    Ismael

    #1160394

    Hello, the code already existed in the custom CSS but now it works. Thanks for your help. :)

    Enfold and Kriesi is awesome!!! Weiter so. :)

    • This reply was modified 2 weeks ago by  joe-ell.
    #1160524

    Hi,

    I’m glad this was resolved. If you need additional help please let us know here the forums.

    Best regards,
    Jordan Shannon

Viewing 14 posts - 1 through 14 (of 14 total)

The topic ‘Update to 4.6: Warning: require_once(includes/helper-privacy.php)’ is closed to new replies.