Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #924757

    I run daily backups, so I usually have no hesitation updating plugins and themes. This time, the site gave a 500 error after I updated, and when I switched to the Twenty Seventeen theme, the site loaded just fine.

    There is an issue (at least for me) with the latest theme. I’m running the following plugins on this site:
    • Gravity Forms
    • Instagram Feed (https://smashballoon.com/instagram-feed)
    • Jetpack by WordPress.com
    The Events Calendar (https://wordpress.org/plugins/the-events-calendar/)
    • WP Super Cache

    I didn’t try deactivating plugins one-by-one…I didn’t have time. I just downloaded the backup and rolled back Enfold to 4.2. The site loads now.

    I wanted to let you all know what happened in hopes that it’s an easy fix. Or if there’s a red flag among the plugins, please let me know.

    #924760

    Yes, the same thing happened to me too. I get error message:
    “Fatal error: Can’t use function return value in write context in ../themes/enfold/header.php on line 6”

    Hopefully this will get fixed soon! I don’t have a backup so I’m screwed now.

    #924885

    Upgrade PHP version to minimum 5.6 or replace /wp-content/themes/enfold/header.php file with this one – https://www.dropbox.com/s/r389b5x4ippscyn/header.php?dl=0 to bring up backwards compatibility with older PHP versions. Please also see – https://kinsta.com/blog/php-7-hhvm-benchmarks/

    #924931

    Hi AJDesignCo,

    Did you see any error messages after you had updated?

    Thanks @markpevans for helping out, upgrading your versions of PHP might help.

    Best regards,
    Rikard

    #924932

    Hi @joannapurosto,

    Please open a new thread and include WordPress admin login and FTP details to your site in private so that we can have a closer look.

    Best regards,
    Rikard

    #925521

    Thank you Rikard! I thought I had all the sites in my hosting environment rolled forward to PHP 7, but this one was not. Problem solved. Thanks again.

Viewing 6 posts - 1 through 6 (of 6 total)

The topic ‘Update to 4.2.6 Seems to Break Site’ is closed to new replies.