Tagged: , ,

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #1104750

    Dear Support-Team

    On my wordpress Dashboard I am asked to update my .PHP. Together with the Hosting-Support, I updated the PHP but the Website did not seem to work. We then figured out that we never updated the Enfold theme and that might be a reason for the website to crash. Enfold is currently running on the version 3.1.2. So I tried to update to the new Enfold Version via uploading the .zip-File. This did not work. And it did not work either via the “update” page. Could this be because the .PHP is not up to date?

    Do you have an idea on how I could solve this problem and update both the Enfold-Theme and the PHP without the website crashing?

    Thanks for your support.

    Kind regards,
    Joel Berger

    #1104754

    Hey Joel

    It is very likely that the issue is due to the old version of the Enfold theme.

    I would solve your issue like that:
    a) Make a full backup of your website via a plugin such as UpdraftPlus.
    b) Update your PHP version via your hoster.
    c) Install the newest Enfold version via FTP (delete the existing enfold folder before so you don’t have any old files left).

    I hope that helps. Otherwise just post again here.

    Gruess
    Michi

    P.S.: I am just a participant like you and can’t see any private data you might have posted here.

    #1104837

    Hy Michael

    Thanks a lot for your input. The update worked. Now there is only a warning on top of the page:
    Warning: count(): Parameter must be an array or an object that implements Countable in /nhldata02/271/118271/data/web/sutergerteis/htdocs/wp-content/plugins/microkids-related-posts/microkids-related-posts.php on line 645

    Do you have any idea on how I could solve this issue as well?

    Kind regards / Liebe Grüsse
    Joel

    #1104887

    I managed to find a solution, so the warning does not show anymore :).

    #1104984

    Great – I guess you just deleted this plugin ;)

    #1105073

    Hy Michael :)

    I actually was able to change the code in the microkids-related-posts.php file, so it does not show the warning anymore.
    As I checked the speed of the website (https://developers.google.com/speed/pagespeed/insights/?hl=de) it seems that the theme enfold is slowing down the speed quite a bit. Do you have any Idea on how I could solve this issue as well?

    Thanks for your help.

    Kind regards,
    Joel Berger

    #1105081

    Hallo Joel

    Ich mache hier mal auf Deutsch weiter ;)

    Ah perfekt, wenn du direkt den Code im File anpassen konntest. Vermutlich wird die Warnung dann aber wieder erscheinen, wenn du das Plugin aktualisierst, nicht?

    Bezüglich PageSpeed:
    Ich vermute es handelt sich um die Website http://sutergerteis.ch – korrekt? Dass Google dort niedrige Werte anzeigt, kann zahlreiche Ursachen haben. Das Theme an sich ist aus meiner Sicht aber ziemlich schnell.

    Dinge, die mir grad in den Sinn kommen dazu:
    a) Bei welchem Hoster bist du denn? Green vermutlich…
    b) Stelle sicher, dass HTTPS die Standard-URL ist und das Protokoll HTTP/2 verwendet wird.
    c) Welche PHP-Version verwendest du?
    d) In den Debug-Infos sehe ich, dass du die JS- sowie CSS-Kompression nicht aktiv hast. Hat dies einen bestimmten Grund?
    Compress: CSS:disabled - JS:disabled

    Viele Grüsse aus Frauenfeld
    Michi

    #1105086

    Hallo Michi

    Das passt. Danke für dein erneutes Feedback :).

    Aha, das wusste ich nicht… Dann werde ich wohl das Plug-In beim nächsten Update löschen oder neu anpassen.

    Ja es geht um die Webseite https://sutergerteis.ch/.
    Vielen Dank! Habe die erwähnten Punkte angepasst. Jetzt sieht es schon um einiges besser aus.
    a) Genau. Das Hosting von unserer Webseite läuft bei Green.
    b) HTTPS hat geklappt. Wo kann ich das Protokoll HTTP/2 einstellen? Im Panel vom Hosting?
    c) PHP 7.2
    d) Habe die Debug-Infos angepasst.

    Danke für dein erneutes Feedback.

    Freundliche Grüsse
    Joel

    #1105091

    Hallo Joel

    HTTPS hat geklappt. Wo kann ich das Protokoll HTTP/2 einstellen? Im Panel vom Hosting?

    Eigentlich ja, aber frage doch direkt mal bei green nach, ob sie HTTP/2 überhaupt unterstützen. Von anderen Hostern weiss ich, dass Sie dies (noch) nicht unterstützen und alle Anfragen deshalb stets via HTTP/1.1 gehen, was um einiges langsamer ist.

    Viele Grüsse
    Michi

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.