Viewing 21 posts - 1 through 21 (of 21 total)
  • Author
  • #1376308

    Hello and good evening,
    After updating the Enfold Theme from 5.2.1 to 5.3 the side crashed. When I deactivate the WPML V 4.5.14 plug-in then the side is working.
    Thank you for your help in advance.

    • This topic was modified 1 year, 6 months ago by georgx.

    the same issue for me.
    I downgraded the PHP version in the hosting : PHP 8.0 >> 7.4
    and the site is working again.
    error message before :
    Warning: Undefined array key “fr” in …/wp-content/themes/enfold/config-wpml/config.php on line 609

    Warning: Cannot modify header information – headers already sent by (output started at …/wp-content/themes/enfold/config-wpml/config.php:588) in …/wp-login.php on line 464

    It seems like the WPML configuration in ENFOLD 5.3 is not compatible with PHP 8.0 ?????

    I hope it can help…


    Hi Georg,

    Thanks for the login details. I see that you are running the latest version of the theme, and WPML is active. I can’t see any problems on your site though, did you manage to find a solution?

    Best regards,


    Hi ppi37,

    Please open a new thread and include WordPress admin login details in private, so that we can have a closer look at your site.

    Best regards,


    Hi all,
    I have downgraded the php from 8 to 7.4.33 now it works.
    At the moment it seems that Enfold 5.3 doesn’t works together with PHP 8 and the latest version of WPML.
    Thanks again and best regards,

    • This reply was modified 1 year, 6 months ago by georgx.


    Thank you for the update.

    A lot of Enfold sites are running properly on PHP 8 without this error, so this might be an issue local to your installation. Did you enable the Maintenance Mode option from the Enfold > Theme Options panel? Line 588 of the config-wpml/config.php seems to be related to the maintenance mode option. Please try to deactivate the option temporarily, before switching again to the latest version of PHP.

    Best regards,


    Same for my sites running WPML 4.5.14 and Enfold 5.3. I’ve had to downgrade to PHP 7.4 to get the sites running again.

    PHP Fatal error: Uncaught InvalidArgumentException: Trying to read non existing property in class avia_superobject: wpml in /wp-content/themes/enfold/framework/php/base-classes/class-object-properties.php:33

    Best, Joris



    Could you please replace the content of enfold/config-templatebuilder/avia-template-builder/php/base-classes/class-object-properties.php file with –
    enfold/config-wpml/class-avia-wpml.php file with –
    enfold/framework/php/base-classes/class-object-properties.php file with –

    If you would like us to update the files for you, please post temporary WP admin logins here and if theme editor is disabled in WP dashboard, please post FTP logins as well :)

    Best regards,

    • This reply was modified 1 year, 6 months ago by Yigit.
    This reply has been marked as private.

    Hi Georg,

    I have updated the files for you. Please review your website :)

    Best regards,


    Hi Yigit,

    Thanks for your quick response/fix! Replacing the files did the trick for me.

    I presume (and hope) these fixes will be implemented in an Enfold update soon? I’ve got quite a few websites using Enfold and it’s quite cumbersome to update all files for all websites by hand.

    Best regards,


    Hi Yigt,
    Thank you for your quick answer and help.
    Now it works proberly.
    Thank you.
    Kind regards,


    Hey Georg and Joris,

    Thanks for the feedback!

    We will try to release a minor update this week :)



    The changed files did also the trick to restore our website. Our site was running on PHP 7.4 anyways, that was not the issue for our site.
    We also used this short code snippet in functions.php to remove Google Fonts (german DSGVO nightmare):

    Obviously the following line does not work anymore in 5.3 and breaks execution:
    $avia->style->print_extra_output = false;

    Any documentation/fix for what has changed that dramatically?

    • This reply was modified 1 year, 6 months ago by gejos.

    Hi @gejos,

    Please use following code instead

    function my_output_google_webfonts_script( $activate ){
      return false;
    add_filter( 'avf_output_google_webfonts_script', 'my_output_google_webfonts_script', 10, 1 );



    Hi Yigit,
    I updated the 3 files and now there is no error message with PHP 7.4 or 8.0
    But the maintenance mode doesn’t seem to work now.
    I tryed with Firefox, Chrome, and Safari and no maintenance mode even if activated.
    Can you please have a look ?
    the hosting is PHP 8.0


    Sorry Yigit,
    the maintenance mode works again.
    cache ???


    Thank you Yigit, that new code snippet fixed the remaining issue. Best regards!



    yes, probably it was the cache. Glad it is working fine now!

    You are welcome!

    Best regards,


    @yigit, this fix is still necessary? Or the newest version of Enfold includes it already?


    mistermagoo8691 this fix is already in v5.3.1.1 so you don’t need to add. If you have any further questions please create a new thread and we will gladly try to help you. Thank you for using Enfold.

    Best regards,

Viewing 21 posts - 1 through 21 (of 21 total)
  • The topic ‘Update Enfold from 5.2.1 to 5.3 doesn't work with WPML 4.5.14’ is closed to new replies.