Tagged: 

Viewing 18 posts - 1 through 18 (of 18 total)
  • Author
    Posts
  • #1003737

    Hi, after i update WordPress i also prefere to update Enfold.

    but i get follow error:

    Beim Aktualisieren von Enfold ist ein Fehler aufgetreten: Download fehlgeschlagen. Es wurde keine gültige URL übermittelt.

    Aktualisierung des Themes Enfold (1 von 1)

    Warning: preg_match() expects parameter 2 to be string, array given in /home/creati16/www/creati16.myhostpoint.ch/wordpress/wp-admin/includes/class-wp-upgrader.php on line 258

    Warning: file_exists() expects parameter 1 to be a valid path, array given in /home/creati16/www/creati16.myhostpoint.ch/wordpress/wp-admin/includes/class-wp-upgrader.php on line 258

    Warning: strip_tags() expects parameter 1 to be string, array given in /home/creati16/www/creati16.myhostpoint.ch/wordpress/wp-admin/includes/class-bulk-upgrader-skin.php on line 61
    Herunterladen der Aktualisierung von …

    Warning: parse_url() expects parameter 1 to be string, array given in /home/creati16/www/creati16.myhostpoint.ch/wordpress/wp-admin/includes/file.php on line 970

    Warning: preg_split() expects parameter 2 to be string, array given in /home/creati16/www/creati16.myhostpoint.ch/wordpress/wp-includes/kses.php on line 1325

    Warning: strtolower() expects parameter 1 to be string, array given in /home/creati16/www/creati16.myhostpoint.ch/wordpress/wp-includes/http.php on line 517

    Warning: strtolower() expects parameter 1 to be string, array given in /home/creati16/www/creati16.myhostpoint.ch/wordpress/wp-includes/http.php on line 517

    Any solution?

    #1003753

    I am getting similar errors. This is what happens to my site;

    Updating Theme Enfold (1/1)

    Warning: preg_match() expects parameter 2 to be string, array given in /home1/vincefow/public_html/vestedinterestgroup/wp-admin/includes/class-wp-upgrader.php on line 258

    Warning: file_exists() expects parameter 1 to be a valid path, array given in /home1/vincefow/public_html/vestedinterestgroup/wp-admin/includes/class-wp-upgrader.php on line 258

    Warning: strip_tags() expects parameter 1 to be string, array given in /home1/vincefow/public_html/vestedinterestgroup/wp-admin/includes/class-bulk-upgrader-skin.php on line 61
    Downloading update from …

    Warning: parse_url() expects parameter 1 to be string, array given in /home1/vincefow/public_html/vestedinterestgroup/wp-admin/includes/file.php on line 970

    Warning: preg_split() expects parameter 2 to be string, array given in /home1/vincefow/public_html/vestedinterestgroup/wp-includes/kses.php on line 1325

    Warning: strtolower() expects parameter 1 to be string, array given in /home1/vincefow/public_html/vestedinterestgroup/wp-includes/http.php on line 517

    Warning: strtolower() expects parameter 1 to be string, array given in /home1/vincefow/public_html/vestedinterestgroup/wp-includes/http.php on line 517

    #1004098

    Any Idea or solution? the path is worng but why?

    dunja

    #1004137

    I got these errors:
    Warning: Illegal string offset ‘http_code’ in /home/MYSITE/public_html/wp-content/themes/enfold/framework/php/auto-updates/class-envato-protected-api.php on line 307

    Warning: Illegal string offset ‘api_error’ in /home/MYSITE/public_html/wp-content/themes/enfold/framework/php/auto-updates/class-envato-protected-api.php on line 307

    …….and this message:
    There was an error during the enfold update. The update was not well successful. An invalid url was provided

    #1004236

    To everyone in this thread… i believe I know the aswer to all of our current theme update challenges.

    Could this be it? The link is in another thread about the compatiblity between WordPress 4.9.8 and Enfold’s latest updates.

    Here’s the link: https://kriesi.at/support/topic/ (Purchase code hidden if logged out) /

    #1004252

    Hi,

    Thank you for sharing the link, let us know if you need any further assistance.

    Best regards,
    Vinay

    #1004413

    Hey!

    Maybe the issue is caused by a known bug in the themeforest api. To fix it use the theme editor (Appearance > Editor) and edit Enfold. Go to enfold/framework/php/auto-updates/ and open the class-pixelentity-theme-update.php file. Clear the entire file (remove the code) and copy the entire code from here https://pastebin.com/raw/epetJ1SG into the blank file. Afterwards save the file and the update should work.

    You can also use ftp to update the file. Save the code from here: https://pastebin.com/raw/epetJ1SG to a file called class-pixelentity-theme-update.php. Then connect to your server via ftp, go to the directory wp-content/enfold/framework/php/auto-updates/ and overwrite the class-pixelentity-theme-update.php with the updated file you created before.

    Cheers!
    Peter

    #1005170

    Hey @dude – thank you. That worked! I’m super grateful!

    This is the first time I have ever edited anything in my editor so I was a little nervous… you made look easy. Thank you.

    #1005269

    Hi vincefowler,

    Great, glad you got it working and sorry for the problems. Please let us know if you should need any further help on the topic.

    Best regards,
    Rikard

    #1006157

    Hi @dude!! Great…it worked!!!! Thank you so much, really really gratefull!!!

    Best regards,
    Monica

    #1006245

    Hi bruttougo,

    Glad you got it working for you! :)

    If you need further assistance please let us know.

    Best regards,
    Victoria

    #1014802

    Hi,
    I’ve similar problem, even after having overwritten the file “class-pixelentity-theme-update.php”, emptied the cache and tried to update again, continue to give me this error:

    #1014804

    Best way: download new Enfold and install it. Make sure, that you use Enfold Child for you CSS. Than you can easy delete and install new.

    #1014834

    Do I have to unzip the zip file, delete the enfold folder and replace it with the new one?

    #1014861

    Hi cybernaty,

    Do I have to unzip the zip file, delete the enfold folder and replace it with the new one?

    Yes, you can do it this way. Just don’t delete the old folder at once, rename it first so it stays as a backup.

    Best regards,
    Victoria

    #1014877

    yes, unzip, delete old and install new (not overwrite – this was not working for me)

    #1014937

    I solved it, but now I have other problems with the recommended plugin for optimizing “Optimus” images. Upon activation, it sends an error.
    However it is not a problem to write here.

    Thank you so much

    #1015056

    Hi,

    Great! Please feel free to open a new thread if you need anything else. We’ll close this one for now. :)

    Best regards,
    Ismael

Viewing 18 posts - 1 through 18 (of 18 total)

The topic ‘Update Enfold’ is closed to new replies.