Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #1396299

    Uncaught SyntaxError: Unexpected token ‘<‘ (at plugin.min.js?wp-mce-49110-202011

    We have an error showing up on one of our Enfold installs. It’s the only one with this issue, and we’ve done all of the usual testing. We’ve deactivated plugins and removed all code from the child theme, cleared the server cache, cleared the browser cache, and tested on different machines… Nothing seems to fix this. I also re-installed a fresh version of WordPress and Enfold parent theme.

    What’s really odd is this is a subsite of a MultiSite network that other sites use Enfold. Only this one has errors. Plugins and themes are all shared. So, that leads me to believe it’s something local just to this subsite.

    Whenever a page, post, or other CPT, is made or edited, no matter which editor (advanced enfold, classic, or block), whenever you click the link icon in TinyMCE the box doesn’t show and the console reports another error:
    plugin.min.js?wp-mce-49110-20201110:1 Uncaught TypeError: Cannot set properties of undefined (setting ‘tempHide’)
    at tN.<anonymous> (plugin.min.js?wp-mce-49110-20201110:1:3403)
    at c.exec.<computed> (tinymce.min.js?ver=49110-20201110:2:190487)
    at pp.execCommand (tinymce.min.js?ver=49110-20201110:2:189626)
    at tN.execCommand (tinymce.min.js?ver=49110-20201110:2:346040)
    at t.cmd.t.onclick (tinymce.min.js?ver=49110-20201110:2:345166)
    at c.fire (tinymce.min.js?ver=49110-20201110:2:197006)
    at i.fire (theme.min.js?wp-mce-49110-20201110:1:28284)
    at HTMLDivElement.o (theme.min.js?wp-mce-49110-20201110:1:32492)
    at C (tinymce.min.js?ver=49110-20201110:2:10800)
    at HTMLDivElement.d (tinymce.min.js?ver=49110-20201110:2:10946)

    It’s almost like a JS file is getting run as HTML.

    If we use the basic text editor for html, that link button works great.

    Here are the details:
    Enfold 5.4
    WordPress 6.1.1
    php 8
    WP Engine as the host

    Any ideas where we need to look?

    #1396329

    Hi mgyura,

    Can you try to disable Javascript File Merging And Compression and CSS File Merging And Compression in Enfold > Performance?

    Best regards,
    Nikko

    #1396398

    Sorry, I failed to mention in my first ticket that we did that. I tweaked all theme settings to not combine css or js. I also played with where the javascript gets loaded and tested the other settings. Clearing the server cache after changing settings each time.

    I just tested again this morning and the same issue is occurring. So, it’s not something that appears to be stuck in the cache.

    #1396445

    Hi,

    Thanks for the update. Please send us a temporary WordPress admin login and login URL so that we can have a closer look. You can post the details in the Private Content section of your reply.

    Best regards,
    Rikard

    #1396452

    Thank you. Credentials are below in the private section.

    #1396636

    Hi,

    Thanks for that. I can’t find anything in the obvious places unfortunately, are we allowed to temporarily deactivate plugins and themes? Also, did you try removing the content in your footer widgets?

    Edit; please share FTP login details with us as well.

    Best regards,
    Rikard

    • This reply was modified 1 year, 2 months ago by Rikard.
    #1396658

    Thank you for your message.

    I did just try the footer widgets; there is a lot of code. I removed every widget and tried again. but ran into the same error.

    I’ve also deactivated plugins. I have not tried switching the theme. How does that work with Enfold? If I switch to 2023 from WP, will the settings save for when I switch it back? Or will the entire settings and layouts need to be rebuilt?

    #1396666

    Thank you for your help. I was able to migrate the sub-site to a development server so you can have full access to everything you need.

    When I moved it, the error is now different. No console errors, but the visual editor doesn’t load unless I publish the post. Nor can I switch to the Enfold Advance editor without first publishing the post.

    This issue gets fixed when I activate the 2023 default theme. But then shows back up when I reactivate Enfold.

    All the credentials are in the private area below. Please let me know what else I can do to assist.

    #1396721

    Hi,

    Thanks for the login details and video. I tried deactivating all plugins first of all, but some are network activated, and it seems like our account cannot access the full network. Could you give us full access, and is it ok if we deactivate all plugins on the network for testing purposes?

    Best regards,
    Rikard

    #1396732
    This reply has been marked as private.
    #1396740

    Hi,
    Thanks for the video and the login, I network deactivated the Classic Editor plugin and the issue is solved.
    This plugin is not needed and the Classic Editor option is built into the theme at Enfold Theme Options ▸ Select Your Editor ▸ Use WP Classic Editor
    Please try using the theme option for your network, I reenabled the Classic Editor plugin so please test by disabling it on the network first.
    **Update I found that your Classic Editor plugin can stay network activated if you change the theme option to Enfold Theme Options ▸ Select Your Editor ▸ Use WP Classic Editor, but I still recommend removeing the network Classic Editor plugin.

    Best regards,
    Mike

Viewing 11 posts - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.