Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #920894

    I’ve updated to the latest version and now have this error message rather than my website – can you help? I don’t programme, just update as an when required.

    Fatal error: Uncaught Error: Cannot use object of type WP_Error as array in /www/sites/6d5/8d1/www.bodylogiq.com/web/wp-content/themes/enfold/config-templatebuilder/avia-template-builder/php/asset-manager.class.php:265 Stack trace: #0 /www/sites/6d5/8d1/www.bodylogiq.com/web/wp-content/themes/enfold/config-templatebuilder/avia-template-builder/php/asset-manager.class.php(99): aviaAssetManager->generate_file(‘css’, Array, Object(WP_Styles)) #1 /www/sites/6d5/8d1/www.bodylogiq.com/web/wp-content/themes/enfold/config-templatebuilder/avia-template-builder/php/asset-manager.class.php(65): aviaAssetManager->merge(‘css’, ‘avia-merged-sty…’) #2 /www/sites/6d5/8d1/www.bodylogiq.com/web/wp-includes/class-wp-hook.php(286): aviaAssetManager->try_minifying_scripts(”) #3 /www/sites/6d5/8d1/www.bodylogiq.com/web/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(NULL, Array) #4 /www/sites/6d5/8d1/www.bodylogiq.com/web/wp-includes/plugin.php(453): WP_Hook->do_action(Array) #5 /www/sites/6d5/8d1/www.bodylogiq.com/web/wp-include in /www/sites/6d5/8d1/www.bodylogiq.com/web/wp-content/themes/enfold/config-templatebuilder/avia-template-builder/php/asset-manager.class.php on line 265

    #920896

    Hey Bodylogiq,
    Did you update Enfold to v4.2.5 via FTP?
    We are rewriting the elements and changing the structure in the /config-templatebuilder/ folder, and when you update via FTP some of the older files are being left in the folder at: /wp-content/themes/enfold/config-templatebuilder/
    The solution is to delete the /config-templatebuilder/ folder via FTP and re-upload from the new v4.2.5 theme.
    Please try this.

    Best regards,
    Mike

    #921318

    Hi,
    I have the same issue. Delete the /config-templatebuilder/ folder via FTP and re-upload from the new v4.2.5 theme seems does not fix this issue.

    Roll back the whole server image back to 4.2.4 fixed my issue.

    Cheers,
    Paul

    • This reply was modified 5 years, 11 months ago by dengpengcd.
    #921398
    #921507

    Hi Mike, I updated via wordpress and have done for a while. I’ve deleted config-templatebuilder and ftp new folder over. No change to error message. The download came via themeforest and only has today’s date, so I assume it is 4.2.5. The last download I have is dated Oct 2016 and I don’t know the version number. Before I copy those files across to the enfold folder, can you let me know if it will cause more problems and will I lose data? Thanks

    #921993

    Hi,

    Thank you for the update. As a temporary fix, please disable the new “minification” feature.

    // https://kriesi.at/support/topic/disable-new-minify-merging-for-css-and-js-avia-merged-styles/#post-921266

    Best regards,
    Ismael

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.