Viewing 30 posts - 1 through 30 (of 31 total)
  • Author
    Posts
  • #1225553

    I’m not able to see text in text block to edit it. See pictures

    Receive this error when trying to view and edit text in content box

    View post on imgur.com

    You see when you click on the content block you can’t see text.

    View post on imgur.com

    This is the content in the text box that I’m trying to edit.

    View post on imgur.com

    #1225567

    Hey Cassandra,

    Did you try disabling all active plugins to see if the issue resolves?

    Best regards,
    Jordan Shannon

    #1225574

    Ok, I just tried that and it doesn’t resolve the issue.

    #1226163

    Hi,

    Thanks for the update. You have markup in your content which doesn’t seem to do anything, for example:

    <div class="field field--name-field-banner field--type-entity-reference-revisions field--label-hidden field--item">
    <div class="flat-banner paragraph paragraph--type--flat-banner paragraph--view-mode--default">
    <div class="flat-banner__container active" style="top: 56.2667%; transition: none;">
    <div class="flat-banner__content">

    Did you copy it from somewhere maybe? The markup seems to be breaking the Layout Builder, can we copy the content to a test page in order to check if removing the extra markup helps?

    Best regards,
    Rikard

    #1226204

    What version of Enfold do you use? There was on one former version a little bug with text-block element.

    #1226464
    #1226466

    No I haven’t. I don’t do anything with coding. Only download updates from Themeforest/Envato

    #1226503

    Hi Cassandra,

    Can you please make that profile admin. We cannot see the theme options like this.

    Best regards,
    Victoria

    #1226508

    Hello Victoria,

    My apologies, I have updated the profile. Thanks!

    #1226565

    Hi Cassandra,

    Thank you.

    You should be running at least php7 for the code to work properly. Please consider upgrading your php version.

    The minimum requirement is php7.2.

    Best regards,
    Victoria

    #1226567

    Thanks. Can you please provide directions on how this can be obtained and installed? Is there a cost for this?

    #1226578

    Hi Cassandra,

    No, there is no cost really. You need to make a full website backup and ask your hosting provider to switch your php to php7.2 or higher.

    If you need further assistance please let us know.
    Best regards,
    Victoria

    #1226581

    Never mind. I contact our hosting company and they updated us to 7.3 version of PHP. This has had no affect on the issue I was experiencing. I’m still not able to view the text block. Please help!

    #1226586

    In speaking the the hosting company they said there’s a problem with the Avia Layout Builder. That I need to contact the them developers. It appears that the blame is being switched between hosting company and theme maker. Please help. I just need to get this fixed. This has been over 3 months of dealing with the issue and trying to trouble shoot before I finally brought you all in. Thanks so much!

    #1226587

    the new Enfold works perfectly under newer php version. What is your hoster? On most cases you can switch yourself the php version to newer versions on Hoster Backend.

    #1226589

    The new PHP version was updated a few moments ago. The PHP isn’t the issue it appears. We need to look at other possible causes. Bluehost is our hosting company.

    #1227039

    D3rojas, are you experiencing the same issues? I’m inclined to agree with you, the support is almost non-existent. I’m hoping they see our pleas for help and respond soon. I do like Enfold but there are several other themes where support is better and theme doesn’t require as much maintenance. Soon we’ll have no other choice but to look at implementing a new solution. Perhaps good customer service isn’t part of their commitment to their customer base.

    #1227097

    Hi Cassandra,

    Thanks for the kind words, it feels very nice to read such things.

    You have added a lot of markup in your content on the page in question, I’m guessing that you copied it from somewhere, and the markup in the content is breaking the layout builder. Please enable debug mode so that we can copy your content to a test page and clean up the markup for you: https://kriesi.at/documentation/enfold/intro-to-advanced-layout-builder/#debug-mode. If you need help with that from the non-existent support, then please give us permission to do so.

    Best regards,
    Rikard

    #1227264

    Hello Rikard,

    Thanks for your message. What I’m explaining to you all is that I have not added anything. I don’t know anything about coding and developing. All I did was update the theme and update wordpress. Apparently at some point the two stopped interacting with each other which has caused this issue. I’m afraid if I do this, I will mess the entire site up. If you know what the issue is, please just fix it. You all have the login credentials. Do I have to pay for support for this?

    Our Theme is dependent on a child theme. I don’t know if that changes things. I can’t do any debugging or coding at all. I’m sorry. This site was built by a consultant back in 2016 and handed off to us to manage. It’s supposed to be plug and play so that you don’t have to have developer skills to maintain but it’s starting to sound as if the Theme is outdated or WordPress is. It appears that maybe both have seen their better days and we need to move on to a more modern platform that doesn’t require you to have to troubleshoot to fix every other day.

    Please advise.

    Thank you!

    #1227280

    This site was built by a consultant back in 2016 and handed off to us to manage.

    Are you familiar with using a ftp client? Please go to your ftp folder of enfold-child and have a look if there are other files than :
    style.css , functions.php and screenshot.png – if so – please tell us what folders/files are in additon on the server.
    Maybe that consultant has created some own child-theme files.
    Updating via the dashboard does not overwrite these files ( and that is among other things the advantage of a child theme ) – but sometimes when essential files are updated the child-theme files had to be adjusted.
    F.e. some users got an own child-theme header.php – there was a time where the lightbox implementation changes on Enfold Parent Theme ( and that is in header.php) – so after updating the lightbox does not work anymore.
    it would help if we knew if such extra child files existed.

    Next assumption: Updating via the dashboard does not always work correctly. It seems to finish the update process successfully, but it has left write errors.
    i do always update via ftp this way: https://kriesi.at/support/topic/some-hints-and-advice-to-update-enfold/#post-1056107
    This also has the advantage that there is always a rollback in case of inconsistencies.

    If you have your child-theme – than you can try that if it brings back a working textblock alb. ( except there are the given : Maybe on top )

    #1227323

    Thanks, here are the files contained within the child theme. I don’t know how to update via FTP.

    View post on imgur.com

    #1227327

    Yes – Thats why i post the link: https://kriesi.at/support/topic/some-hints-and-advice-to-update-enfold/#post-1056107

    See documentation how it’s generally done. Easy – drag&drop. : https://kriesi.at/documentation/enfold/install-enfold-theme/#ftp-install

    if you are on the layer where enfold and enfold-child folder are siblings ( on your client see image press: “Up one level” )
    you can do it like in my link said:

    Update via ftp.

    • Rename the downloaded newest version to enfold-new
    • Upload that enfold-new folder to the themes folder
    • Rename your enfold folder to f.e. enfold-old
    • Rename your enfold-new folder to enfold
    • Check if all your existing settings work to your full satisfaction.

    Yes – then stop here

    No ( rollback )

    • rename back the enfold folder back to enfold-new
    • rename the enfold-old folder back to enfold
    #1227330

    If I do that I’m afraid I’ll mess something up and the whole site will be down. I guess I’ll have to look at other ways. Appreciate the feedback even if it didn’t help. Have a great rest of your week and take care!

    #1227343

    It would help if you were willing to follow the instructions. It’s uncertain if it will solve the problem, but at least it will help you to avoid writing mistakes or orphaned older files.

    Through this procedure, I think I’ve explained it well, you have exactly this safety in the backhand – to return to the previous state.
    The trick on this is not to overwrite the existing enfold folder but to upload a new one with a different name ( enfold-new). When this is done only a double renaming on the ftp folder does change the enfold parent themes. The existing is renamed to enfold-old and the newly uploaded now is renamed to enfold. From this moment the newest is the source for the enfold-child ( because that is the reference : then name of the folder: enfold ).

    After all, I gave you the links to help you get ahead here.
    My kind of help is always the help for self-help – under the aspect of the steep learning curve. If you always want to be dependent on help from others, you can do so.
    Dito: Have a great rest of your week and take care!

    #1227487

    Hi Cassandra,

    Please enable debug mode so that we can copy your content to a test page and clean up the markup for you: https://kriesi.at/documentation/enfold/intro-to-advanced-layout-builder/#debug-mode. If you need help with that from the non-existent support, then please give us permission to do so.

    If you don’t give us permission for what I asked above then we can’t help you out, just say yes or no. You don’t need to pay anything extra for this.

    Best regards,
    Rikard

    #1227524

    Hello Rikard,

    You do have my permission to enable debug mode so that you can clean up the mark-up. Please and thank you so much!

    Let me know if there’s anything else I can do to help. I’m sorry my developer skills are so limited. I do plan to take some classes soon.

    #1227870

    Hi,

    Thanks for that, I cleaned up massive amounts of unnecessary and unclosed html markup and the text blocks are working again. Please see private. I would advice you to keep your layouts a bit more compartmentalised, so an image would use the image element instead of being added into a text block, and the same thing goes for headers which can use the Special Heading element. As for you text then I would suggest that you use a separate Text Block element for each block or paragraph of text.

    If you need help with moving the working content on the test page in private to your live page then please let us know.

    Best regards,
    Rikard

    #1228336

    Hello Rikard,

    Unfortunately, I’m still not able to see information in content box. It still just says “Click here to add your own text”. I’m not certain what is going on. Are you able to do what Guenni007 has suggested? Maybe that will fix it. Otherwise I’ll have to hire an outside consultant to fix it. Thanks again for all your help! I truly appreciate you trying even if it didn’t fix the issue. It was a very nice gesture.

    #1228582

    Hi Cassandra,

    Are you still looking at the live page? Please look at the test page I created and linked to in my previous reply, I’ll link to it in this reply as well in private. The text blocks are working on that page: https://imgur.com/a/tdvZcRG. All you need to do is to clean up the design or layout so that it looks the way you want it to, then we can copy all the shortcodes from the test page to the live page. Or delete the old page and give the new one the same name and permalink. There’s no need to hire any consultants :-)

    Best regards,
    Rikard

    #1228626

    Hello,

    Thanks so much. I am able to view the content in the text block. This is great! I will go with your second option. Delete old page and use the page you created as a test page. Again, I truly appreciate the help. I have no idea how or why this changed. All of a sudden I did an update to Theme and WordPress and it just stopped working. All this has been very helpful information.

    Thanks again!

Viewing 30 posts - 1 through 30 (of 31 total)

You must be logged in to reply to this topic.