Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #1255323

    Hi,

    I am using the Google Font Monserrat 400 / 500 / 600 / 700 normal. Also downloaded and installed locally via the Enfold Font Mgr and that works fine.
    Have also been doing some performance tuning and noticed that Monserrat seems to be a rather fat font. Each of these 4 styles has a TTF of about 240KB so I end up with about 1MB. I guess that I can somehow optimize that.

    So I used FontSquirrel (https://www.fontsquirrel.com/tools/webfont-generator) to convert these TTFs to the WOFF equivalent.
    The generated WOFFs are only 33KB per font style.

    I created a ZIP containing:
    montserrat-medium-webfont.woff
    montserrat-regular-webfont.woff
    montserrat-semibold-webfont.woff
    montserrat-bold-webfont.woff

    When I import this ZIP with the Enfold font-manager, it only seems to import the 400 style.
    The font manager displays:

    Font: Montserrat ( font-family: montserrat )
    normal: 400

    Is there a specific reason for this? Do you recommend a different way to get the WOFFs installed?

    Thank you,
    Dimitri

    • This topic was modified 1 year, 3 months ago by  DimitriMTM.
    #1256070

    Could someone have a look at this question pls?

    Thank you, D

    #1256550

    Hi,

    Thank you for the inquiry.

    The custom font manager follows certain rules when uploading a new font, which depends a lot on the information in the zip and files inside that zip file, so changing the file structure or creating your own from scratch may cause the font uploader to fail.

    Have you tried using the @font-face rule instead?

    // https://www.w3schools.com/cssref/css3_pr_font-face_rule.asp

    Best regards,
    Ismael

    #1256994

    Hi Ismael,

    It’s fixed.

    @fontface worked when I explicitly mentioned it in the HTML/CSS code. However the TTF was also still being picked up.
    Now with your comments re: the Font Manager and specific rules, I had a look at the filenames when you create the ZIP download package with Google Fonts. When I used the exact same filenames but with the WOFF2 extension and imported that ZIP file again with the Enfold Font Manager it works.

    Thanks for the hint.

    Cheers, D

    #1256997

    BTW has a huge impact on my Google PageSpeed mobile score. From the 20-30 range to 70+…

    Cheers, D

    #1257155

    Hi DimitriMTM,

    Glad you got it working for you! :)

    If you need further assistance please let us know.

    Best regards,
    Victoria

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.