Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #318923

    Hi,

    Can you please provide a step-by-step instruction to translate things like ‘read more’ and ‘comments’ into Dutch?

    I’ve searched the forums and found some advice to use the Codestyling Localization plugin, and I did, but everything seems to be fine there: when I use this plugin and go to the translation page of the Enfold theme, I can see the Dutch .mo and .po files (nl_NL.mo and nl_NL.po) and the terms like ‘read more’ and ‘comments’ are translated. To be sure I also regenerated the .po file. Still no luck.

    Where do I need to set the language to Dutch? In the config file I changed define ('WPLANG', ''); to define ('WPLANG', 'nl_NL'); but no luck.

    I really don’t have a clue where to start, so any help will be appreciated. Thnx in advance!

    Marc

    • This topic was modified 9 years, 8 months ago by Marc Bijl.
    #319020

    Hey Marc!

    Thank you for using Enfold.

    Install the plugin, go to Tools > Localization and select “Themes”. Then search for “Enfold” in the list and click on “Add new language” or select the Deutsch/Deutschland. Click on “Rescan” to fetch all text strings. Then click on “Edit” and translate the required strings from the “avia_framework” textdomain. At least click the “create mo file” button next to the “Textdomain” selection dropdown (top left corner).

    Regards,
    Ismael

    #319098

    Hi Ismael, thnx for the reply.

    I followed your instructions step-by-step, but there’s still the ‘Read more’ text on my blog page:
    http://www.marcbijl.nl/blog

    When I go to Tools > Localization and select the Themes tab, I see this info for the Enfold theme:

    Textdomain: avia_framework
    Version: 2.9.2
    State: deactivated

    Can it be that the State needs to be ‘activated’?
    Though I have no clue how to achieve that…

    #319106

    Hmm, just edite wp-config.php and changed define ('WPLANG', ''); into define ('WPLANG', 'nl_NL'); but that doesn’t make any difference so far…

    #319625

    Hi!

    Is your Dashboard in Dutch? can you create us an admin account?

    Cheers!
    Josue

    #319640
    This reply has been marked as private.
    #320238

    Hi Marc!

    That means your installation is set to Dutch but doesn’t have the Dutch translation files, therefore it is unable to translate those WP strings (read more, etc). I’d suggest re-installing WordPress using a copy from here:
    http://nl.wordpress.org/

    Cheers!
    Josue

    #320361

    Allright, thnx!
    I’ll give that a try.

    To keep my theme, child theme (including custom css), plugins, and the content of my website: can I simply overwrite the WP core files with the core files of the Dutch pack? Or do I need to start from scratch, and reinstall all the plugins, recreate all the content, and adjust the the theme again?

    Cheers,
    Marc

    #320685

    Hey Marc!

    You’d just need to upload wp-content/languages from the Dutch WordPress folder.

    Regards,
    Josue

    #320731

    Hi Josue,

    Thnx mate, it worked! I went to nl.wordpress.org, downloaded the whole lot, did a complete overwrite of all the files through FTP (the Dutch site told me to do so), logged in, and set the language to Dutch in the Admin area (General settings, if I’m not wrong…). In the wp-config.php file I also changed define ('WPLANG', ''); into define ('WPLANG', 'nl_NL'); but that should not be necessary – says the language setting option in the Admin area.

    Anyway, my site seems to be in Dutch now, great!

    Topic closed, cheers!
    Marc

    #320754

    You are welcome Marc, glad to help :)

    Regards,
    Josue

    #320755

    You are welcome Marc, glad to help :)

    Regards,
    Josue

Viewing 12 posts - 1 through 12 (of 12 total)
  • The topic ‘Translate things like 'read more', 'comments' etc to Dutch’ is closed to new replies.