Viewing 20 posts - 1 through 20 (of 20 total)
  • Author
    Posts
  • #1360627

    Alexander Baum

    Hallo,
    wir wollten gerade Euer Theme installieren. Leider kommt es zu einem Fehler.

    Könnt Ihre das bitte prüfen.

    Danke Alexander Baum

    Wenn du Hilfe bei diesem Problem suchst, wirst du möglicherweise nach einigen der folgenden Informationen gefragt:
    WordPress-Version 6.0.1
    Aktives Theme: Enfold (Version 5.1.1)
    Aktuelles Plugin: (Version )
    PHP-Version 8.0.20

    Fehler-Details
    ==============
    Ein Fehler vom Typ E_ERROR wurde in der Zeile 62 der Datei /var/www/vhosts/26164.s1.creoline.cloud/httpdocs/wp-content/themes/enfold/config-layerslider/LayerSlider/assets/classes/class.km.autoupdate.v3.php verursacht. Fehlermeldung: Uncaught Error: Call to undefined function extract() in /var/www/vhosts/26164.s1.creoline.cloud/httpdocs/wp-content/themes/enfold/config-layerslider/LayerSlider/assets/classes/class.km.autoupdate.v3.php:62
    Stack trace:
    #0 /var/www/vhosts/26164.s1.creoline.cloud/httpdocs/wp-content/themes/enfold/config-layerslider/LayerSlider/assets/classes/class.km.autoupdate.plugins.v3.php(22): KM_UpdatesV3->__construct()
    #1 /var/www/vhosts/26164.s1.creoline.cloud/httpdocs/wp-content/themes/enfold/config-layerslider/LayerSlider/assets/init.php(94): KM_PluginUpdatesV3->__construct()
    #2 /var/www/vhosts/26164.s1.creoline.cloud/httpdocs/wp-content/themes/enfold/config-layerslider/LayerSlider/layerslider.php(65): require(‘…’)
    #3 /var/www/vhosts/26164.s1.creoline.cloud/httpdocs/wp-content/themes/enfold/config-layerslider/config.php(418): include_once(‘…’)
    #4 /var/www/vhosts/26164.s1.creoline.cloud/httpdocs/wp-includes/class-wp-hook.php(307): Avia_Config_LayerSlider->handler_include_layerslider()
    #5 /var/www/vhosts/26164.s1.creoline.cloud/httpdocs/wp-includes/class-wp-hook.php(331): WP_Hook->apply_filters()
    #6 /var/www/vhosts/26164.s1.creoline.cloud/httpdocs/wp-includes/plugin.php(476): WP_Hook->do_action()
    #7 /var/www/vhosts/26164.s1.creoline.cloud/httpdocs/wp-settings.php(598): do_action()
    #8 /var/www/vhosts/26164.s1.creoline.cloud/httpdocs/wp-config.php(78): require_once(‘…’)
    #9 /var/www/vhosts/26164.s1.creoline.cloud/httpdocs/wp-load.php(50): require_once(‘…’)
    #10 /var/www/vhosts/26164.s1.creoline.cloud/httpdocs/wp-admin/admin.php(34): require_once(‘…’)
    #11 /var/www/vhosts/26164.s1.creoline.cloud/httpdocs/wp-admin/themes.php(10): require_once(‘…’)
    #12 {main}
    thrown

    #1360696

    Hi Alexander,

    Please send us a temporary WordPress admin login and login URL so that we can have a closer look. You can post the details in the Private Content section of your reply.

    Best regards,
    Rikard

    #1360733

    Alexander Baum

    Hello, here is the access.

    br Alexander

    #1360752

    Hi,

    Thanks for that. I tried activating Enfold, but the site returns a critical error message. Do you have a backup which you could restore? Also, do you have server error logs which you could share with us?

    Best regards,
    Rikard

    #1360763

    Alexander Baum

    Hello Rikard,
    since WP6.0 there is an automatic recovery mode in case of errors in WP. In this case, the theme caused this error. The error description is in the first post of the ticket.
    The site is now in recovery mode. The login is active.

    Greetings Alexander

    #1360773

    Hi,

    Thanks for the update. Did you try to deactivate all plugins, then activate the theme?

    Best regards,
    Rikard

    #1360800

    Alexander Baum

    Hello, all plugins are disabled. The error remains unchanged. see below

    Wenn du Hilfe bei diesem Problem suchst, wirst du möglicherweise nach einigen der folgenden Informationen gefragt:
    WordPress-Version 6.0.1
    Aktives Theme: Enfold (Version 5.1.1)
    Aktuelles Plugin: (Version )
    PHP-Version 8.0.20

    Fehler-Details
    ==============
    Ein Fehler vom Typ E_ERROR wurde in der Zeile 62 der Datei /var/www/vhosts/26164.s1.creoline.cloud/httpdocs/wp-content/themes/enfold/config-layerslider/LayerSlider/assets/classes/class.km.autoupdate.v3.php verursacht. Fehlermeldung: Uncaught Error: Call to undefined function extract() in /var/www/vhosts/26164.s1.creoline.cloud/httpdocs/wp-content/themes/enfold/config-layerslider/LayerSlider/assets/classes/class.km.autoupdate.v3.php:62
    Stack trace:
    #0 /var/www/vhosts/26164.s1.creoline.cloud/httpdocs/wp-content/themes/enfold/config-layerslider/LayerSlider/assets/classes/class.km.autoupdate.plugins.v3.php(22): KM_UpdatesV3->__construct()
    #1 /var/www/vhosts/26164.s1.creoline.cloud/httpdocs/wp-content/themes/enfold/config-layerslider/LayerSlider/assets/init.php(94): KM_PluginUpdatesV3->__construct()
    #2 /var/www/vhosts/26164.s1.creoline.cloud/httpdocs/wp-content/themes/enfold/config-layerslider/LayerSlider/layerslider.php(65): require(‘…’)
    #3 /var/www/vhosts/26164.s1.creoline.cloud/httpdocs/wp-content/themes/enfold/config-layerslider/config.php(418): include_once(‘…’)
    #4 /var/www/vhosts/26164.s1.creoline.cloud/httpdocs/wp-includes/class-wp-hook.php(307): Avia_Config_LayerSlider->handler_include_layerslider()
    #5 /var/www/vhosts/26164.s1.creoline.cloud/httpdocs/wp-includes/class-wp-hook.php(331): WP_Hook->apply_filters()
    #6 /var/www/vhosts/26164.s1.creoline.cloud/httpdocs/wp-includes/plugin.php(476): WP_Hook->do_action()
    #7 /var/www/vhosts/26164.s1.creoline.cloud/httpdocs/wp-settings.php(598): do_action()
    #8 /var/www/vhosts/26164.s1.creoline.cloud/httpdocs/wp-config.php(76): require_once(‘…’)
    #9 /var/www/vhosts/26164.s1.creoline.cloud/httpdocs/wp-load.php(50): require_once(‘…’)
    #10 /var/www/vhosts/26164.s1.creoline.cloud/httpdocs/wp-admin/admin.php(34): require_once(‘…’)
    #11 /var/www/vhosts/26164.s1.creoline.cloud/httpdocs/wp-admin/themes.php(10): require_once(‘…’)
    #12 {main}
    thrown

    #1360807

    Hi,

    Thanks for contacting us!

    Could you please post FTP logins here privately as well?

    Cheers!
    Yigit

    #1360810

    Alexander Baum

    Hello, the FTP access has been created.

    Br Alexander

    #1360843

    Hi,

    Thanks for the details. I tried uploading a fresh copy of the theme, but I didn’t make any difference unfortunately. Could you try using a different PHP version to see if that changes anything please? 7.4 for example.

    Best regards,
    Rikard

    #1360858

    Alexander Baum

    Hi Rikard,
    changing the PHP version was successful. The theme and all plugins could be activated.

    Will you offer a solution for PHP 8.x.x?

    Greetings Alexander

    #1360866

    Hi,

    Great, I’m glad to hear that it’s working using 7.4. I’m not sure if we can offer a solution though, since it’s not a general problem with the theme. I’ve been running the theme on PHP 8.x.x for months now without any problems, both on local and live installations. Are you ok with 7.4 for now?

    Best regards,
    Rikard

    #1361060

    Alexander Baum

    Hello Ricard,
    thanks for your support. I will ask the hosting provider and WP about the problem with PHP 8.x.x.
    I will write you the result later.

    Alexander

    #1361087

    Hi,

    Thanks for the update, we’ll keep this thread open for you.

    Best regards,
    Rikard

    #1361316

    Alexander Baum

    Hi Rikard,
    I got a reply from the hoster. Unfortunately, I cannot write directly to the plug-in provider. Can you please do this?

    Br Alex

    >>>>>>>>>>>>>>>
    Sehr geehrter Herr Baum,

    vielen Dank für Ihre Rückmeldung.

    Sofern Sie die aktuellste Version von WordPress und die aktuellste Version von Layerslider installiert haben, wird die Unterstützung von PHP 8 vom Plugin-Herstellers versichert.
    https://kreatura.ticksy.com//ticket/3071227/

    Falls Sie den bereits genannten Fehler mit aktiviertem PHP 8 weiter erhalten, empfehle ich Ihnen PHP 7.4 weiterzuverwenden.

    Unglücklicherweise handelt es sich bei dem von Ihnen beschrieben Verhalten um einen Fehler, resultierend aus einem Drittanbieter-Plugin oder Drittanbieter-Theme.
    Leider kann ich Ihnen für Drittanbieter Erweiterungen keine Unterstützung durch unseren Support anbieten.

    Daher muss ich Sie bedauerlicherweise bitten, sich direkt an den Plugin-Hersteller kreatura zu wenden.
    >>>>>>>>>

    #1361326

    Hi,

    Thanks for the update. Are you referring to the LayerSlider plugin? If so, then that is bundled with the theme, and it’s working on all installations I’ve seen running PHP 8.x.x, so it’s not a general problem with the theme or LayerSlider. We can’t say why this problem is happening on your site unfortunately, but you could try to deactivate the bundled LayerSlider under Enfold->Layout Builder, to see if that makes any difference. Look for the Integrated (Bundled) LayerSlider Plugin option.

    Best regards,
    Rikard

    #1361329

    Alexander Baum

    Hello Ricard,
    I have now deactivated the slider plug-in and switched the hosting back to 8x.x.
    An error of the Theme Plug-In is now caused again.

    Here is the error message.

    Greetings Alexander

    >>>>>>>>>>>>>>>>>>>>>>>
    Wenn du Hilfe bei diesem Problem suchst, wirst du möglicherweise nach einigen der folgenden Informationen gefragt:
    WordPress-Version 6.0.1
    Aktives Theme: Enfold (Version 5.1.1.1-image) Aktuelles Plugin: (Version ) PHP-Version 8.0.20

    Fehler-Details
    ==============
    Ein Fehler vom Typ E_ERROR wurde in der Zeile 38 der Datei /var/www/vhosts/26164.s1.creoline.cloud/httpdocs/wp-content/themes/enfold/css/dynamic-css.php verursacht. Fehlermeldung: Uncaught Error: Call to undefined function extract() in /var/www/vhosts/26164.s1.creoline.cloud/httpdocs/wp-content/themes/enfold/css/dynamic-css.php:38
    Stack trace:
    #0 /var/www/vhosts/26164.s1.creoline.cloud/httpdocs/wp-content/themes/enfold/includes/admin/register-dynamic-styles.php(234): require()
    #1 /var/www/vhosts/26164.s1.creoline.cloud/httpdocs/wp-content/themes/enfold/functions.php(781): avia_prepare_dynamic_styles()
    #2 /var/www/vhosts/26164.s1.creoline.cloud/httpdocs/wp-includes/class-wp-hook.php(307): avia_custom_styles()
    #3 /var/www/vhosts/26164.s1.creoline.cloud/httpdocs/wp-includes/class-wp-hook.php(331): WP_Hook->apply_filters()
    #4 /var/www/vhosts/26164.s1.creoline.cloud/httpdocs/wp-includes/plugin.php(476): WP_Hook->do_action()
    #5 /var/www/vhosts/26164.s1.creoline.cloud/httpdocs/wp-settings.php(598): do_action()
    #6 /var/www/vhosts/26164.s1.creoline.cloud/httpdocs/wp-config.php(79): require_once(‘…’)
    #7 /var/www/vhosts/26164.s1.creoline.cloud/httpdocs/wp-load.php(50): require_once(‘…’)
    #8 /var/www/vhosts/26164.s1.creoline.cloud/httpdocs/wp-login.php(12): require(‘…’)
    #9 {main}
    thrown

    #1361354

    Hi,

    Thanks for the update. We would like to check the backend of your site a bit more, but it’s not possible to login because of the fatal error message. Could you change the PHP version back so that we can login please?

    Best regards,
    Rikard

    #1361359

    Alexander Baum

    Hello Ricard,
    I changed the PHP version again.

    Br Alex

    #1361373

    Hi Alex,

    Thanks for that. I can’t find any obvious reason to these errors unfortunately. Do you have the possibility to try other PHP versions, like 8.0.1x or 8.1.xx for example? Like I stated before, I’m running the theme without any problem on different PHP 8.x.x versions. Locally I’m running 8.0.19, and my live test site is running 8.1. I’ve also tested the live site with PHP 8.2.

    Best regards,
    Rikard

Viewing 20 posts - 1 through 20 (of 20 total)

You must be logged in to reply to this topic.