Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #1154296

    REQUIRED: Text Domain: is missing from your style.css header.
    Warning: More than one text-domain is being used in this theme. This means the theme will not be compatible with WordPress.org language packs.
    The domains found are avia_framework, woothemes, wordpress-importer, envato, , tgmpa, plugindomain, avia_builder, woocommerce, LayerSlider, installer, Layer
    WARNING: The theme uses the add_shortcode() function. Custom post-content shortcodes are plugin-territory functionality.
    WARNING: The theme is using #wpadminbar. Hiding the admin bar is not allowed.
    WARNING: Found wp_deregister_script in framework/php/function-set-avia-frontend.php. Themes must not deregister core scripts.
    Line 1566: if($deregister) wp_deregister_script( $handle );
    WARNING: Found wp_deregister_script in config-layerslider/LayerSlider/wp/scripts.php. Themes must not deregister core scripts.
    Line 52: wp_deregister_script(‘jquery’);
    Line 187: wp_deregister_script(‘jquery’);
    WARNING: Found a translation function that is missing a text-domain. Function esc_attr_e, with the arguments ‘Move up’
    WARNING: Found a translation function that is missing a text-domain. Function esc_attr_e, with the arguments ‘Move down’
    WARNING: Found a translation function that is missing a text-domain. Function esc_attr__, with the arguments ‘Insert Video’
    WARNING: Found a translation function that is missing a text-domain. Function _n_noop, with the arguments ‘This theme requires the following plugin: %1$s.’, ‘This theme requires the following plugins: %1$s.’

    and plus a lot more

    #1154297

    Any suggestions?

    #1154537

    Hi,

    What is your question?

    Best regards,
    Rikard

    #1154637

    Questions is Why am I getting these warnings and how to correct them.

    • This reply was modified 1 week, 3 days ago by  sag.
    #1154855

    Hi,

    What are you testing with and why do you need to correct them? Is something not working as it should in the theme?

    Best regards,
    Rikard

    #1155078

    I am using theme check plug in, are these errors common to this theme?
    why do I want to correct them? I guess when I see so many warnings I question what else Is wrong and I am trying to be proactive before a problem arises.
    Thank you for asking.

    #1155181

    Hi,

    Ok, I can address the first two for example:

    Warning: More than one text-domain is being used in this theme. This means the theme will not be compatible with WordPress.org language packs.
    The domains found are avia_framework, woothemes, wordpress-importer, envato, , tgmpa, plugindomain, avia_builder, woocommerce, LayerSlider, installer, Layer

    Our theme is not available on wordpress.org, we have our own language files.

    WARNING: The theme uses the add_shortcode() function. Custom post-content shortcodes are plugin-territory functionality.

    The theme uses shortcodes yes, otherwise you wouldn’t be able to use the Layout Builder.

    If you don’t want warnings like these they I think you would have to use a plain theme from wordpress.org.

    Best regards,
    Rikard

    #1155184

    Thank You for your response and clarifying the warnings. I am just making sure that the template is being used the way it is intended and there is no user errors involved. This subject is closed.

    #1155293

    Hi,

    Thanks for the update, I’ll close this thread for now then. Please open a new thread if you should have any further questions or problems.

    Best regards,
    Rikard

Viewing 9 posts - 1 through 9 (of 9 total)

The topic ‘Theme Check reveals the problems shown below.’ is closed to new replies.