Tagged: , ,

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #634114

    Hi,

    My site works on desktop and tablet, but the theme appears to be broken on mobile. Any suggestions on what would cause this or how to fix it?

    Thanks!

    #634161

    Hey dcembitterment,

    The mobile version appears fine on my end, please elaborate the issue what browser or device you are using and which part is exactly appears to be broken?

    Best regards,
    Vinay

    #634847

    Hi Vinay,

    After reading your response, I cleared my iOS cache for Safari, which is the browser I’m using on my iPhone. I’m still encountering the same issues. Instead of a static homepage, it’s displaying a bare-bones version of my blog page. Also, when I navigate to a subpage, the problem persists, and code is visible. I just had a friend confirm that he is seeing the same thing on Android.

    I have taken screenshots but cannot figure out how to upload them.

    Please advise.

    #635002

    Hi,

    I checked on my android phone and i was able to reproduce the issue. I can conform this is not Enfold related and it looks like in your hosting options somewhere you have selected to make the site mobile friendly so it is forcing a default template or the site is using a 3rd party plugin. Please check in hosting control panel if there are any such options to disable it or better yet contact the hosting company to disable this option on Cpanel.

    Best regards,
    Vinay

    #636477

    Hello,

    I checked with my theme, and their support provided the solution listed below. Can you please implement it, since this is a problem that many users seem to be encountering with this theme?

    Thanks,
    Eric

    I carefully checked the settings of the theme, but I could not find anything wrong. After that, checked in google about similar problems and it seems that a lot of users are facing the same issue. In most cases the problem is resolved as explained in the article:

    https://kriesi.at/support/topic/responsive-problem-on-mobile-display-enfold-theme/

    Simply said, you should add the following lines in Quick CSS in Enfold theme options under General Styling tab

    Code:
    @media only screen and (max-width: 767px) {
    .flex_column { width: 100% !important; margin-left: 0; }}

    I am afraid i am not a CSS specialist and I am not sure how exactly this will affect the theme, so you should better contact again the theme developers again and ask them for advice how exactly should be done and what will be the effect.

    If you need our assistance after that, feel free to contact us again.

    #637269

    Hi,

    Can you reproduce the issue on our demos? http://kriesi.at/themes/enfold/

    On mobile view, it seems to switch to a “mobile-theme”. Is this a plugin? You can see that the html is completely different from enfold:

    http://imgur.com/nqlanW8

    Best regards,
    Ismael

    #637436

    Hello,

    Here is the reply from the people at my hosting service. Can you please apply this fix to my site in the correct place?

    I carefully checked the settings of the theme, but I could not find anything wrong. After that, checked in google about similar problems and it seems that a lot of users are facing the same issue. In most cases the problem is resolved as explained in the article:

    https://kriesi.at/support/topic/responsive-problem-on-mobile-display-enfold-theme/

    Simply said, you should add the following lines in Quick CSS in Enfold theme options under General Styling tab

    Code:
    @media only screen and (max-width: 767px) {
    .flex_column { width: 100% !important; margin-left: 0; }}

    I am afraid i am not a CSS specialist and I am not sure how exactly this will affect the theme, so you should better contact again the theme developers again and ask them for advice how exactly should be done and what will be the effect.

    Thank you for your help fixing this existing issue.

    #637515

    Hi,

    There are 2 mobile layouts of your site

    1. When you re-size the browser on desktop it looks like the screenshot i have attached earlier.
    2. When you view the site on an actual mobile device it looks different.

    I am assuming you want the mobile version of the site to look like the screenshot(desktop style) when viewed on an actual mobile right?

    The code is not the issue but you are using a plugin which is overriding the default styles.

    To find which plugin is overriding the default theme styles please follow these steps:

    1. Go to your plugins page > Deactivate all active Plugins
    2. Update WordPress and Enfold to latest version if you have not.
    3. Make sure all the plugins are updated.
    4. If the problem does not persist when plugins are turned off, activate one plugin at a time and refresh until you find the plugin in conflict.

    We await the results of your plugin compatibility test.

    Thanks for your cooperation :)

    Best regards,
    Vinay

    #639367

    Hi Vinay,

    It looks like the issue has been resolved, but I did not go in and modify anything. I’m guessing that someone from your company did, because now all of my plugins are activated instead of Jetpack. Is this a Jetpack issue? I would really like to have that plugin activated, since it is the most central plugin to any WordPress site. Please advise.

    #640086

    Hi,

    We accessed the site but we didn’t do anything to it because the issue is not related to the theme. It switches to a different theme on mobile view.

    Best regards,
    Ismael

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.