Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #254013

    I was very disappointed when i updated to latest enfold and latest wp (3.9) because the text-editor of the visual composer is now creating messy code. Before it was beautiful, structured and didnt add weird tags. Now it mushes my nice clean code into a mess, adds p tags randomly, and i have to clean it up to make sense of it. This is awful!! Please fix. I initially switched form Nevada to Enfold, because nevada would do this, but if enfold starts messing up code, i will have to find a new theme to work with. Please advise!!

    What im referencing is the “text block” element in avia layout builder. When i close the text block, it adds br tags, p tags and messes up the structure terribly!

    #254407

    Hey fandragon!

    Can you post the link to your website and point out the issue so we can take a look?

    Cheers!
    Yigit

    #254604

    the issue is on the backend. Not visible in front end, but it affects the development of the site. I attached some screenshots of how it was before and how it is now.

    Before:
    Here is a screenshot how it was before the update. Nice and clean code, nice paragraphs, easy to see, easy to edit, no junky code
    http://i58.tinypic.com/fkv78w.png

    After:
    And this is the same page after the update. Notice the mushy awful code, hard to find stuff and edit and its stuffed with unnecessary code, all messed up. This slows down development significantly if i have to clean up these messes every time, and every time i click save it mushes it up back again.
    http://i62.tinypic.com/11rwv7k.png

    Any ideas why this is happening? And i did disable all plugins, and its still doing it. This is happening with wp3.9 and newest Enfold.

    #255385

    Hi!

    I’ll mark the thread for Kriesi. Afaik we didn’t change the textblock code but maybe the new TinyMCE version adds these tags.

    Cheers!
    Peter

    #255712

    Is there a way to get rid of that? It is really really bothersome and time consuming to clean them up …
    One of the reasons i love Enfold was because it wouldnt add junk code and was nice and clean : )

    #256946

    Hey!

    Tbh I’m not even sure what causes this issue. Thus I want to wait for Kriesi’s feedback before we try to “fix” something. Please create us an admin account and post the login credentials as private reply. Also proviide a link to a post/page where Kriesi can reproduce the issue.

    Regards,
    Peter

    #257302

    Hi!

    found a fix for the issue, next update will include that ;)

    Cheers!
    Kriesi

Viewing 7 posts - 1 through 7 (of 7 total)

The topic ‘The text editor block not working correctly’ is closed to new replies.