Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #1079453

    Hi, I have three sites using The Events Calendar Pro. On two sites, when you squash the display (to force mobile view), the map on the single event page vanishes.
    I have disabled all plugins and it still happens.
    I have enabled twenty sixteen and there is no issue.
    I can not figure out why one of the sites is working OK but the other two are not.
    More info in private:

    #1081062

    Hey H,

    Enfold displays two different event meta bar, one for desktop and one for mobile. There is no error in console but div, which should have Google maps code inside, is empty on mobile version of meta bar.

    Could you please create temporary admin login for one of the sites where Google maps does not load and share it with us privately?

    Best regards,
    Yigit

    #1084876

    Hi Yigit

    Please see login details below:

    Many thanks,

    #1085483

    Hi H,

    Thanks for the info!

    I am seeing error due to Google maps in console – https://developers.google.com/maps/documentation/javascript/error-messages# (Purchase code hidden if logged out) . I see that you have inserted Google maps API key in Enfold theme options. Could you please enable it on your staging site as well?

    Best regards,
    Yigit

    #1086271

    Hi Yigit,
    Sorry about that, I thought I had a wildcard on that domain but I had entered */ instead of *.
    Please can you take a look now?

    Many thanks,
    H

    #1086862

    Hi H,

    I have checked on your site and it seems to be working properly now.
    I have posted a screenshot in private content.

    Best regards,
    Nikko

    #1087182

    @nikko,

    Hi, my problem was not this. My event maps do not show on mobile but Yigit could not do anything as the MAP API was not applied to my staging site. My reply was merely to state that I had enabled the API key. So @yigit can now look at the issue of the map not showing on single events on mobile ;)
    Please see the original post.
    Hope this helps,
    H

    #1088120

    Hi H,

    I see, I have tested it out and also could not figure why this is happening.
    There are no js errors but the mobile map isn’t rendering as it should and just leave an empty space.
    I’ll ask my colleagues to take a look at it as well.

    Best regards,
    Nikko

    #1089261

    @nikko,

    Thanks Nikko, it is a strange one for sure, given I have 3 sites. 1 is OK and the other two do not display the map :/
    I look forward to your reply.

    #1090956

    Hi H,

    Could you please share FTP logins of your staging site as well?

    Cheers!
    Yigit

    #1092470

    Of course, see Private.

    #1093655

    Hi H,

    We have updated Enfold to the latest version* which has events related fix included but it did not help.
    Also checked if loading multiple maps was the issue but that does not seem to be the case either.

    I contacted The Events Calendar team and asked if they have any insights.

    We will keep you updated :)

    Best regards,
    Yigit

Viewing 12 posts - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.