Tagged: 

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #1127926

    Hello,
    We’ve followed your upload Google fonts documentation. The font displays but is now suddenly displaying as italics across the site. Also see sub menus displaying in italics too now.

    General Styling > Heading Font > Merriweather Sans (300, 400, 700, 800)
    General Styling > Font for your body text > Libre Franklin (100, 200, 300, 400, 500, 600, 700, 800, 900)

    Advanced styling > Main Menu Links > Merriweather Sans (300, 400, 700, 800)
    Text transform = Default
    Letter spacing = Default
    Font weight = Default

    Quick CSS (Nothing relates to italics)

    .avia-bullet { display: none !important; }
    .js_active .toggler {padding-right: 60px !important; }
    #advanced_menu_toggle, #advanced_menu_hide {visibility: hidden !important;}

    No extra font code added in functions.php

    <?php
    add_filter('avf_title_args', 'fix_single_post_title', 10, 2);
    function fix_single_post_title($args,$id)
    {
        if ( is_singular('post') )
        {
            $args['title'] = get_the_title($id);
            $args['link'] = get_permalink($id);
            $args['heading'] = 'h1';
        }
    
        return $args;
    }
    // [Feedzy Horizontal]
    function bweb_horizontal_layout( $content, $feedURL ) {
    	return '<div class="feedzy-horizontal">' . $content . '</div>';
    }
    add_filter( 'feedzy_global_output', 'bweb_horizontal_layout', 9, 2 );
    #1128571

    Hey Julie,
    Sorry for the late reply, thanks for the login. I took a look at your page and see italics, but everywhere I look in the backend I also see manually entered

    <em>

    , such as the Team Member Description & Accordion Toggles, so I’m not sure where you see the error and have a italics you do not want. Please advise. One possibility is that you have an open italics tag somewhere that is affecting the regular text.

    Best regards,
    Mike

    #1129025

    Hi again,
    We swept the site and found not open EM tags. On top of that we swapped out the Google font for a standard font and refreshed server cache. When we removed the Google Fonts selection, the body content displayed correctly (no italics) However, italics was found in places where the EM tag doesn’t exist. Here are some examples:
    MAIN MENU > Sub menu items
    FOOTER Widgets

    If you flip back to the standard font (not Google font), the main menu sub menu items are still in italics.

    #1129121

    Hi,
    Thank you for explaining, so I examined the sub menu items and found that there was no css causing the italics and the browser listed the text as font style as “normal”
    If I changed the font in your advanced styles to another built-in font the error didn’t occur, after I cleared my cache.
    I downloaded the font zip from your media library and tested on my localhost, and the error occurred for me also.
    But I could not find a reason for this, I do note that the advanced styling doesn’t give the option to choose a font style for the “main menu”.
    I tried deleting the italic font files from the zip file and then imported it again and this time the error didn’t occur. I then tested adding the “em” tag and also tested using “font-style: italic;” css, both of which displayed italics.
    So it seems that the italic font files are not needed to display italic, but for some reason, the files are causing an error.

    Please give this a try, and let us know if it helps.

    Best regards,
    Mike

    #1129261

    That worked! Thanks for the solution Mike.

    #1129347

    Hi welswebmaster,

    Glad you got it working for you! :)

    If you need further assistance please let us know.

    Best regards,
    Victoria

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.